Download it now!
Bug 82500 - Operators missing in Standard Filter
Summary: Operators missing in Standard Filter
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
4.3.0.0.alpha0+ Master
Hardware: All All
: medium normal
Assignee: Julien Nabet
URL:
Whiteboard: target:4.4.0 target:4.3.4
Keywords: bibisectRequest, regression
: 85928 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-08-12 09:44 UTC by hc.stoellinger
Modified: 2015-12-17 08:29 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description hc.stoellinger 2014-08-12 09:44:21 UTC
In the standard filter of LO-Base 4.3.3.1 I miss the operators <= and >= (less and greater than). They were present in all previous versions. Is this intentional?
Comment 1 Robert Großkopf 2014-08-12 19:03:23 UTC
I can confirm this for LO 4.3.0.0alpha0 and all other 4.3-versions up to 4.3.0.4. In the standard filter of tables and queries appear "=" three times. ">=" and "<=" have been changed to "=".

My system: OpenSUSE 12.3 64bit rpm Linux.
Comment 2 Julien Nabet 2014-11-09 22:17:05 UTC
*** Bug 85928 has been marked as a duplicate of this bug. ***
Comment 3 Julien Nabet 2014-11-09 22:30:19 UTC
I think it's a regression from http://cgit.freedesktop.org/libreoffice/core/commit/?id=be88126e80b1f6b9a3090ba4617d9a87dfb0a0bd
I'm testing a patch right now.
Comment 4 Julien Nabet 2014-11-09 22:31:09 UTC
It concerns all platforms.
Comment 5 Commit Notification 2014-11-09 23:23:44 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=3d16e8593ac1e9d90f0a033732766907476822f9

Resolves fdo#82500: Operators missing in Standard Filter

It will be available in 4.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 6 Julien Nabet 2014-11-09 23:26:23 UTC
Gerrit review for 4.3:
https://gerrit.libreoffice.org/12328
Comment 7 Commit Notification 2014-11-10 16:24:55 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "libreoffice-4-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=4188f610144bc88e7fbc5a7aee174a4d760f3f51&h=libreoffice-4-3

Resolves fdo#82500: Operators missing in Standard Filter

It will be available in 4.3.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 8 Tony Bowyer 2014-12-15 00:24:03 UTC
I have 4.3.4.1 and still have this issue where I can't do GreaterThan/Equals or LessThan/Equals conditions.

Latest comments said it should have been fixed in this version.  Which version is it going to be in?
Comment 9 Julien Nabet 2014-12-15 06:29:40 UTC
Tony: it should be ok from 4.3.4, could you attach a screenshot by using this link https://bugs.freedesktop.org/attachment.cgi?bugid=82500&action=enter ?
Comment 10 Tony Bowyer 2014-12-18 21:34:58 UTC
Looks like it has just been fixed in 4.3.5

Thanks.
Comment 11 Robinson Tryon (qubit) 2015-12-17 08:29:52 UTC
Migrating Whiteboard tags to Keywords: (bibisectRequest)
[NinjaEdit]