Bug 82520 - Other: Text not rotated in SVG export of chart
Summary: Other: Text not rotated in SVG export of chart
Status: RESOLVED DUPLICATE of bug 57215
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.4.2 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2014-08-12 17:59 UTC by fred.lovine
Modified: 2015-05-29 15:25 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Sample spreadsheet document containing a chart (21.60 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-08-12 17:59 UTC, fred.lovine
Details
SVG export of chart (8.30 KB, image/svg+xml)
2014-08-12 18:01 UTC, fred.lovine
Details
original drawing (23.38 KB, application/vnd.oasis.opendocument.graphics)
2014-09-02 11:21 UTC, klaus.welch
Details
original drawing as pdf (8.33 KB, application/pdf)
2014-09-02 11:22 UTC, klaus.welch
Details
original drawing exported as svg (9.94 KB, image/svg+xml)
2014-09-02 11:23 UTC, klaus.welch
Details
original drawing exported as wmf (4.96 KB, image/x-wmf)
2014-09-02 11:23 UTC, klaus.welch
Details
writer document importing svg and wmf export (29.36 KB, application/vnd.oasis.opendocument.text)
2014-09-02 11:24 UTC, klaus.welch
Details
writer document exported as pdf (198.24 KB, application/pdf)
2014-09-02 11:24 UTC, klaus.welch
Details

Note You need to log in before you can comment on or make changes to this bug.
Description fred.lovine 2014-08-12 17:59:47 UTC
Created attachment 104515 [details]
Sample spreadsheet document containing a chart

Problem description: Export of chart to SVG does not display vertical text.

Steps to reproduce:
1. Create chart with Y axis title (text should be vertical)
2. Right click on chart, select "Export as Image"
3. Save in SVG format.
4. Open SVG file in web browser.

Current behavior:
Y axis title is horizontal.

Expected behavior:
Y axis title should be vertical.
              
Operating System: Windows 7
Version: 4.2.4.2 release
Comment 1 fred.lovine 2014-08-12 18:01:17 UTC
Created attachment 104516 [details]
SVG export of chart
Comment 2 fred.lovine 2014-08-12 18:07:19 UTC
Run the test.svg file through http://validator.w3.org/check. The result is:

Error Line 62, Column 176: there is no attribute "transform"
…tPosition" x="837" y="4770" transform="translate(837,4770) rotate(-90) transla…

It appears that the "transform" attribute is not valid on a <tspan> element, and should instead be on the <text> element.
Comment 3 klaus.welch 2014-09-02 11:20:35 UTC
I've the same issue when exporting a drawing containing vertical text (either as plain text or as a text attached to e.g. a line).

I've attached a testcase:
 * original drawing (testcase.odg)
 * pdf-export of original drawing (testcase_odg.pdf)
 * svg-export of original drawing (testcase.svg)
 * wmf-export of original drawing (testcase.wmf)
 * write-document importing testcase.svg and testcase.wmf (testcase.odt)
 * pdf-export of imported drawings (testcase_odt.pdf)


Operating system: RHEL5.6
Version: 4.3.1.2
Comment 4 klaus.welch 2014-09-02 11:21:36 UTC
Created attachment 105591 [details]
original drawing
Comment 5 klaus.welch 2014-09-02 11:22:04 UTC
Created attachment 105592 [details]
original drawing as pdf
Comment 6 klaus.welch 2014-09-02 11:23:05 UTC
Created attachment 105593 [details]
original drawing exported as svg
Comment 7 klaus.welch 2014-09-02 11:23:28 UTC
Created attachment 105594 [details]
original drawing exported as wmf
Comment 8 klaus.welch 2014-09-02 11:24:05 UTC
Created attachment 105595 [details]
writer document importing svg and wmf export
Comment 9 klaus.welch 2014-09-02 11:24:39 UTC
Created attachment 105596 [details]
writer document exported as pdf
Comment 10 Jacques Guilleron 2014-09-02 21:09:34 UTC
Hi Fred, Klaus,

Thanks to you for your report. However, this was previously reported. See Bug 57215 - Wrong text rotation in SVG Export (rotated text appears as non-rotated).
leave a comment in this bug if you think it necessary.

Regards,

Jacques

*** This bug has been marked as a duplicate of bug 57215 ***