Bug 82570 - Default Shortcuts not Reachable on Different Keyboard Layouts
Summary: Default Shortcuts not Reachable on Different Keyboard Layouts
Status: RESOLVED DUPLICATE of bug 82117
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Localization (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks: Shortcuts-Locale
  Show dependency treegraph
 
Reported: 2014-08-13 15:32 UTC by Harald Koester
Modified: 2017-04-25 15:39 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
List with proposals of new default shortcuts for German keyboard layout. (17.18 KB, application/vnd.oasis.opendocument.text)
2017-04-25 13:17 UTC, Harald Koester
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Harald Koester 2014-08-13 15:32:47 UTC
Problem description: 

The problem arose when I tried to use the new Calc function (version 4.3.0) “Fill Single Edit” (In the release notes the function is called “Start cell edit with content of cell above”.) with a keyboard with a German layout. The default short cut is “Alt+' “. With a German keyboard the character “ ' “ is only reachable via the Shift key. Hence the shortcut “Alt+' “ is not possible. 

Then I checked if there are more default shortcuts which are not reachable on a German keyboard in the Customize dialogue. I found these:
For Writer: “Strg+[“, “Strg+]“, “Strg+*“, “Strg+/“
For Calc: “Strg+;“, “Strg+' “, “Strg+[“, “Strg+]“, “Strg+*“, “Strg+/“, “Strg+Umschalt+;”, 
For Impress: “Strg+[“, “Strg+]“, “Strg+/“
For Draw: “Strg+[“, “Strg+]“, “Strg+/“
Hint: “Strg” on a german keyboard is identical to “Ctrl” and “Umschalt” to “Shift”.

I am sure that there are similar problems with keyboard layouts of other languages. Besides shortcuts with special characters also shortcuts with “Alt+Ctrl+...” are problematic. On several keyboard layouts these shortcuts (Alt+Ctrl+...) are used to insert special characters. See also bug 38891, bug 36377, bug 36588.

Expected behaviour: 
At least the default shortcuts should always be reachable with the particular keyboard layout. That may imply that there are different default shortcuts for the same function with different keyboard layouts. Or generally problematic default shortcuts (with special characters or with “Alt+Ctrl+...”) should not be used any more. 

Furthermore it would be good, if it is not possible to assign a function to a shortcut that is not reachable with the particular keyboard in the Customize dialogue.


              
Operating System: Windows 7
Version: 4.3.0.4 release
Comment 1 Andras Timar 2014-08-28 15:26:08 UTC
There are more functions, than available keyboard shortcuts. If you take the time to clean up the shortcuts for German, then modifications are possible, because shortcuts are localizable. See http://opengrok.libreoffice.org/xref/core/officecfg/registry/data/org/openoffice/Office/Accelerators.xcu
Comment 2 Harald Koester 2014-12-03 13:16:43 UTC
Bug 82117 has been written with the same intention.
Comment 3 Hanan Sela 2015-04-21 19:09:56 UTC
The same problem in Hebrew, can not use ctrl short-cuts when the keyboard layout is Hebrew. Even not the general ctrl+c ctrl+v etc. This problem was not present in older versions <4. In Ubuntu 14.04, removing the LO-genome package solved the problem but then LO behave, look and feel like old fashion.
Comment 4 QA Administrators 2016-09-20 09:33:09 UTC Comment hidden (obsolete)
Comment 5 Harald Koester 2016-09-23 17:34:02 UTC
Bug still exists in version 5.2.1 with Win7.
Bug exists already with some of the shortcuts in version 3.3.0. Hence inherited from OOo.
Comment 6 Yousuf Philips (jay) (retired) 2017-04-18 14:41:25 UTC
Hi Harald,

In order to move this forward, please provide a list of the incorrectly assigned commands and their german shortcuts and what they should be changed to. Please check other office suites to see what they use for the same command shortcuts. I've instructed the bug report in bug 82117 to do the same, so maybe these to bugs should be consolidated.

(In reply to Hanan Sela from comment #3)
> The same problem in Hebrew, can not use ctrl short-cuts when the keyboard
> layout is Hebrew. Even not the general ctrl+c ctrl+v etc. This problem was
> not present in older versions <4. In Ubuntu 14.04, removing the LO-genome
> package solved the problem but then LO behave, look and feel like old
> fashion.

Hi Hana,

Please open a new bug about this issue, so it can be addressed for problems with Hebrew shortcuts.
Comment 7 Harald Koester 2017-04-25 13:17:40 UTC
Created attachment 132830 [details]
List with proposals of new default shortcuts for German keyboard layout.
Comment 8 Yousuf Philips (jay) (retired) 2017-04-25 15:39:11 UTC
Thanks for the document Harald. I'm going to close this bug as a duplicate of the other bug so all efforts to improve german shorts are in one place.

(In reply to Hanan Sela from comment #3)
> The same problem in Hebrew, can not use ctrl short-cuts when the keyboard
> layout is Hebrew. Even not the general ctrl+c ctrl+v etc. This problem was
> not present in older versions <4. In Ubuntu 14.04, removing the LO-genome
> package solved the problem but then LO behave, look and feel like old
> fashion.

Hi Hana,

Please open a new bug about this issue, so it can be addressed for problems with Hebrew shortcuts.

*** This bug has been marked as a duplicate of bug 82117 ***