Bug 82656 - VIEWING: Stains on slides in slides pane
Summary: VIEWING: Stains on slides in slides pane
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.3.0.4 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
: 88074 (view as bug list)
Depends on:
Blocks: Slide-Page-Pane
  Show dependency treegraph
 
Reported: 2014-08-15 09:15 UTC by E Moen
Modified: 2019-03-28 11:28 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Picture that shows (with red arrow) the black blob (79.61 KB, image/png)
2014-08-15 09:15 UTC, E Moen
Details
File with the bug showing (589.98 KB, application/vnd.oasis.opendocument.presentation)
2014-08-16 15:18 UTC, E Moen
Details
Another odp file with the stain problem (108.08 KB, application/vnd.oasis.opendocument.presentation)
2014-08-17 08:09 UTC, E Moen
Details
Screenshot with the stain before removing an object (151.24 KB, image/png)
2014-08-17 08:11 UTC, E Moen
Details
Screenshot with the stain after removing an object (136.74 KB, image/png)
2014-08-17 08:12 UTC, E Moen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description E Moen 2014-08-15 09:15:15 UTC
Created attachment 104662 [details]
Picture that shows (with red arrow) the black blob

Slides in the slides pane show black blobs. This happens on several slides in the pane. No apparent reason: i.e. no specific item on a slide to blame.
Operating System: Windows 7
Version: 4.3.0.4 release
Comment 1 tommy27 2014-08-16 12:49:07 UTC
please attach the corresponding presentation file as well so we can test and debug
Comment 2 E Moen 2014-08-16 15:18:15 UTC
Created attachment 104738 [details]
File with the bug showing
Comment 3 Jacques Guilleron 2014-08-16 17:23:55 UTC
Hi,

I could not reproduce with 
LO 4.3.0.4, 
LO 4.4.0.0.alpha0+
Build ID: eddd7646d672ea9b0561dacb09da224d098e531e
TinderBox: Win-x86@39, Branch:master, Time: 2014-07-18_06:42:50
and LO 4.2.7.0.0+
Build ID: 92216be6ce13990b8ea6b6264c656d2bc1746401
TinderBox: Win-x86@42, Branch:libreoffice-4-2, Time: 2014-07-14_16:21:42

Windows 7 Home Premium.

Is it the first time you encounter this issue? 
Did you try a new profile? > https://wiki.documentfoundation.org/UserProfile

Regards,

Jacques
Comment 4 E Moen 2014-08-17 08:09:57 UTC
Created attachment 104752 [details]
Another odp file with the stain problem
Comment 5 E Moen 2014-08-17 08:11:15 UTC
Created attachment 104753 [details]
Screenshot with the stain before removing an object
Comment 6 E Moen 2014-08-17 08:12:04 UTC
Created attachment 104754 [details]
Screenshot with the stain after removing an object
Comment 7 E Moen 2014-08-17 08:13:48 UTC
Hi,

This is not the first time I had this issue. I do not recall exactly when I first encountered it but I think I also saw this in the first 4-release I used (4.0...). This was on another computer (Windows 64 Home Premium).

I have tried the profile thing. I renamed my profile and let LO generate a fresh one. Made no difference.

My experience is that once the stains show, they're persistently there.

I have attached three new files:
- Example odp with one slide that also shows a black stain (in the slide pane)
- Impress Screenshot with that file loaded without any changes
- Impress Sceenshot with after removing an object (changing the stain)

Hope this helps some...

Regards,

E Moen
Comment 8 Jacques Guilleron 2014-08-17 16:01:27 UTC
Thank you very much for those useful infos.
As far i can see, it seems that affects only slides with Bullets.
Can you confirm?

Can you see also if in Options > LibreOffice > View how this issue move when you uncheck 
Use hardware acceleration
or 
Use Anti-Aliasing

Thanks,

Jacques
Comment 9 E Moen 2014-08-18 07:48:38 UTC
Hello,

You are right about the bullits! Removing them makes the stains disappear. I noticed also that it only happens when the body of the slide contains a text box starting with a bullit. If the text box starts with a sentence (or just one word), there is no problem. 

As far as Hardware acceleration and Anti aliasing are concerned:
- Hardware Acceleration makes no difference (seperately and combined with anti aliasing)
- Anti aliasing only slightly changed te shape of the stains (done by removing and reintroducing the bullits in the slide). I guess this was to be expected as drawing images should change with this setting.


Thanks again and success!

Regards,

E Moen
Comment 10 E Moen 2014-08-18 19:44:42 UTC
Hi,

I need to add a comment because the previous comment is not entirely correct. I mentioned that when a text box does not start with a bullit, there are no stains. This is only partly correct. When a slide already contains the stains, removing the first bullit (or adding words before the bullits) does not solve the problem. However the are slides in my presentation whith text boxes not starting with bullits (but containing bullits from the second line down) that do not show the stains.

Regards,

E Moen
Comment 11 Owen Genat (retired) 2014-10-11 12:58:09 UTC
(In reply to Jacques Guilleron from comment #8)
> As far i can see, it seems that affects only slides with Bullets.

Well spotted. The "stain" seems to be a series of enlarged bullet points. It may be related to the use of Black Circle (U+25CF) in the text:list-level-style-bullet element, although this has been in use since v3.3.4.1. Not reproducible under GNU/Linux, so perhaps a font-related rendering issue under Windows?
Comment 12 Jacques Guilleron 2014-10-15 13:58:08 UTC
@ Owen: Yes, enlarged character U+25CF or... not reduced when making thumbnail, because we don't see that in the normal view. 
The proportions seem befit. 
But this behaviour is not confirmed by anyone.

@ E Moen: Did you try a recent version?

Jacques
Comment 13 E Moen 2014-10-15 14:09:07 UTC
(In reply to Jacques Guilleron from comment #12)
> @ Owen: Yes, enlarged character U+25CF or... not reduced when making
> thumbnail, because we don't see that in the normal view. 
> The proportions seem befit. 
> But this behaviour is not confirmed by anyone.
> 
> @ E Moen: Did you try a recent version?
> 
> Jacques

Jacques,

Yes I did. Currently I'm on:

Versie: 4.3.2.2 
Build ID: edfb5295ba211bd31ad47d0bad0118690f76407d

This version also shows the bullit stains.

Regards,

E. Moen
Comment 14 E Moen 2014-10-18 08:39:39 UTC
Hi,

Asked to do a backtrace on version 4.3.3 RC1, I noticed that the bullit related stains are still there.

Regards,

Egbert
Comment 15 A (Andy) 2014-10-25 07:30:35 UTC
Reproducible with LO 4.3.2.2 (Win 8.1)

Steps to Reproduce:
1. Open IMPRESS and create a new presentation
2. Write "Test" in the main text area
3. Select the word "Test"
4. Go to FORMAT -> BULLETS AND NUMBERING -> tab BULLETS
5. Select any bullet option except Solid Diamond Bullets and Solid Large Square Bullets (the two in the upper right)
6. Go to FORMAT -> CHARACTER -> tab FONTS
7. Change the font size to a value of 15 or below
8. Click outside of the main text area

Result:
The selected bullets will be shown as very large bullets a bit above the text line in the slides pane on the left. 
This happens only if the font size is 15 or below, otherwise it is not reproducible.  Furthermore, it is not reproducible with the two bullet types from step 5.  With all the other bullet types it is reproducible.
Comment 16 A (Andy) 2015-04-03 19:21:59 UTC
*** Bug 88074 has been marked as a duplicate of this bug. ***
Comment 17 tommy27 2016-04-16 07:24:34 UTC Comment hidden (obsolete)
Comment 18 QA Administrators 2017-05-22 13:25:39 UTC Comment hidden (obsolete)
Comment 19 Roman Kuznetsov 2019-03-28 11:28:16 UTC
don't repro in

Version: 6.3.0.0.alpha0+ (x64)
Build ID: 5cb2db6dd7d234a610a6501668a9901af8472b7f
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2019-03-26_23:06:31
Locale: ru-RU (ru_RU); UI-Language: en-US
Calc: threaded

WFM