Bug 82707 - STATUSBAR: Unify click behaviour
Summary: STATUSBAR: Unify click behaviour
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard: target:4.4.0 target:5.4.0
Keywords:
Depends on: 105669
Blocks: Statusbar
  Show dependency treegraph
 
Reported: 2014-08-16 18:08 UTC by Yousuf Philips (jay)
Modified: 2017-11-05 21:46 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) 2014-08-16 18:08:06 UTC
In Writer, there are 12 sections in the statusbar:

1) page number
2) word count
3) page style
4) character language
5) edit mode
6) selection style
7) document modify status
8) digital signature
9) insert field
10) page view style (1 page, 2 page, book)
11) zoom slider (zoom out, slider, zoom in)
12) zoom percentage

Of these entries, 8 entries have double click functionality (5 of which only function with double click), 5 entries have right-click context menus (2 of which left-click also opens the context menu), and 2 function with the left or right click (numbers 10 and 11). Below is the list with their click functionality:

1) page number - dbl click dlg
2) word count - dbl click dlg
3) page style - dbl click dlg, right context menu
4) character language - left/right context menu
5) edit mode - dbl click (overwrite mode), single click (insert mode)
6) selection style - left/right context menu
7) document modify status - dbl click save
8) digital signature - dbl click dlg, right context menu
9) insert field - dbl click dlg
10) page view style - left/right click
11) zoom slider - left/right click
12) zoom percentage - dbl click dlg, right context menu

To fix this setup, i'd like to suggest that one of the following approaches be used to unify the behaviour.

1) single click context menu, double click dialog/action - with this behaviour, single left or right click only brings up the context menu, if there is one, and double click is left for the opening of dialogs and execution of actions (change edit mode, save document).

2) single click context menu, single click dialog/action - this behaviour has entries with a context menu open context menus on single left or right click and open dialogs on double click, while entries that only have double click dialog/action also function with a single left or right click.

3) left click dialog/action, right click context menu - this behaviour isnt departing much from how it is presently and only adds that when an entry has a double click dialog/action, that a single left click also acts like a double click and context menus only appear with right-click.
Comment 1 Owen Genat (retired) 2014-08-18 11:36:42 UTC
(In reply to comment #0)
> 2) single click context menu, single click dialog/action - this behaviour
> has entries with a context menu open context menus on single left or right
> click and open dialogs on double click, while entries that only have double
> click dialog/action also function with a single left or right click.

I vote for this option, because any double-click in any UI is IMO one click too many.
Comment 2 Adolfo Jayme 2014-10-26 16:38:10 UTC
+1
Comment 3 Yousuf Philips (jay) 2014-10-26 17:55:51 UTC
(In reply to Adolfo Jayme from comment #2)
> +1

So which of the three solutions do you like?
Comment 4 Adolfo Jayme 2014-10-26 19:23:15 UTC
(In reply to Jay Philips from comment #3) 
> So which of the three solutions do you like?

Sorry for not being clear. I think 2) is simpler, so I’d vote for it, as Owen did.
Comment 5 A (Andy) 2014-10-31 19:04:40 UTC
I would also prefer 2)
Comment 6 Commit Notification 2014-11-09 16:22:44 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=0280a35b20448b7f678b6e150cbc2564da4910ce

fdo#82707 Unify click behavior in Statusbar (Writer)

It will be available in 4.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 7 Samuel Mehrbrodt (CIB) 2014-11-09 16:26:38 UTC
We discussed this in the IRC and agreed that #3 is a better option. Double click actions just seem wrong for the statusbar.

Adolfo, Andy, are you ok with this?
Comment 8 Yousuf Philips (jay) 2014-11-09 16:29:02 UTC
Yes we had discussed this in the IRC and we felt it would be best to have left clicking buttons and right clicking for context menus. Any thoughts, Owen, Adolfo, Andy?
Comment 9 Miklos Vajna 2014-11-09 17:31:29 UTC
FWIW, this change broke CppunitTest_sw_mailmerge, see e.g. http://tinderbox.libreoffice.org/cgi-bin/gunzip.cgi?tree=MASTER&brief-log=1415551201.32129
Comment 10 Samuel Mehrbrodt (CIB) 2014-11-09 18:22:03 UTC
I couldn't reproduce the failure locally, but pushed something that hopefully fixes it: http://cgit.freedesktop.org/libreoffice/core/commit/?id=123e49d6e307c41a5f59878335563ad7203b23ff
Comment 11 Miklos Vajna 2014-11-09 21:07:41 UTC
Maybe you had a --disable-dbgutil build (default) and the problem was specific to --enable-dbgutil? Just guessing.

The fix helped, thanks for the quick reaction!
Comment 12 Adolfo Jayme 2014-11-09 22:50:53 UTC
> We discussed this in the IRC

It’s fine for me, but I have a question...

Why did you “privately” settled on something without trying to reach with the rest of people involved, by using more open spaces, such as this bug or the UX-Advise list? Remember that not everyone has the time to be on IRC...

Well, whatever. Now, the status bar items should visually react on mouse hover.
Comment 13 Yousuf Philips (jay) 2014-11-15 00:07:59 UTC
It would be great if we could disable the left-click on the character language and selection style sections to completely unify the behaviour.
Comment 14 Mike §chinagl 2014-12-20 22:05:49 UTC
This bug fix comes with LibreOffice 4.4 (release notes https://wiki.documentfoundation.org/ReleaseNotes/4.4) 


Click behaviour was unified so that left-click results in an action or dialog appearing and right-click results in the display of a context menu.


Status should be changed, I think
Comment 15 Mike §chinagl 2015-01-22 10:44:51 UTC
The status of the bug should be changed by competent people.
Comment 16 V Stuart Foote 2015-01-22 13:12:34 UTC
Looks like the issue of comment 13 is still outstanding, suppressing left click opening of context menu for 4 & 6 (character language, selection style).

Samuel, Jay are you still poking at it?
Comment 17 Yousuf Philips (jay) 2015-01-25 12:44:34 UTC
Samuel was poking at this, but he hasnt been around in a while.
Comment 18 Samuel Mehrbrodt (CIB) 2015-01-26 10:56:51 UTC
I'm opening this task for others as I don't have any time to devote to LO currently, sorry.
Comment 19 Commit Notification 2017-02-02 02:12:55 UTC
Adolfo Jayme Barrientos committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=5f33745c1d6750126e53a02b2a95355a3e5b16a0

tdf#105669 tdf#82707 A single click in the status bar is now enough

It will be available in 5.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 20 Thomas Lendo 2017-06-01 20:10:03 UTC
Is it intended that a right-click on Single-page view/Multiple-page view/Book view does the same action as a left-click?

I would assume that a right-click opens a context menu. If there is no context menu, then no action should be started. Actions after right-clicks are a little bit scary.
Comment 21 Xisco Faulí 2017-11-05 21:46:50 UTC
A polite ping to Adolfo Jayme Barrientos: is this bug fixed? if so, could you please close it as RESOLVED FIXED ? Thanks