Bug 82708 - STATUSBAR: Missing tooltips
Summary: STATUSBAR: Missing tooltips
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium enhancement
Assignee: Samuel Mehrbrodt (CIB)
QA Contact:
URL:
Whiteboard: target:4.4.0
Keywords:
: 74501 84830 (view as bug list)
Depends on:
Blocks: Statusbar
  Show dependency treegraph
 
Reported: 2014-08-16 18:29 UTC by Yousuf Philips (jay)
Modified: 2015-09-10 14:50 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) 2014-08-16 18:29:10 UTC
In Writer, there are 12 sections in the statusbar:

1) page number
2) word count
3) page style
4) character language
5) edit mode
6) selection style
7) document modify status
8) digital signature
9) insert field
10) page view style (1 page, 2 page, book)
11) zoom slider (zoom out, slider, zoom in)
12) zoom percentage

Of the 12 sections in the statusbar, only 4 entries have tooltips (numbers 5 to 8). Here are suggestions for tooltips for the missing 8 sections.

1) "Page Number / Total Pages. Double-click to open navigator dialog"
2) "Word & Character Count. Double-click to open dialog"
3) "Page Style. Right-click to change style and double-click to modify style"
4) "Character Language. Click to set character or paragraph language"
9) "Insert Field. Double-click to open dialog"
10) "Page View - One", "Page View - Two", "Page View - Book"
11) "Zoom Out", "Click or drag slider to change zoom level", "Zoom In"
12) "Zoom Level. Right-click for context menu and double-click for dialog"

These suggestions may need to be adjusted if one of the suggestions in bug 82707 are taken.
Comment 1 Olivier R. 2014-08-26 13:44:30 UTC
I agree with this.
Comment 2 Yousuf Philips (jay) 2014-08-26 14:25:33 UTC
Here are tooltips from IBM Symphony.

 1) Page Number : [page number text]
 3) Page Style: [page style name]
 5) Insert Mode: [mode name]
 6) Selection Mode: [selection mode]
10) View Layout: One Column, View Layout: Two Columns, View Layout: Book Preview
12) Zoom: [zoom percentage]
Comment 3 Yousuf Philips (jay) 2014-11-09 16:45:07 UTC
*** Bug 84830 has been marked as a duplicate of this bug. ***
Comment 4 Yousuf Philips (jay) 2014-11-11 21:44:07 UTC
Samuel put in the patch for this - http://cgit.freedesktop.org/libreoffice/core/commit/?id=355770eff40acc07e9cd46fa4dcfb39e6a86166e
Comment 5 Yousuf Philips (jay) 2014-11-14 22:18:14 UTC
All look good except for page number, which doesnt have a tooltip when you create a new document. :D
Comment 6 Yousuf Philips (jay) 2014-11-15 00:24:31 UTC
(In reply to Jay Philips from comment #5)
> All look good except for page number, which doesnt have a tooltip when you
> create a new document. :D

This was to state that the tooltips worked. :D

I went over the tooltip texts and submitted a patch - https://gerrit.libreoffice.org/#/c/12433/
Comment 7 Commit Notification 2014-11-18 09:29:05 UTC
Yousuf Philips committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=62155d261117f1f99c9e494b17286012d9e6908e

fdo#82708 editing statusbar tooltip texts

It will be available in 4.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 8 Mike §chinagl 2014-12-20 22:06:51 UTC
This bug fix comes with LibreOffice 4.4 (release notes https://wiki.documentfoundation.org/ReleaseNotes/4.4) 


Tooltips were added to all elements of the statusbar.
Comment 9 László Németh 2015-09-04 15:52:50 UTC
*** Bug 74501 has been marked as a duplicate of this bug. ***
Comment 10 Yousuf Philips (jay) 2015-09-05 00:21:10 UTC
(In reply to Yousuf (Jay) Philips from comment #5)
> All look good except for page number, which doesnt have a tooltip when you
> create a new document. :D

@Samuel: Can you look into this as this is still pending? This issue happens when you open a document as well.
Comment 11 Samuel Mehrbrodt (CIB) 2015-09-05 09:41:06 UTC
(In reply to Yousuf (Jay) Philips from comment #10)
> (In reply to Yousuf (Jay) Philips from comment #5)
> > All look good except for page number, which doesnt have a tooltip when you
> > create a new document. :D
> 
> @Samuel: Can you look into this as this is still pending? This issue happens
> when you open a document as well.

Hm this doesn't happen in 4.4, only in master. Need to investigate.
Comment 12 Maxim Monastirsky 2015-09-06 08:56:11 UTC
@Jay: Just in case you didn't notice, the zoom slider tooltip was removed recently in Bug 93928.