Bug Hunting Session
Bug 82774 - Other: Base crashes during form design -Table Control
Summary: Other: Base crashes during form design -Table Control
Status: RESOLVED DUPLICATE of bug 83943
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2014-08-18 14:19 UTC by Prakash
Modified: 2014-09-17 04:39 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
attachment-832-0.html (2.60 KB, text/html)
2014-08-20 07:22 UTC, Prakash
Details
attachment-832-1.dat (1 bytes, multipart/alternative)
2014-08-20 07:22 UTC, Prakash
Details
unitedcghs_banklist.sql (2.82 KB, application/octet-stream)
2014-08-20 07:22 UTC, Prakash
Details
unitedcghs_billbook.sql (3.70 KB, application/octet-stream)
2014-08-20 07:22 UTC, Prakash
Details
unitedcghs_electricmeter.sql (10.88 KB, application/octet-stream)
2014-08-20 07:22 UTC, Prakash
Details
unitedcghs_filterflat.sql (2.09 KB, application/octet-stream)
2014-08-20 07:22 UTC, Prakash
Details
unitedcghs_flatdata.sql (3.82 KB, application/octet-stream)
2014-08-20 07:22 UTC, Prakash
Details
unitedcghs_funds.sql (2.15 KB, application/octet-stream)
2014-08-20 07:22 UTC, Prakash
Details
unitedcghs_occupancy.sql (7.01 KB, application/octet-stream)
2014-08-20 07:22 UTC, Prakash
Details
unitedcghs_ownerdata.sql (17.55 KB, application/octet-stream)
2014-08-20 07:22 UTC, Prakash
Details
unitedcghs_ownership.sql (7.65 KB, application/octet-stream)
2014-08-20 07:22 UTC, Prakash
Details
unitedcghs_receiptbook.sql (3.11 KB, application/octet-stream)
2014-08-20 07:22 UTC, Prakash
Details
unitedcghs_routines.sql (33.22 KB, application/octet-stream)
2014-08-20 07:22 UTC, Prakash
Details
unitedcghs_selecting.sql (2.28 KB, application/octet-stream)
2014-08-20 07:22 UTC, Prakash
Details
unitedcghs_utiltyrate.sql (2.36 KB, application/octet-stream)
2014-08-20 07:22 UTC, Prakash
Details
unitedcghs_watermeter.sql (9.97 KB, application/octet-stream)
2014-08-20 07:22 UTC, Prakash
Details
unitedcghsDatabase.odb (98.28 KB, application/vnd.sun.xml.base)
2014-08-20 07:22 UTC, Prakash
Details
attachment-5797-0.html (2.35 KB, text/html)
2014-08-21 07:37 UTC, Prakash
Details
attachment-5797-1.dat (1 bytes, multipart/alternative)
2014-08-21 07:37 UTC, Prakash
Details
chitnis.zip (78.42 KB, application/zip)
2014-08-21 07:37 UTC, Prakash
Details
Symptom reproduction (zip): odb file, schema creation sql, crash report, notes (65.51 KB, application/zip)
2014-09-15 18:58 UTC, DierkH
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Prakash 2014-08-18 14:19:40 UTC
Problem description: While designing forms for MySQL back end database, base crashes when the next column of table control is clicked/selected for adjusting properties.

Steps to reproduce:
1. Create form in design mode with a main form as described on page 107-109 of base handbook. Add two sub forms accessing tables in mysql, each with a table control. One gives info on last record in table using a mysql view, while the other is used to add data only to the table (not view).  After a few changes/adjustment to column properties the selection of next column crashes the base.
2. 
3. ....

Current behavior: Base crashes!

Expected behavior: Should take up next column for adjusting/setting properties.

              
Operating System: Windows 7
Version: 4.2.5.2 release
Comment 1 Robert Großkopf 2014-08-19 11:26:02 UTC
I have tried the following:
Connected to a MariaDB (OpenSUSE 12.3 64bit rpm Linux).
Created a form in Base.
In this document one form connected to a table, 2 subforms (both with tablecontrols) also connected to this table. Subforms are linked to the mainform with different links.

No problems here to edit the form with LO 4.2.6.2. Also no problems to navigate through data.

I couldn't confirm any bug. Might be the buggy situation isn't described clear enough.
Comment 2 Prakash 2014-08-20 07:22:41 UTC
Created attachment 104943 [details]
attachment-832-0.html

I can only send a copy of the base .ODB file and backup of the MySQL
database I am using. Would that help analyse the problem?

Prakash Chitnis


On 19 August 2014 16:56, <bugzilla-daemon@freedesktop.org> wrote:

> robert@familiegrosskopf.de changed bug 82774
> <https://bugs.freedesktop.org/show_bug.cgi?id=82774>
>  What Removed Added  CC   robert@familiegrosskopf.de
>
>  *Comment # 1 <https://bugs.freedesktop.org/show_bug.cgi?id=82774#c1> on
> bug 82774 <https://bugs.freedesktop.org/show_bug.cgi?id=82774> from
> robert@familiegrosskopf.de <robert@familiegrosskopf.de> *
>
> I have tried the following:
> Connected to a MariaDB (OpenSUSE 12.3 64bit rpm Linux).
> Created a form in Base.
> In this document one form connected to a table, 2 subforms (both with
> tablecontrols) also connected to this table. Subforms are linked to the
> mainform with different links.
>
> No problems here to edit the form with LO 4.2.6.2. Also no problems to navigate
> through data.
>
> I couldn't confirm any bug. Might be the buggy situation isn't described clear
> enough.
>
>  ------------------------------
> You are receiving this mail because:
>
>    - You reported the bug.
>
>
Comment 3 Prakash 2014-08-20 07:22:42 UTC
Created attachment 104944 [details]
attachment-832-1.dat
Comment 4 Prakash 2014-08-20 07:22:42 UTC
Created attachment 104945 [details]
unitedcghs_banklist.sql
Comment 5 Prakash 2014-08-20 07:22:42 UTC
Created attachment 104946 [details]
unitedcghs_billbook.sql
Comment 6 Prakash 2014-08-20 07:22:42 UTC
Created attachment 104947 [details]
unitedcghs_electricmeter.sql
Comment 7 Prakash 2014-08-20 07:22:42 UTC
Created attachment 104948 [details]
unitedcghs_filterflat.sql
Comment 8 Prakash 2014-08-20 07:22:42 UTC
Created attachment 104949 [details]
unitedcghs_flatdata.sql
Comment 9 Prakash 2014-08-20 07:22:42 UTC
Created attachment 104950 [details]
unitedcghs_funds.sql
Comment 10 Prakash 2014-08-20 07:22:42 UTC
Created attachment 104951 [details]
unitedcghs_occupancy.sql
Comment 11 Prakash 2014-08-20 07:22:42 UTC
Created attachment 104952 [details]
unitedcghs_ownerdata.sql
Comment 12 Prakash 2014-08-20 07:22:42 UTC
Created attachment 104953 [details]
unitedcghs_ownership.sql
Comment 13 Prakash 2014-08-20 07:22:42 UTC
Created attachment 104954 [details]
unitedcghs_receiptbook.sql
Comment 14 Prakash 2014-08-20 07:22:42 UTC
Created attachment 104955 [details]
unitedcghs_routines.sql
Comment 15 Prakash 2014-08-20 07:22:42 UTC
Created attachment 104956 [details]
unitedcghs_selecting.sql
Comment 16 Prakash 2014-08-20 07:22:42 UTC
Created attachment 104957 [details]
unitedcghs_utiltyrate.sql
Comment 17 Prakash 2014-08-20 07:22:42 UTC
Created attachment 104958 [details]
unitedcghs_watermeter.sql
Comment 18 Prakash 2014-08-20 07:22:42 UTC
Created attachment 104959 [details]
unitedcghsDatabase.odb
Comment 19 Robert Großkopf 2014-08-20 13:51:31 UTC
(In reply to comment #2)
> Created attachment 104943 [details]
> attachment-832-0.html
> 
> I can only send a copy of the base .ODB file and backup of the MySQL
> database I am using. Would that help analyse the problem?
> 
> Prakash Chitnis

Could you please add one copy (export of the data for the whole database) with

mysqldump -u <mysqlusername> -l <databasename> > /home/user/database.sql;

or a command like this?
Put the file together with the *.odb-file in a *.zip-package and it could well be downloaded and installed here.

Regards

Robert
Comment 20 Prakash 2014-08-21 07:37:05 UTC
Created attachment 105013 [details]
attachment-5797-0.html

The files forwarded were from MYSQL export command. I am attaching zip file
chitnis.zip.
And Thanks for your attention and efforts.

Prakash Chitnis


On 20 August 2014 19:21, <bugzilla-daemon@freedesktop.org> wrote:

>   *Comment # 19 <https://bugs.freedesktop.org/show_bug.cgi?id=82774#c19>
> on bug 82774 <https://bugs.freedesktop.org/show_bug.cgi?id=82774> from
> robert@familiegrosskopf.de <robert@familiegrosskopf.de> *
>
> (In reply to comment #2 <https://bugs.freedesktop.org/show_bug.cgi?id=82774#c2>)> Created attachment 104943 [details] <https://bugs.freedesktop.org/attachment.cgi?id=104943> [details] <https://bugs.freedesktop.org/attachment.cgi?id=104943&action=edit>
> > attachment-832-0.html
> >
> > I can only send a copy of the base .ODB file and backup of the MySQL
> > database I am using. Would that help analyse the problem?
> >
> > Prakash Chitnis
>
> Could you please add one copy (export of the data for the whole database) with
>
> mysqldump -u <mysqlusername> -l <databasename> > /home/user/database.sql;
>
> or a command like this?
> Put the file together with the *.odb-file in a *.zip-package and it could well
> be downloaded and installed here.
>
> Regards
>
> Robert
>
>  ------------------------------
> You are receiving this mail because:
>
>    - You reported the bug.
>
>
Comment 21 Prakash 2014-08-21 07:37:06 UTC
Created attachment 105014 [details]
attachment-5797-1.dat
Comment 22 Prakash 2014-08-21 07:37:06 UTC
Created attachment 105015 [details]
chitnis.zip
Comment 23 Robert Großkopf 2014-08-21 13:58:14 UTC
Hi Prakash,

I have installed all on my MariaDB-Server. Much forms there, also a field which is special defined with the user.

I have to contact to the database with JDBC, because there is no native connector for MySQL for my system (OpenSUSE 12.3 64 bit rpm) here. So could be a special problem of the connector.

Which special form gets the error?
Comment 24 Prakash 2014-08-21 16:35:44 UTC
Hi Robert,

I am still developing the forms. The problem is in readmeters and
read_e_meter. Initially I planned to enter both electric and water meter
readings in a single form.  When the problem started I decided to have
separate forms and reached present stage in read_e_meter.  Could the
problem be in Windows installation of Libre Office? I doubt that.

I am not clear regarding your reference to *'a field which is special
defined with the user*'.  I don't recall any special field. Are you
referring to a field in the database tables or in a base form?

By the way, I am trying to install and run MySQL on opensuse 13.1
(learner).  Any pointers to a good guide/tutorial will be much
appreciated.  Actually I did quite a lot of work in dBase III+, dBase IV
and Visual dBase 15 years back (thanks Alan Simpson).  But then turned my
attention to my main specialisation i.e. Engineering Quality Assurance.
Things have changed a lot since!

Prakash


On 21 August 2014 19:28, <bugzilla-daemon@freedesktop.org> wrote:

>   *Comment # 23 <https://bugs.freedesktop.org/show_bug.cgi?id=82774#c23>
> on bug 82774 <https://bugs.freedesktop.org/show_bug.cgi?id=82774> from
> robert@familiegrosskopf.de <robert@familiegrosskopf.de> *
>
> Hi Prakash,
>
> I have installed all on my MariaDB-Server. Much forms there, also a field which
> is special defined with the user.
>
> I have to contact to the database with JDBC, because there is no native
> connector for MySQL for my system (OpenSUSE 12.3 64 bit rpm) here. So could be
> a special problem of the connector.
>
> Which special form gets the error?
>
>  ------------------------------
> You are receiving this mail because:
>
>    - You reported the bug.
>
>
Comment 25 Robert Großkopf 2014-08-21 19:24:26 UTC
Hi Prakash,

I couldn't reproduce any crash in this forms. Only problem is: The forms would start without content. The database seems to miss the user 'Prakash'@'%' - because I have installed it as my local user. And so some fileds werent filled with content.

One field isn't formatted correct: "FullName" has a length '-1' - in both forms. But I don't think this would solve your problem.

You could also try to change the connection to your database. So we could see, if it is a problem with the direct connection. You have connected with the native connector. Where did you get it. I don't know any working native connector for windows. Last working connector is for LO 4.0 ...
Comment 26 Prakash 2014-08-22 04:30:24 UTC
Hi Robert,

The connector I got is "MySQL Connector 1.0.2" from The Document
Foundation. The file name mysql-connector-ooo.oxt.  My set up is also
planned for/as a single machine local user.  However, I am using Windows 7
OS and not Linux for this 'project'.  This connector appeared to be the
simplest solution! Would you advise going to TCP/IP set up?

Regarding 'Full Name' field in the form, I did not notice the -1 length set
up as this particular complete table control is read only to tell the user
he has the correct "customer" in view.  Since no data is to be input there
may not be a problem. The -1 must have come as default as I did not change
it.

All tables in the database have not been populated as yet (with test
data).  I intend to complete one form at a time, adding minimal data from
existing records in spreadsheets, and then checking the working of the
forms in adding new data.  The core tables i.e. flatdata, ownership,
ownerdata, and occupancy have practically all current data.  The peripheral
info tables like banklist, funds, utilityrate have also been populated.
forms for the electricmeter and watermeter tables are under design and have
actual data for testing.  Balance tables which depend on these two can only
be taken up later.

My problem is while adjusting the properties of the forms in design mode.
There are two separate sub forms with table controls at different levels,
both connecting to electricmeter table. The upper one is again view only to
show existing data (through a view). The second is add data only and
accesses electricmeter table directly. It is when adjusting the column
properties of these controls that the problem arises. On completing
properties of one column and clicking on the next the base crashes.

Prakash Chitnis


On 22 August 2014 00:54, <bugzilla-daemon@freedesktop.org> wrote:

>   *Comment # 25 <https://bugs.freedesktop.org/show_bug.cgi?id=82774#c25>
> on bug 82774 <https://bugs.freedesktop.org/show_bug.cgi?id=82774> from
> robert@familiegrosskopf.de <robert@familiegrosskopf.de> *
>
> Hi Prakash,
>
> I couldn't reproduce any crash in this forms. Only problem is: The forms would
> start without content. The database seems to miss the user 'Prakash'@'%' -
> because I have installed it as my local user. And so some fileds werent filled
> with content.
>
> One field isn't formatted correct: "FullName" has a length '-1' - in both
> forms. But I don't think this would solve your problem.
>
> You could also try to change the connection to your database. So we could see,
> if it is a problem with the direct connection. You have connected with the
> native connector. Where did you get it. I don't know any working native
> connector for windows. Last working connector is for LO 4.0 ...
>
>  ------------------------------
> You are receiving this mail because:
>
>    - You reported the bug.
>
>
Comment 27 Robert Großkopf 2014-08-22 14:35:43 UTC
Hi Prakash,

have found the direct connector. Didn't know there is a working connector for LO 4.1 and 4.2. Seems to be ok.

Now I have found the reason why it wasn't working here:
Have a look in the code of Dump20140821.sql. The DEFINER for the views are different. DEFINER = CURRENT_USER would work. I couldn't open the views here, where the DEFINER is shown as 'Prakash'@'%' - there isn't a user 'Prakash'here on my system.
How did you create different views? The other views are shown as 'root'@'localhost'. I have set both to CURRENT_USER and could see all data in the forms. I could see the forms and could open the relations between the forms. I could change or copy columns of the tablecontrol - all seems to work.

Please write down step by step:
1. Open form "read_e_meters".
2. Mark ... with the mouse 
... and so on. So I could see, if I could reproduce any crash here.
Comment 28 Prakash 2014-08-23 04:39:52 UTC
Hi Robert,

OOPS!  I had started creating the tables as root and then added a user
Prakash.  All the tables and views were made with MySQL Work Bench 6.
Thereafter I had added another user for testing and working from Libre.
That should not make a difference, but still, I will clean up my "multiple
user identities" and then come back with a step by step description for
reproducing the crashes.

Thanks.

Prakash Chitnis


On 22 August 2014 20:05, <bugzilla-daemon@freedesktop.org> wrote:

>   *Comment # 27 <https://bugs.freedesktop.org/show_bug.cgi?id=82774#c27>
> on bug 82774 <https://bugs.freedesktop.org/show_bug.cgi?id=82774> from
> robert@familiegrosskopf.de <robert@familiegrosskopf.de> *
>
> Hi Prakash,
>
> have found the direct connector. Didn't know there is a working connector for
> LO 4.1 and 4.2. Seems to be ok.
>
> Now I have found the reason why it wasn't working here:
> Have a look in the code of Dump20140821.sql. The DEFINER for the views are
> different. DEFINER = CURRENT_USER would work. I couldn't open the views here,
> where the DEFINER is shown as 'Prakash'@'%' - there isn't a user 'Prakash'here
> on my system.
> How did you create different views? The other views are shown as
> 'root'@'localhost'. I have set both to CURRENT_USER and could see all data in
> the forms. I could see the forms and could open the relations between the
> forms. I could change or copy columns of the tablecontrol - all seems to work.
>
> Please write down step by step:
> 1. Open form "read_e_meters".
> 2. Mark ... with the mouse
> ... and so on. So I could see, if I could reproduce any crash here.
>
>  ------------------------------
> You are receiving this mail because:
>
>    - You reported the bug.
>
>
Comment 29 Prakash 2014-08-23 10:29:41 UTC
Hi Robert,

This is what happens :

1. Open read_e_meters for editing.
2. Click open Form Navigator.
3. Click open Properties Menu.
4. Select Table Control 1 under SubForm_ntry.
5. Click on column id_e_meter_read to bring up its properties.
6. Click on label in properties and change it to Id Read.
7. Click on Read-only property to change it to Yes.
8. Now click on idownership to adjust its properties. Base immediately
crashes!

The only way out I found was to save after each column was adjusted, close
form, save and close database, again open database, open form to edit and
take up next column. Very tedious you will agree!

Prakash Chitnis


On 22 August 2014 20:05, <bugzilla-daemon@freedesktop.org> wrote:

>   *Comment # 27 <https://bugs.freedesktop.org/show_bug.cgi?id=82774#c27>
> on bug 82774 <https://bugs.freedesktop.org/show_bug.cgi?id=82774> from
> robert@familiegrosskopf.de <robert@familiegrosskopf.de> *
>
> Hi Prakash,
>
> have found the direct connector. Didn't know there is a working connector for
> LO 4.1 and 4.2. Seems to be ok.
>
> Now I have found the reason why it wasn't working here:
> Have a look in the code of Dump20140821.sql. The DEFINER for the views are
> different. DEFINER = CURRENT_USER would work. I couldn't open the views here,
> where the DEFINER is shown as 'Prakash'@'%' - there isn't a user 'Prakash'here
> on my system.
> How did you create different views? The other views are shown as
> 'root'@'localhost'. I have set both to CURRENT_USER and could see all data in
> the forms. I could see the forms and could open the relations between the
> forms. I could change or copy columns of the tablecontrol - all seems to work.
>
> Please write down step by step:
> 1. Open form "read_e_meters".
> 2. Mark ... with the mouse
> ... and so on. So I could see, if I could reproduce any crash here.
>
>  ------------------------------
> You are receiving this mail because:
>
>    - You reported the bug.
>
>
Comment 30 Robert Großkopf 2014-08-23 17:44:32 UTC
Hi Prakash,
> 
> This is what happens :
> 
> 1. Open read_e_meters for editing.
> 2. Click open Form Navigator.
> 3. Click open Properties Menu.
> 4. Select Table Control 1 under SubForm_ntry.
> 5. Click on column id_e_meter_read to bring up its properties.
> 6. Click on label in properties and change it to Id Read.
> 7. Click on Read-only property to change it to Yes.
> 8. Now click on idownership to adjust its properties. Base immediately
> crashes!

Have done all this with OpenSUSE 12.3 64bit rpm an LO 4.2.6.2 - couldn't produce any crash while using JDBC-connection. Haven't any possibility to chose the direct connection, because there is no extension available.

Step 2, 3 and 4 are steps, which have nothing to do with the changing of the properties. 1 - 5 - 6 - 7 - 8 should do the same. But also no crash here.

Regards

Robert
Comment 31 Prakash 2014-08-24 04:04:36 UTC
Hi Robert,

Steps 2,3, & 4 are required on my set up as the form navigator and
properties menus don not start automatically. No issue there.
I am using Windows 7  Ultimate OS (32 bit) using direct connector. So the
issue may not be reproducible on your set up. I am not an expert or power
user so I will need a little (read lots of) help.  Here is what I propose
to do at my end:

A. Set up JDBC connection with existing set up and see if the problem
remains. Could you point me to some docs how to set up JDBC connection?

B. I do tinker with Opensuse.  My PC has dual booting with 12.3 and 13.1 on
the linux end. When trying to work there I found :

i)  I have installed MariaDB on 12.3 with MySQL Workbench. I have enabled
mysql through YAST. But, unlike under windows, there is no default
connection available as seen on work bench. When I try to add a connection
I get connection refused message.  What is it I am doing wrong?

ii) Same happens on 13.1 with MySQL or MariaDB (tried both).

To try under either with option B, I need help to get the database started
and import existing files from windows. Could you guide me or point to
appropriate link?

Prakash Chitnis


On 23 August 2014 23:14, <bugzilla-daemon@freedesktop.org> wrote:

>   *Comment # 30 <https://bugs.freedesktop.org/show_bug.cgi?id=82774#c30>
> on bug 82774 <https://bugs.freedesktop.org/show_bug.cgi?id=82774> from
> robert@familiegrosskopf.de <robert@familiegrosskopf.de> *
>
> Hi Prakash,>
> > This is what happens :
> >
> > 1. Open read_e_meters for editing.
> > 2. Click open Form Navigator.
> > 3. Click open Properties Menu.
> > 4. Select Table Control 1 under SubForm_ntry.
> > 5. Click on column id_e_meter_read to bring up its properties.
> > 6. Click on label in properties and change it to Id Read.
> > 7. Click on Read-only property to change it to Yes.
> > 8. Now click on idownership to adjust its properties. Base immediately
> > crashes!
>
> Have done all this with OpenSUSE 12.3 64bit rpm an LO 4.2.6.2 - couldn't
> produce any crash while using JDBC-connection. Haven't any possibility to chose
> the direct connection, because there is no extension available.
>
> Step 2, 3 and 4 are steps, which have nothing to do with the changing of the
> properties. 1 - 5 - 6 - 7 - 8 should do the same. But also no crash here.
>
> Regards
>
> Robert
>
>  ------------------------------
> You are receiving this mail because:
>
>    - You reported the bug.
>
>
Comment 32 Prakash 2014-08-25 16:23:49 UTC
Hi Robert,

I installed the JDBC connector and tried to edit the read_e_meter form.
The crash happened as before. So it is not the connector problem.

By the way let me also amplify that it is not only the base but the entire
Office Suite that crashes.  Any file open in Writer or Calc goes down with
the base.

PrakashC


On 23 August 2014 23:14, <bugzilla-daemon@freedesktop.org> wrote:

>   *Comment # 30 <https://bugs.freedesktop.org/show_bug.cgi?id=82774#c30>
> on bug 82774 <https://bugs.freedesktop.org/show_bug.cgi?id=82774> from
> robert@familiegrosskopf.de <robert@familiegrosskopf.de> *
>
> Hi Prakash,>
> > This is what happens :
> >
> > 1. Open read_e_meters for editing.
> > 2. Click open Form Navigator.
> > 3. Click open Properties Menu.
> > 4. Select Table Control 1 under SubForm_ntry.
> > 5. Click on column id_e_meter_read to bring up its properties.
> > 6. Click on label in properties and change it to Id Read.
> > 7. Click on Read-only property to change it to Yes.
> > 8. Now click on idownership to adjust its properties. Base immediately
> > crashes!
>
> Have done all this with OpenSUSE 12.3 64bit rpm an LO 4.2.6.2 - couldn't
> produce any crash while using JDBC-connection. Haven't any possibility to chose
> the direct connection, because there is no extension available.
>
> Step 2, 3 and 4 are steps, which have nothing to do with the changing of the
> properties. 1 - 5 - 6 - 7 - 8 should do the same. But also no crash here.
>
> Regards
>
> Robert
>
>  ------------------------------
> You are receiving this mail because:
>
>    - You reported the bug.
>
>
Comment 33 Robert Großkopf 2014-08-25 18:33:36 UTC
(In reply to comment #32)
> Hi Robert,
> 
> I installed the JDBC connector and tried to edit the read_e_meter form.
> The crash happened as before. So it is not the connector problem.

It's also the Windows-System?
Have you tried to rename the LO-user-directory? Must be here:  %appdata%\libreoffice\4\user
When you rename this directory (for example '4' to '4old') it will be rewritten next time. Could be there is something saved, which set this buggy behavior.

If you get the same on another system (Linux, for example) I don't know how I could help any more. Here all the steps work and no crash is happening ...
Comment 34 Prakash 2014-08-27 15:14:01 UTC
Hi Robert,

I have tried your suggestions but to no avail. I even re-installed the
suite, tried with JDBC connector etc. No use. I am now recreating the form
afresh to get my project restarted, if there was some corruption in the
file.

However, I am convinced there is a bug in the "table control" which is
acting up under Windows OS possibly Windows 7.  I recall reading a piece of
advice to save work frequently while designing forms as it tends to crash.
I have hit the error point consistently on my system. May be someone from
the "bug removal" team who specialises on windows OS should take a look at
it.

Prakash Chitnis



On 26 August 2014 00:03, <bugzilla-daemon@freedesktop.org> wrote:

>   *Comment # 33 <https://bugs.freedesktop.org/show_bug.cgi?id=82774#c33>
> on bug 82774 <https://bugs.freedesktop.org/show_bug.cgi?id=82774> from
> robert@familiegrosskopf.de <robert@familiegrosskopf.de> *
>
> (In reply to comment #32 <https://bugs.freedesktop.org/show_bug.cgi?id=82774#c32>)
> > Hi Robert,
> >
> > I installed the JDBC connector and tried to edit the read_e_meter form.
> > The crash happened as before. So it is not the connector problem.
>
>
> It's also the Windows-System?
> Have you tried to rename the LO-user-directory? Must be here:
> %appdata%\libreoffice\4\user
> When you rename this directory (for example '4' to '4old') it will be rewritten
> next time. Could be there is something saved, which set this buggy behavior.
>
> If you get the same on another system (Linux, for example) I don't know how I
> could help any more. Here all the steps work and no crash is happening ...
>
>  ------------------------------
> You are receiving this mail because:
>
>    - You reported the bug.
>
>
Comment 35 Robert Großkopf 2014-08-27 17:39:10 UTC
(In reply to comment #34)
Hi Prakash,

> I have tried your suggestions but to no avail. I even re-installed the
> suite, tried with JDBC connector etc. No use.

I don't know if I had understand it right. Did you rename
%appdata%\libreoffice\4\user ?
If you have reinstalled LO this folder isn't installed new. Most people have saved there personal data like the entries for fields in letters, the personal dictionary, graphics and other things. So it would appear also in the reinstalled version or in a new installed version. And if there is something, which is the reason for a buggy behavior in LO 4.2, it wouldn't be deleted by reinstalling LO.
I had the first times some crashes with LO 4.2 - not with this bug. Then I renamed the folder for the personal configuration of LO and the crashes had been gone...

Regards

Robert
Comment 36 Prakash 2014-08-28 06:48:55 UTC
Hi Robert,

I renamed the old file as indicated by you in the first instance! The
re-installation was a later attempt. In fact I have shifted to 4.2.6.2 now
but the problem remained. Which is why I am starting a new form (file) to
get over some inadvertent error on my part while designing the crashing
file.
My doubts on the table control however remain unanswered.

Regards

Prakash Chitnis


On 27 August 2014 23:09, <bugzilla-daemon@freedesktop.org> wrote:

>   *Comment # 35 <https://bugs.freedesktop.org/show_bug.cgi?id=82774#c35>
> on bug 82774 <https://bugs.freedesktop.org/show_bug.cgi?id=82774> from
> robert@familiegrosskopf.de <robert@familiegrosskopf.de> *
>
> (In reply to comment #34 <https://bugs.freedesktop.org/show_bug.cgi?id=82774#c34>)
> Hi Prakash,
>
> > I have tried your suggestions but to no avail. I even re-installed the
> > suite, tried with JDBC connector etc. No use.
>
>
> I don't know if I had understand it right. Did you rename
> %appdata%\libreoffice\4\user ?
> If you have reinstalled LO this folder isn't installed new. Most people have
> saved there personal data like the entries for fields in letters, the personal
> dictionary, graphics and other things. So it would appear also in the
> reinstalled version or in a new installed version. And if there is something,
> which is the reason for a buggy behavior in LO 4.2, it wouldn't be deleted by
> reinstalling LO.
> I had the first times some crashes with LO 4.2 - not with this bug. Then I
> renamed the folder for the personal configuration of LO and the crashes had
> been gone...
>
> Regards
>
> Robert
>
>  ------------------------------
> You are receiving this mail because:
>
>    - You reported the bug.
>
>
Comment 37 Prakash 2014-09-02 07:36:01 UTC
Hi Robert,

Whichever way I try (with Windows 7 OS) I run into the same problem.
Beyond a stage, with table control placed on the form, Libre Office crashes
when moving from one column to the next for editing properties. Would it be
possible to put someone using Windows 7 (32 bit) to check the
reproducibility of the crash.

Prakash Chitnis


On 28 August 2014 12:18, Prakash Chitnis <chitnis7m64@gmail.com> wrote:

> Hi Robert,
>
> I renamed the old file as indicated by you in the first instance! The
> re-installation was a later attempt. In fact I have shifted to 4.2.6.2 now
> but the problem remained. Which is why I am starting a new form (file) to
> get over some inadvertent error on my part while designing the crashing
> file.
> My doubts on the table control however remain unanswered.
>
> Regards
>
> Prakash Chitnis
>
>
> On 27 August 2014 23:09, <bugzilla-daemon@freedesktop.org> wrote:
>
>>   *Comment # 35 <https://bugs.freedesktop.org/show_bug.cgi?id=82774#c35>
>> on bug 82774 <https://bugs.freedesktop.org/show_bug.cgi?id=82774> from
>> robert@familiegrosskopf.de <robert@familiegrosskopf.de> *
>>
>> (In reply to comment #34 <https://bugs.freedesktop.org/show_bug.cgi?id=82774#c34>)
>> Hi Prakash,
>>
>> > I have tried your suggestions but to no avail. I even re-installed the
>> > suite, tried with JDBC connector etc. No use.
>>
>>
>> I don't know if I had understand it right. Did you rename
>> %appdata%\libreoffice\4\user ?
>> If you have reinstalled LO this folder isn't installed new. Most people have
>> saved there personal data like the entries for fields in letters, the personal
>> dictionary, graphics and other things. So it would appear also in the
>> reinstalled version or in a new installed version. And if there is something,
>> which is the reason for a buggy behavior in LO 4.2, it wouldn't be deleted by
>> reinstalling LO.
>> I had the first times some crashes with LO 4.2 - not with this bug. Then I
>> renamed the folder for the personal configuration of LO and the crashes had
>> been gone...
>>
>> Regards
>>
>> Robert
>>
>>  ------------------------------
>> You are receiving this mail because:
>>
>>    - You reported the bug.
>>
>>
>
Comment 38 Prakash 2014-09-14 07:19:42 UTC
I finally managed to copy the MySQL database and librebase .odb file to
open suse 13.1.
The existence of bug is confirmed as the problem recurs with opensuse 13.1
os also.
Prakash Chitnis

On 2 September 2014 23:10, <bugzilla-daemon@freedesktop.org> wrote:

>  Jochen <dr@jochenschiffers.de> changed bug 82774
> <https://bugs.freedesktop.org/show_bug.cgi?id=82774>
>  What Removed Added  CC   dr@jochenschiffers.de
>
>  ------------------------------
> You are receiving this mail because:
>
>    - You reported the bug.
>
>
Comment 39 DierkH 2014-09-15 18:58:29 UTC
Created attachment 106342 [details]
Symptom reproduction (zip): odb file, schema creation sql, crash report, notes

I'm hoping this can be a more or less complete symptom reproduction kit. Uploaded in response to a request on http://ask.libreoffice.org/en/question/37864/base-keeps-crashing-while-making-forms/
Comment 40 Robert Großkopf 2014-09-15 19:27:57 UTC
(In reply to comment #39)
> Created attachment 106342 [details]
> Symptom reproduction (zip): odb file, schema creation sql, crash report,
> notes
> 
> I'm hoping this can be a more or less complete symptom reproduction kit.
> Uploaded in response to a request on
> http://ask.libreoffice.org/en/question/37864/base-keeps-crashing-while-
> making-forms/

So you could reproduce the bug? Please set this bug to "New". I have tried it with the database of Prakash and couldn't reproduce.
Comment 41 Robert Großkopf 2014-09-16 17:51:05 UTC
(In reply to comment #39)
> Created attachment 106342 [details]
> Symptom reproduction (zip): odb file, schema creation sql, crash report,
> notes

I tried to import the definition of the tables and view - doesn't work.
There is a view, which is looking for a table v_dbadlrunslast. This Table doesn't exist. A table named v_dbaDLRunsLast does exist.

But only some lines later in the code v_dbaDLRunsLast should be dropped for a view - and that wouldn't work, because the table is needed for the view before.

So I couldn't test and couldn't confirm this bug with the attachment.
Comment 42 Robert Großkopf 2014-09-16 18:26:27 UTC
I have changed the entries for https://bugs.freedesktop.org/attachment.cgi?id=106342 to the right tablename.
Then I tested the database and got a crash in the first form (...Clients). When I opened the form ...LegalEntities the tablecontrol of the subform wasn't high enough. I changed the hight of the tablecontrol. Now I could change from one field to another without any problem.
Tried the same in the first form with the same result. Changing the hight of the tablecontrol and the buggy behavior is gone.
Both tablecontrols were created without rowmarker and navigationbar. Don't know if this has anything to do with the crash.

I set this bug to NEW. Will try to reproduce it with the internal HSQLDB.

I could reproduce the bug with all LO-versions, also LO 3.3.0beta1 and other LO 3.*-versions. So I set the bug as Inherited From OOo.
My system: OpenSUSE 64bit rpm Linux. I set the Platform to all.
Comment 43 Robert Großkopf 2014-09-16 19:02:27 UTC
I have tried it with a normal HSQLDB-database. It's the same behavior. Has nothing to do with MySQL, also nothing to do with form and subform. The tablecontrols aren't high enough. If you change the height to more than one row the bug disappears.

I will set this bug as a duplicate of the new. There are too many misleading informations in this bug.
Feel free to reopen, if you think this isn't right.

*** This bug has been marked as a duplicate of bug 83943 ***
Comment 44 Prakash 2014-09-17 04:33:02 UTC
That appears to be an internal base table not a part of my database in
MySQL.

I had managed to copy the database and .odb file to system with opensuse
13.1 (64 bit) OS.  The base crashes the same. In fact my current attempts
(under opensuse0 the crash occurs faster! If you think it might help in
locating the bug, I can upload that set too.

Prakash Chitnis

On 16 September 2014 23:21, <bugzilla-daemon@freedesktop.org> wrote:

>   *Comment # 41 <https://bugs.freedesktop.org/show_bug.cgi?id=82774#c41>
> on bug 82774 <https://bugs.freedesktop.org/show_bug.cgi?id=82774> from
> robert@familiegrosskopf.de <robert@familiegrosskopf.de> *
>
> (In reply to comment #39 <https://bugs.freedesktop.org/show_bug.cgi?id=82774#c39>)> Created attachment 106342 [details] <https://bugs.freedesktop.org/attachment.cgi?id=106342> [details] <https://bugs.freedesktop.org/attachment.cgi?id=106342&action=edit>
> > Symptom reproduction (zip): odb file, schema creation sql, crash report,
> > notes
>
> I tried to import the definition of the tables and view - doesn't work.
> There is a view, which is looking for a table v_dbadlrunslast. This Table
> doesn't exist. A table named v_dbaDLRunsLast does exist.
>
> But only some lines later in the code v_dbaDLRunsLast should be dropped for a
> view - and that wouldn't work, because the table is needed for the view before.
>
> So I couldn't test and couldn't confirm this bug with the attachment.
>
>  ------------------------------
> You are receiving this mail because:
>
>    - You reported the bug.
>
>
Comment 45 Prakash 2014-09-17 04:39:55 UTC
Thanks! There is a problem and not only something wrong in my work. The
tablecontrol height was limited by me as only one record is to be "shown",
which is why there is no record marker or navigation bar.  I will try to
work with a "taller" table control and see what happens (both windows and
opensuse).

Prakash Chitnis

On 16 September 2014 23:56, <bugzilla-daemon@freedesktop.org> wrote:

> robert@familiegrosskopf.de changed bug 82774
> <https://bugs.freedesktop.org/show_bug.cgi?id=82774>
>  What Removed Added  Hardware Other All  OS Windows (All) All  Status UNCONFIRMED
> NEW  Version 4.2.5.2 release Inherited From OOo  Ever confirmed   1
>
>  *Comment # 42 <https://bugs.freedesktop.org/show_bug.cgi?id=82774#c42>
> on bug 82774 <https://bugs.freedesktop.org/show_bug.cgi?id=82774> from
> robert@familiegrosskopf.de <robert@familiegrosskopf.de> *
>
> I have changed the entries forhttps://bugs.freedesktop.org/attachment.cgi?id=106342 to the right tablename.
> Then I tested the database and got a crash in the first form (...Clients). When
> I opened the form ...LegalEntities the tablecontrol of the subform wasn't high
> enough. I changed the hight of the tablecontrol. Now I could change from one
> field to another without any problem.
> Tried the same in the first form with the same result. Changing the hight of
> the tablecontrol and the buggy behavior is gone.
> Both tablecontrols were created without rowmarker and navigationbar. Don't know
> if this has anything to do with the crash.
>
> I set this bug to NEW. Will try to reproduce it with the internal HSQLDB.
>
> I could reproduce the bug with all LO-versions, also LO 3.3.0beta1 and other LO
> 3.*-versions. So I set the bug as Inherited From OOo.
> My system: OpenSUSE 64bit rpm Linux. I set the Platform to all.
>
>  ------------------------------
> You are receiving this mail because:
>
>    - You reported the bug.
>
>