Download it now!
Bug 82805 - you cannot enter a date 27 Mar 2011
Summary: you cannot enter a date 27 Mar 2011
Status: CLOSED DUPLICATE of bug 63230
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.5.2 release
Hardware: All All
: high critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-08-19 08:09 UTC by iva012
Modified: 2014-08-23 16:22 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description iva012 2014-08-19 08:09:59 UTC
Date 27 Mar 2011 in LibreOffice Calc automatically convert (while click Enter) in date 26 Mar 2011.
Comment 1 sophie 2014-08-19 08:25:40 UTC
Hi, please don't set your own bug on New, it needs to be confirmed by a QA team member. 
What is your operating system, what is the version of LibreOffice you used? and provide a clear step to reproduce. Thanks - Set as needinfo - Sophie
Comment 2 Urmas 2014-08-19 11:38:42 UTC
The dates before 27.03.11 0:00 and 1:00 are displayed as "26". Also found in master.
Comment 3 m.a.riosv 2014-08-19 20:52:54 UTC
Maybe this is a duplicate of https://bugs.freedesktop.org/show_bug.cgi?id=74869,

The issue seems to be in relation with some time zones for the OS.
Comment 4 Julien Nabet 2014-08-19 21:30:40 UTC
Eike: Calc + date related bug, thought you might be interested in this one.

(I don't reproduce this with 4.3.0.4 LO Debian package but probably missed some points)
Comment 5 Eike Rathke 2014-08-20 13:07:26 UTC
@iva012:
Which timezone are you in, and was there some change in timezone offset or daylight saving time on that date?
Comment 6 Urmas 2014-08-20 15:21:21 UTC
It is DST +1 staring date in Europe, at 2:00.
Comment 7 Eike Rathke 2014-08-20 15:37:51 UTC
That's CEST, no problem with that here. So what's the exact timezone? e.g. Europe/Berlin or...?
Comment 8 Urmas 2014-08-20 16:01:31 UTC
I can reproduce it with 'UTC+07 Omsk, Novosibirsk' Windows timezone.
Comment 9 Eike Rathke 2014-08-23 16:21:51 UTC
Reproduced with a TZ=Asia/Novosibirsk environment.
Technically times between 2011-03-27T00:00 and 01:00 do not exist, which (again) is the problem here.
See also https://en.wikipedia.org/wiki/Time_zones_in_Russia#Daylight_saving_time

*** This bug has been marked as a duplicate of bug 63230 ***