Download it now!
Bug 82862 - Formula turning up values incorrect- Critical
Summary: Formula turning up values incorrect- Critical
Status: RESOLVED DUPLICATE of bug 80846
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-08-20 11:20 UTC by SriJanani
Modified: 2014-08-25 12:28 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Simple formulas not working in 4.2.2.5 version of LO (43.12 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-08-20 11:20 UTC, SriJanani
Details
Formulas issue attached version 4.2.5.2 (57.62 KB, image/jpeg)
2014-08-20 11:23 UTC, SriJanani
Details

Note You need to log in before you can comment on or make changes to this bug.
Description SriJanani 2014-08-20 11:20:12 UTC
Created attachment 104972 [details]
Simple formulas not working in 4.2.2.5 version of LO

Hi,

I would like to bring to your notice that the simple formulas are not returning the values correctly at the initial moment. For example I am attaching the sheet and the screenshot can someone help on this. 

Thank You,

Regards,
SriJanani
Email: jananikumar2k8@gmail.com

Bug: In the column D the values are not getting calculated fromsum(D12:D14) wherein it calculates for D12 and D13 only. 

Version used: 4.2.2.5
Comment 1 SriJanani 2014-08-20 11:23:45 UTC
Created attachment 104973 [details]
Formulas issue attached version 4.2.5.2
Comment 2 Eike Rathke 2014-08-20 12:05:07 UTC
I don't know how you managed to get those results, also H14,J14,K14,J14,M14 don't reflect the current state, the results are stored in the document file, but a hard recalculation once fixes it, hit Shift+Ctrl+F9

Did you enter the value in D14 while AutoCalculate was off? Or do you know what happened during that time?

Also, this is not a blocker, and please don't set a bug to ASSIGNED status.
Comment 3 SriJanani 2014-08-25 09:06:16 UTC
Hi,

Further to our discussion with the user what he is trying to do is. 


He is calculating sum(E8:E10) in a new Libre office sheet.

E8= 1
E9= 2
E10= 3

E11=sum(E8:E10) that is 6.

Now user saves the sheet and closes. He opens the same sheet and changes the values in the column E9 from 2 to 3. 


E8= 1
E9= 3
E10= 3

E11=sum(E8:E10) that is 7.

Here is the issue-> now user wants to recall the changes so he presses Ctrl+Z. The values are not getting reflected automatically unless we press Ctrl+Shift+F9.  Please assist. 

In users PC autocalculate is turned all already. 

Awaiting your response

Thank you,

Regards,
SriJanani
Comment 4 SriJanani 2014-08-25 12:15:59 UTC
Adding to the above issue I tested the same with 4.3.31 version- If a value is changed its getting reflected. For example if I am removing the value from one particular cell and leaving it as blank then do a undo action it does not auto calculate the value. 

Awaiting your response.
Comment 5 GerardF 2014-08-25 12:28:50 UTC
(In reply to comment #3)

> Here is the issue-> now user wants to recall the changes so he presses
> Ctrl+Z. The values are not getting reflected automatically unless we press
> Ctrl+Shift+F9.  Please assist. 

OK, thanks.
This is a "Undo not recalculate" problem.
Fix by Kohei :
https://bugs.freedesktop.org/show_bug.cgi?id=80846

*** This bug has been marked as a duplicate of bug 80846 ***