Bug Hunting Session
Bug 82870 - FILEOPEN: scaled images dont look as crisp as they used to
Summary: FILEOPEN: scaled images dont look as crisp as they used to
Status: RESOLVED DUPLICATE of bug 86675
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.6.2 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:4.5.0
Keywords: bibisected, regression
Depends on:
Blocks:
 
Reported: 2014-08-20 14:09 UTC by Yousuf Philips (jay) (retired)
Modified: 2015-12-17 08:32 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
4.3 vs 4.1 (297.73 KB, image/png)
2014-08-20 14:09 UTC, Yousuf Philips (jay) (retired)
Details
clip from LODev440 20140906 on Windows (232.01 KB, image/png)
2014-09-07 20:16 UTC, V Stuart Foote
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2014-08-20 14:09:00 UTC
Created attachment 104986 [details]
4.3 vs 4.1

Steps:
1) Open https://wiki.documentfoundation.org/images/0/0f/GS42-GettingStartedLO.odt
2) Look at the images in the document and you'll see they are not very crisp with their smoothing.

Tested in 4.2.6 and 4.3.2 on Linux.
Comment 1 Jean-Baptiste Faure 2014-08-24 17:56:27 UTC
There is the same problem with not scaled images. You can see that with the full page image on the first page.
Perhaps this regression in the rendering quality is the price of a better rendering performance.


Best regards. JBF
Comment 2 V Stuart Foote 2014-09-07 20:16:20 UTC
Created attachment 105868 [details]
clip from LODev440 20140906 on Windows

WFM on Windows 7 sp1, 64-bit

Resolved?
Comment 3 Yousuf Philips (jay) (retired) 2014-09-08 02:47:43 UTC
Bug is likely only linux based as 4.2.5 on windows doesnt have the bad image scaling.
Comment 4 Moi Jaiunvelo 2014-10-17 12:10:25 UTC
This bug is still present in version 4.3.2.2.0+, build ID: 430m0(Build:2) (debian testing). This appeared recently here, and now all images are poorly displayed, however when exporting to pdf images are ok.
Comment 5 Xisco Faulí 2014-10-22 13:13:20 UTC
Bibisected: Issue introduced in range 418c5f7a4911bb2f1a06858556131b1bc4ad54f6..dacab84536f61f79a5422e1d8d394019ec62f3ec --> http://cgit.freedesktop.org/libreoffice/core/log/?qt=range&q=418c5f7a4911bb2f1a06858556131b1bc4ad54f6..dacab84536f61f79a5422e1d8d394019ec62f3ec
Comment 6 Matthew Francis 2015-01-01 04:38:04 UTC
Closing as duplicate of bug 86675 (I know in general the earlier bug should be duplicated onto, but I already source bisected 86675 and forwarded the report to the original author, so I think it will be less confusing this way round)

*** This bug has been marked as a duplicate of bug 86675 ***
Comment 7 Commit Notification 2015-01-01 12:07:09 UTC
Tomaž Vajngerl committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=5fa404d1b5da93c9baf8e89a94ddd63d76ae6b9d

fdo#82870 scale "super" quality degradation bug

It will be available in 4.5.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 8 Yousuf Philips (jay) (retired) 2015-01-01 12:17:22 UTC
Thanks tomaz for catching this. Hope you can back port it to 4.3 and 4.4. :D
Comment 9 Yousuf Philips (jay) (retired) 2015-01-02 09:46:41 UTC
Returning this to NEW as Tomaz's commit was for bug 86675.
Comment 10 Tomaz Vajngerl 2015-01-02 11:54:56 UTC
Jay, this is the same problem as in fdo#86675 as the lower quality scaling was re-introduced (kendy's commit was reverted) in middle of 4.2. It is totally false that 4.3.4 doesn't have the lower quality as stated in fdo#86675 (I was very confused myself as I just couldn't spot a difference between 4.3.x and 4.4.x). This bug and also fdo#86675 are a duplicate of fdo#74124.
Comment 11 Yousuf Philips (jay) (retired) 2015-01-02 21:19:08 UTC
If you say so Tomaz. :D

*** This bug has been marked as a duplicate of bug 86675 ***
Comment 12 Robinson Tryon (qubit) 2015-12-17 08:32:08 UTC
Migrating Whiteboard tags to Keywords: (bibisected)
[NinjaEdit]