Download it now!
Bug 82895 - FILEOPEN: RTF - box appears on page
Summary: FILEOPEN: RTF - box appears on page
Status: RESOLVED DUPLICATE of bug 78907
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium normal
Assignee: Miklos Vajna
URL:
Whiteboard: target:4.4.0 target:4.3.3
Keywords:
Depends on:
Blocks: RTF
  Show dependency treegraph
 
Reported: 2014-08-21 07:36 UTC by Yousuf Philips (jay) (retired)
Modified: 2014-10-13 18:35 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
sample file (4.97 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2014-08-21 07:36 UTC, Yousuf Philips (jay) (retired)
Details
how it looks on 4.3.2 on Windows (101.50 KB, image/png)
2014-08-23 14:30 UTC, Yousuf Philips (jay) (retired)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2014-08-21 07:36:12 UTC
Created attachment 105012 [details]
sample file

Steps:
1) Open attached file
2) Save as RTF, close and reopen
3) On page 1, there will be a box that wasnt there before saving

I assume this is a fileopen issue as opening the RTF in Kingsoft or MS Word doesnt show this box. Its in 3.3, 4.2.6 and 4.3.2 on Linux.
Comment 1 Owen Genat (retired) 2014-08-23 11:41:30 UTC
(In reply to comment #0)
> 3) On page 1, there will be a box that wasnt there before saving

Under GNU/Linux the box is visible in v4.3.0.4 Build ID: 62ad5818884a2fc2e5780dd45466868d41009ec0 but not visible in v4.4.0.0.alpha0+ Build ID: e379401618268ed7f7f5885a36b90e1f4f6cd4af TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2014-08-18_05:51:03 so may have been fixed recently.
Comment 2 Yousuf Philips (jay) (retired) 2014-08-23 14:30:25 UTC
Created attachment 105159 [details]
how it looks on 4.3.2 on Windows

Just tested it on 4.3.2 on Windows and its still there. This bug didnt effect master on Linux when i tested build 2014-08-09.

Version: 4.3.2.0.0+
Build ID: 5b980040676f2ce0f09b37e1070acb506cbe15e0
TinderBox: Win-x86@42, Branch:libreoffice-4-3, Time: 2014-08-19_14:08:58
Comment 3 Yousuf Philips (jay) (retired) 2014-08-23 14:32:15 UTC
@Joel: Setting bibisectRequest as this is fixed in master and not in 4.3.2.
Comment 4 Jacques Guilleron 2014-08-23 14:34:55 UTC
Hi,

You see Text boundaries, I assume. They are not the same in rtf and odt format. 
This is, for me, a good way to show sections changes, even if I can find that in Navigator.

regards,

Jacques
Comment 5 Yousuf Philips (jay) (retired) 2014-08-23 19:37:27 UTC
Hey Jacques,

Yes it looks like its a text boundary, but it only appears on the first page of the RTF and not the second.
Comment 6 Jacques Guilleron 2014-08-23 22:07:58 UTC
I didn't verify, but this section was not in the first document. There was only a jump to the next page. So the rtf filter added it. This is the issue.
In Word, this rtf file shows on the first page: "section break (next page)" where we should find "next page".

Regard,

Jacques
Comment 7 Julien Nabet 2014-08-27 20:35:51 UTC
On pc Debian x86-64 with master sources updated today, I don't reproduce this.
Either it's a Windows only bug (I don't think so) or it's fixed with master sources.

Could someone give a try with recent master sources on Windows?
Comment 8 Yousuf Philips (jay) (retired) 2014-08-28 01:22:47 UTC
Just to reiterate the issue again, this is a 4.3.x bug that doesnt effect master, which likely means that it needs to be backported from master to 4.3.
Comment 9 Julien Nabet 2014-08-28 05:28:03 UTC
Sorry Jay, I had overlooked this piece of information :-(

Miklos: thought you might have an idea about which commit(s) to backport on 4.3
Comment 10 Miklos Vajna 2014-10-01 12:56:15 UTC
The fix for bug 78907 fixed this one, now backported to libreoffice-4-3.

*** This bug has been marked as a duplicate of bug 78907 ***