Bug 82936 - Editing : references to different sheet get removed on dragging cell
Summary: Editing : references to different sheet get removed on dragging cell
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.3.1.1 rc
Hardware: Other All
: high major
Assignee: Eike Rathke
URL:
Whiteboard: target:4.4.0 target:4.3.1 target:4.2.8
Keywords: regression
: 85946 87446 88537 (view as bug list)
Depends on:
Blocks: mab4.3
  Show dependency treegraph
 
Reported: 2014-08-22 07:18 UTC by Jaise James
Modified: 2015-04-07 12:01 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Reference lost on drag (15.89 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-08-22 07:18 UTC, Jaise James
Details
drag1 (57.32 KB, image/jpeg)
2014-08-22 07:25 UTC, Jaise James
Details
before drag (56.48 KB, image/jpeg)
2014-08-22 07:26 UTC, Jaise James
Details
drag cell (58.49 KB, image/jpeg)
2014-08-22 07:26 UTC, Jaise James
Details
after drag cell formula (59.33 KB, image/jpeg)
2014-08-22 07:27 UTC, Jaise James
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jaise James 2014-08-22 07:18:02 UTC
references to different sheet get removed on dragging cell.

Reference changes to same sheet.

Step to produce.

1. enter some value in the cells [sheet1] 
2. create some formula using values entered in sheet1
3. create a reference in other sheet[sheet2] using formula referring sheet1
4. move the formula created in sheet1.
5. the formula eg. sheet1.A1 get lost on sheet 2 & become A1 only

Sample file attached. 
first formula cells on sheet2
move yellow cell on sheet 1

now check formula on sheet 2. all reference become lost.
Comment 1 Jaise James 2014-08-22 07:18:46 UTC
Created attachment 105077 [details]
Reference lost on drag
Comment 2 Jaise James 2014-08-22 07:25:40 UTC
Created attachment 105078 [details]
drag1
Comment 3 Jaise James 2014-08-22 07:26:18 UTC
Created attachment 105079 [details]
before drag
Comment 4 Jaise James 2014-08-22 07:26:48 UTC
Created attachment 105080 [details]
drag cell
Comment 5 Jaise James 2014-08-22 07:27:27 UTC
Created attachment 105081 [details]
after drag cell formula
Comment 6 ign_christian 2014-08-22 09:46:49 UTC
Reproduced with LO 4.3.1.1 - Ubuntu 12.04 x86

Also reproduced from scratch and with cut-paste. Undo not resolved original reference.

Not reproduced with LO 4.3.0.4, 4.3.0.0.beta1, 4.2.6.2
Comment 7 Eike Rathke 2014-08-22 10:49:44 UTC
I'm working on it.
Comment 8 Commit Notification 2014-08-22 11:05:09 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=75aad687cb5e63a41303aea568bf68b2b5f15d31

resolved fdo#82936 do not clear the 3D flag on refupdate



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 9 Eike Rathke 2014-08-22 11:28:46 UTC
Pending review
https://gerrit.libreoffice.org/11066 for 4-3
https://gerrit.libreoffice.org/11067 for 4-3-1
Comment 10 ign_christian 2014-08-22 11:48:32 UTC
Wow..fixed only in a couple minutes.. :)
Thanks Eike
Comment 11 Commit Notification 2014-08-22 16:05:54 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "libreoffice-4-3-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=756e729f0e8c37143971e83b0e89d9b6ca9d1289&h=libreoffice-4-3-1

resolved fdo#82936 do not clear the 3D flag on refupdate


It will be available already in LibreOffice 4.3.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 12 Commit Notification 2014-08-22 16:07:59 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "libreoffice-4-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=5ef430a700e67c4e5029f5af553c0ce8230b6e74&h=libreoffice-4-3

resolved fdo#82936 do not clear the 3D flag on refupdate


It will be available in LibreOffice 4.3.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 13 ign_christian 2014-08-28 16:32:38 UTC
Verify fixed with LO 4.3.1.2 - Ubuntu 12.04 x86
Comment 14 Eike Rathke 2014-11-07 18:09:14 UTC
*** Bug 85946 has been marked as a duplicate of this bug. ***
Comment 15 Eike Rathke 2014-11-07 18:30:52 UTC
This also crept into 4.2.7, the patch is pending review for 4-2 at https://gerrit.libreoffice.org/12304 but there's no 4.2.8 release scheduled.
Comment 16 Commit Notification 2014-11-09 07:22:09 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "libreoffice-4-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=1b0b80195802dd1e707f07e4825d6847ff810c73&h=libreoffice-4-2

resolved fdo#82936 do not clear the 3D flag on refupdate

It will be available in 4.2.7.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 17 Eike Rathke 2014-11-11 13:25:54 UTC
Clarification: this last fix will NOT be available in 4.2.7, that was an error of the notification script. If at all the fix would be available in 4.2.8 if that would be released.
Comment 18 Björn Michaelsen 2014-11-21 10:09:27 UTC
(In reply to Eike Rathke from comment #17)
> Clarification: this last fix will NOT be available in 4.2.7, that was an
> error of the notification script. If at all the fix would be available in
> 4.2.8 if that would be released.

Thanks Eike for the work here. Ubuntu users are invited to test the 1:4.2.7-0ubuntu2~ppa1 package from https://launchpad.net/~libreoffice/+archive/ubuntu/libreoffice-4-2 as there will be no more upstream 4.2 release.
Comment 19 Eike Rathke 2014-11-21 12:29:07 UTC
Ok, advertizing things ;-) this fix is part of Fedora libreoffice-4.2.7.2-6.fc20
Comment 20 Eike Rathke 2014-12-18 14:16:40 UTC
*** Bug 87446 has been marked as a duplicate of this bug. ***
Comment 21 m.a.riosv 2015-01-17 16:13:49 UTC
*** Bug 88537 has been marked as a duplicate of this bug. ***