Download it now!
Bug 82970 - MENU: Insert footnote button has incorrect tooltip of 'Insert Footnote/Endnote Directly'
Summary: MENU: Insert footnote button has incorrect tooltip of 'Insert Footnote/Endnot...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: low normal
Assignee: Not Assigned
URL:
Whiteboard: target:4.4.0
Keywords:
Depends on:
Blocks: Footnote-Endnote Writer-Toolbars
  Show dependency treegraph
 
Reported: 2014-08-22 20:09 UTC by Yousuf Philips (jay) (retired)
Modified: 2017-06-27 14:44 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2014-08-22 20:09:32 UTC
In the insert toolbar, there are buttons for inserting a footnote (.uno:InsertFootnote) and endnote (.uno:InsertEndnote). The insert footnote tooltip is 'Insert Footnote/Endnote Directly' and the insert endnote tooltip is 'Insert Endnote Directly'.
Comment 1 Julien Nabet 2014-08-23 09:04:11 UTC
On pc Debian x86-64 with master sources updated yesterday, I could reproduce this. It seems inherited from OOo

ux-advise:  The fix is obvious since it's there http://opengrok.libreoffice.org/xref/core/officecfg/registry/data/org/openoffice/Office/UI/WriterCommands.xcu#564 but could there be an explanation? Indeed it's very strange it has been like this since all this time.
Comment 2 Yousuf Philips (jay) (retired) 2014-08-23 14:17:49 UTC
I maybe mistaken but this should be set to NEW, as NEEDINFO is a status when more information is needed from the bug reporter. :)
Comment 3 Julien Nabet 2014-08-23 15:00:17 UTC
You're right Jay, I'll put it at NEW.
Comment 4 Adolfo Jayme 2014-08-23 15:46:36 UTC
I don’t think there is a logical explanation. Go ahead and JFDI ;)
Comment 5 Commit Notification 2014-08-23 17:36:31 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=02f6c270e79879188b2be670c6db4feb56bb064e

Resolves fdo#82970: Insert footnote button has incorrect tooltip



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 6 Adolfo Jayme 2014-08-23 18:20:53 UTC
Merci, Julien!
Comment 7 Yousuf Philips (jay) (retired) 2014-08-24 22:21:30 UTC
Thanks Julien for the fix.