Bug Hunting Session
Bug 83003 - Startcenter: no method to return to recent files window from template manager window
Summary: Startcenter: no method to return to recent files window from template manager...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.4.0.0.alpha0+ Master
Hardware: x86-64 (AMD64) Linux (All)
: high normal
Assignee: Efe Gürkan YALAMAN
URL:
Whiteboard: BSA target:4.4.0 ally
Keywords:
: 83628 (view as bug list)
Depends on:
Blocks: Start-Center-Accessibility
  Show dependency treegraph
 
Reported: 2014-08-24 08:47 UTC by Jean-Baptiste Faure
Modified: 2016-10-25 20:06 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jean-Baptiste Faure 2014-08-24 08:47:41 UTC
In the master (next 4.4) the template manager window opens in the startcenter instead of in its own external window. It's great but there is an issue because there is no mean to return to the recent files window. I suggest to add a button "Recent files" on the green sidebar, in the group "Open file", "Templates".

Best regards. JBF
Comment 1 Jean-Baptiste Faure 2014-08-24 08:51:43 UTC
Sorry, forgot some detail: to open the template manager in the startcenter window, you need to use the button "Templates" in the green sidebar (or its dropdown list). 
The menu entry in File > New > Templates opens the already known window.

Best regards. JBF
Comment 2 Adolfo Jayme 2014-08-24 20:24:45 UTC
I don’t think that the Templates window should be integrated *ever* to the Start screen. It just doesn’t belong there.
Comment 3 Efe Gürkan YALAMAN 2014-08-24 22:01:37 UTC
Hi, it is in work in progress right now. There are other improvements I have to do so I am putting it all together and then will push.

Also Adolfo I worked for whole summer for this. Please don't make my work go to trash. :P

Best,
Comment 4 V Stuart Foote 2014-08-25 15:46:35 UTC
On Windows 7 sp1, 64-bit en-US with
Version: 4.4.0.0.alpha0+
Build ID: 32ce5ae15a8f156b4681c36d248b6731df3457c6
TinderBox: Win-x86@42, Branch:master, Time: 2014-08-25_01:27:12

Only way to return to the Start Center from the "integrated" Template Manager is to select a template allow it to build and then cancel the document, or use a Create button for one of the document types and then cancel it.  Either way, there needs to be a way to return to the Start Center thumbnail view panel.

@Efe, hope your work also addresses needs of bug 77590
Comment 5 Efe Gürkan YALAMAN 2014-08-25 20:36:33 UTC
@Stuart no it doesn't at the moment but working on the start center is fun and there are a lot of things doable.
Comment 6 V Stuart Foote 2014-09-08 20:34:14 UTC
*** Bug 83628 has been marked as a duplicate of this bug. ***
Comment 7 Adolfo Jayme 2014-09-19 01:07:26 UTC
(In reply to comment #3)
> Also Adolfo I worked for whole summer for this. Please don't make my work go
> to trash. :P

Of course not ;) FTR, after analyzing it a bit and visualizing the final outcome, I’ve changed my mind :)
Comment 8 Yousuf Philips (jay) (retired) 2014-09-19 04:54:26 UTC
The suggestion i gave in my duplicate bug: when the template list is active, the template button is shown as pressed and when a user clicks it a second time, it goes back to document list mode.
Comment 9 V Stuart Foote 2014-09-20 15:28:21 UTC
@Efe, Kendy,*

Working with current master on Windows 7 sp1, 64-bit en-US
Version: 4.4.0.0.alpha0+
Build ID: be775a1ab40ccedfbc9659120b82867d6c128e6a
TinderBox: Win-x86@39, Branch:master, Time: 2014-09-19_18:16:31

Efe's work on the Template manager StartCenter looks real good, a functional GUI.

But, while there are GUI controls with mouse movement & selection, there is no keyboard control of the Glade .ui menu or dropdown, or the dialog with cursor (U,D,L,R), <Tab> or <Enter> keys. That is going to need to be added.
Comment 10 V Stuart Foote 2014-10-08 13:54:05 UTC
@Efe, Kendy
(In reply to V Stuart Foote from comment #9)
> @Efe, Kendy,*
> 
> Working with current master on Windows 7 sp1, 64-bit en-US
> Version: 4.4.0.0.alpha0+
> Build ID: be775a1ab40ccedfbc9659120b82867d6c128e6a
> TinderBox: Win-x86@39, Branch:master, Time: 2014-09-19_18:16:31
> 
> Efe's work on the Template manager StartCenter looks real good, a functional
> GUI.
> 
> But, while there are GUI controls with mouse movement & selection, there is
> no keyboard control of the Glade .ui menu or dropdown, or the dialog with
> cursor (U,D,L,R), <Tab> or <Enter> keys. That is going to need to be added.

Bump... 

And in addition to lack of keyboard navigation, once enter the Template views we get trapped there. Unable to get back to the Thumbnail views of recent items. 

Being stuck anywhere in the UI is a serious UX and a11y issue.
Comment 11 Adolfo Jayme 2014-10-08 18:17:30 UTC
Hey! No need to do "bumps" which only get to stress people out. Do not be annoying.
Comment 12 V Stuart Foote 2014-10-08 19:50:18 UTC
(In reply to Adolfo Jayme from comment #11)
> ...Do not be annoying.

Sorry, not trying intentionally to be annoying. However, I know Efe has gone back to class, and Kendy is as always being pulled in many directions with the .UI work and now wrangling the Design team.

Unfortunately the new UX of Template manager integrated with the Start Center needs additional attention.  There is time of course, but this continued lack of keyboard navigation presently is a substantial a11y regression in the Start Center, and makes for generally poor UX--its not done, simply calling Efe back to the task.

Setting the a11y trackers.
Comment 14 Caolán McNamara 2014-10-09 16:22:56 UTC
http://cgit.freedesktop.org/libreoffice/core/commit/?id=b5167e1866efb646270edce8b37894a93bea2cde should resolve comment #10 I believe

If there are outstanding problems after these commits please file separate bugs for them. The initial headline problem here was "no method to return to recent files" and there is now. Though if anyone wants to change it to a toggle instead of two buttons that's fine.
Comment 15 Yousuf Philips (jay) (retired) 2014-10-22 08:34:42 UTC
The button looks good, but is it possible to have an equal amount of space above and below the button so it looks better, as space above it is much larger than below it.
Comment 16 Caolán McNamara 2014-10-23 13:55:51 UTC
see http://cgit.freedesktop.org/libreoffice/core/commit/?id=e87a0ca94b173272f90242c2929b2a0d141acf40 for extra space removal