Bug Hunting Session
Bug 83006 - VIEWING: Problems with EB Garamond & Dolly Pro Font - Small Caps substituted for Normal
Summary: VIEWING: Problems with EB Garamond & Dolly Pro Font - Small Caps substituted ...
Status: RESOLVED DUPLICATE of bug 69254
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.3.0.4 release
Hardware: Other Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2014-08-24 10:18 UTC by Iandol
Modified: 2019-03-09 08:42 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot showing small caps being mis-rendered as regular. (141.42 KB, image/png)
2014-08-24 10:18 UTC, Iandol
Details
EB Garamond Specimen (215.98 KB, application/x-pdf)
2015-03-30 09:44 UTC, Volga
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Iandol 2014-08-24 10:18:17 UTC
Created attachment 105193 [details]
Screenshot showing small caps being mis-rendered as regular.

Problem description: I have a OTF font installed, called Dolly Pro by Underware, and it contains 4 family members: regular, italic, bold and smallcaps. The problem is with LibreOffice is that regular gets shown as smallcaps, and then it creates a non-existant bold-italic. All other software works fine with Dolly Pro and EB Garamond. EB Garamond has a small caps italic and regular variant.

Steps to reproduce:
1. Install EB Garamond http://www.georgduffner.at/ebgaramond/ https://bitbucket.org/georgd/eb-garamond/downloads
2. Start LibreOffice
3. Try to use the regular font

Current behavior: You always get Small caps, even though it calls it regular

Expected behavior: Ability to use font normally

              
Operating System: Mac OS X
Version: 4.3.0.4 release
Comment 1 Iandol 2014-08-24 10:29:12 UTC
Here is the direct download link for EB Garamond:

https://bitbucket.org/georgd/eb-garamond/downloads/EBGaramond-0.015d.zip

And the info for Dolly Pro:

PostScript name	DollyPro-Regular
	Full name	Dolly Pro Regular
	Family	Dolly Pro
	Style	Regular
	Kind	OpenType PostScript

PostScript name	DollyProRegularSC
	Full name	Dolly Pro Regular SC
	Family	Dolly Pro
	Style	Regular SmallCaps
	Kind	OpenType PostScript

PostScript name	DollyPro-RegularItalic
	Full name	Dolly Pro Regular Italic
	Family	Dolly Pro
	Style	Regular Italic
	Kind	OpenType PostScript

PostScript name	DollyPro-Bold
	Full name	Dolly Pro Bold
	Family	Dolly Pro
	Style	Bold
	Kind	OpenType PostScript
Comment 2 Iandol 2014-08-25 15:44:12 UTC
Note, that for EB Garamond, V0.016 has changed the family grouping to push the small-caps variant into a separate family, so the reproduction steps I posted require V0.015d of the font.
Comment 3 Yousuf Philips (jay) (retired) 2014-09-29 06:33:24 UTC
Hello Iandol,

Thank you for submitting the bug. A number of OTF font fixes were added to 4.3.2, so can you install it and test if the problem still continues.
Comment 4 Iandol 2014-09-29 06:57:54 UTC
Many thanks Jay, I've tested 4.3.2.2 and this issue is still present, for both EB Garamond V0.015d and Dolly Pro.
Comment 5 Yousuf Philips (jay) (retired) 2014-09-29 08:29:33 UTC
Hi Iandol,

Can you provide a screenshot for EB Garamond of where the problem is, as i dont have Dolly Pro installed on my linux installation. With the link you provided, i have the following list installed.

EB Garamond 08
EB Garamond 08 SC
EB Garamond 12
EB Garamond 12 All SC
EB Garamond 12 SC
EB Garamond Initials
EB Garamond Initials Fill1
EB Garamond Initials Fill2
Comment 6 Iandol 2014-10-05 07:39:12 UTC
I went to make the screenshot, and it does seem that EB Garamond is now working; though Dolly is still broken. I've found another font that still has this problem apart from Dolly, Fontin Sans. I've sent you Dolly privately.
Comment 7 Yousuf Philips (jay) (retired) 2014-10-26 11:06:40 UTC
Installed Dolly fonts you sent

DollyPro-Bold.otf
DollyPro-Regular.otf
DollyPro-RegularItalic.otf
DollyPro-RegularSmallCaps.otf

and libreoffice lists two entries for these fonts.

Dolly Pro
Dolly Pro Regular SC

So what i've seen is that Dolly Pro Regular and Dolly Pro Regular Italics were listed under Dolly Pro rather than being listed under Dolly Pro Regular SC.
Comment 8 retired 2014-10-26 13:43:47 UTC
Installed Dolly Pro temporarely on system to test this bug.

OSX Font manager says:
Regular
Regular SmallCaps
Regular Italic
Bold

LO Says:
Regular
Bold Italic
Regular Italic
Bold

So confirmed on 10.10 LO 4.3.3.1
Comment 9 Volga 2015-03-30 09:44:38 UTC
Created attachment 114461 [details]
EB Garamond Specimen

This specimen file was created by the author of EB Garamond, all the features as this file shown on are empowered by OpenType.
Comment 10 Christian Lohmaier 2015-09-01 14:39:31 UTC
dupe, the other one also lists other font to test with...

*** This bug has been marked as a duplicate of bug 87288 ***
Comment 11 Thomas Linard 2018-01-05 10:16:23 UTC

*** This bug has been marked as a duplicate of bug 35538 ***
Comment 12 Thomas Linard 2018-01-23 14:04:46 UTC

*** This bug has been marked as a duplicate of bug 69254 ***