Bug 83051 - Other: On a Form and with the Form Navigation toolbar the Find Record crashes Base while searching
Summary: Other: On a Form and with the Form Navigation toolbar the Find Record crashes...
Status: RESOLVED DUPLICATE of bug 83013
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
4.3.0.4 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: possibleRegression
Depends on:
Blocks:
 
Reported: 2014-08-25 10:29 UTC by Andrew
Modified: 2015-12-15 10:57 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
attachment-11904-0.html (2.28 KB, text/html)
2014-08-27 23:29 UTC, Andrew
Details
attachment-11904-1.dat (1 bytes, multipart/alternative)
2014-08-27 23:29 UTC, Andrew
Details
Subscribers Database - Test.odb (30.82 KB, application/vnd.sun.xml.base)
2014-08-27 23:29 UTC, Andrew
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andrew 2014-08-25 10:29:45 UTC
Problem description: When opening a Form and using the Find Record on the Form Navigation toolbar, it crashes Base while searching. Tried it on various commuters and had the same result. When reverted back to 4.2.6.2 all worked well again. 

Steps to reproduce:
1. Open a form
2. click on the Find Record on the Form Navigation toolbar
3. try different settings for the Where to search section
4. leave the Text at the Search for field box
5. enter a search text and execute it
6. most of the time it crashes.

Current behavior: crashes Base

Expected behavior: Finds searched text

              
Operating System: Windows 8
Version: 4.3.0.4 release
Last worked in: 4.2.6.2 release
Comment 1 Robert Großkopf 2014-08-25 18:47:31 UTC
Couldn't confirm any crash while searching in a form with LO 4.3.0.4. But I am using OpenSUSE 12.3 64bit rpm Linux. Could be a special Windows-Bug ...
Comment 2 Andrew 2014-08-26 00:50:48 UTC
I Tested it on a Win 7 64 bit desktop computer, Win 8.1 64 bit laptop, Win 8.1 64 bit 
desktop, 3 separate computers, and they all resulted the same crash. When uninstalled the 
4.3.0 or the 4.3.1 and installed 4.2.6 all was good again.

On 26/08/2014 04:47, bugzilla-daemon@freedesktop.org wrote:
> robert@familiegrosskopf.de <mailto:robert@familiegrosskopf.de> changed bug 83051 
> <https://bugs.freedesktop.org/show_bug.cgi?id=83051>
> What 	Removed 	Added
> CC 		robert@familiegrosskopf.de
>
> *Comment # 1 <https://bugs.freedesktop.org/show_bug.cgi?id=83051#c1> on bug 83051 
> <https://bugs.freedesktop.org/show_bug.cgi?id=83051> from robert@familiegrosskopf.de 
> <mailto:robert@familiegrosskopf.de> *
> Couldn't confirm any crash while searching in a form with LO 4.3.0.4. But I am
> using OpenSUSE 12.3 64bit rpm Linux. Could be a special Windows-Bug ...
> ------------------------------------------------------------------------------------------
> You are receiving this mail because:
>
>   * You reported the bug.
>
Comment 3 Robert Großkopf 2014-08-26 17:44:33 UTC
You updated from LO 4.2 to LO 4.3. Both use the same user-directory for LO.
Have you tried to rename the LO-user-directory? Must be here:  %appdata%\libreoffice\4\user
When you rename this directory (for example '4' to '4old') it will be rewritten next time.

Could be there is a little difference in the directory, which produces the crash. If it isn't the solution, you could delete the new created user-directory and rename the old back.
Comment 4 Andrew 2014-08-27 01:09:10 UTC
On one of my computers the first LO installation was 4.3 as I just built that computer 
last week so everything is a brand new installation on it. Yesterday I uninstalled LO 4.3 
on this and installed 4.2 and the problem with the search crash has gone away.
This machine has Windows 8.1 installed.

On 27/08/2014 03:44, bugzilla-daemon@freedesktop.org wrote:
>
> *Comment # 3 <https://bugs.freedesktop.org/show_bug.cgi?id=83051#c3> on bug 83051 
> <https://bugs.freedesktop.org/show_bug.cgi?id=83051> from robert@familiegrosskopf.de 
> <mailto:robert@familiegrosskopf.de> *
> You updated from LO 4.2 to LO 4.3. Both use the same user-directory for LO.
> Have you tried to rename the LO-user-directory? Must be here:
> %appdata%\libreoffice\4\user
> When you rename this directory (for example '4' to '4old') it will be rewritten
> next time.
>
> Could be there is a little difference in the directory, which produces the
> crash. If it isn't the solution, you could delete the new created
> user-directory and rename the old back.
> ------------------------------------------------------------------------------------------
> You are receiving this mail because:
>
>   * You reported the bug.
>
Comment 5 Caolán McNamara 2014-08-27 15:00:52 UTC
For reference I loaded https://issues.apache.org/ooo/attachment.cgi?id=65456 form "plants3", which has three entries and had no crash on trying different searching.

I think we need a small sample .odb that is guaranteed to reproduce this
Comment 6 Caolán McNamara 2014-08-27 19:43:59 UTC

*** This bug has been marked as a duplicate of bug 83013 ***
Comment 7 Andrew 2014-08-27 23:29:42 UTC
Created attachment 105359 [details]
attachment-11904-0.html

Hi,

This is the actual db that I use, and kept crashing, but with the removed and modified 
data, of course.
I did not check if this crashes base as I removed LO 4.3 and reinstalled 4.2 and with that 
it functions as it should.

On 28/08/2014 01:00, bugzilla-daemon@freedesktop.org wrote:
>
> *Comment # 5 <https://bugs.freedesktop.org/show_bug.cgi?id=83051#c5> on bug 83051 
> <https://bugs.freedesktop.org/show_bug.cgi?id=83051> from Caolán McNamara 
> <mailto:caolanm@redhat.com> *
> For reference I loadedhttps://issues.apache.org/ooo/attachment.cgi?id=65456
> form "plants3", which has three entries and had no crash on trying different
> searching.
>
> I think we need a small sample .odb that is guaranteed to reproduce this
> ------------------------------------------------------------------------------------------
> You are receiving this mail because:
>
>   * You reported the bug.
>
Comment 8 Andrew 2014-08-27 23:29:42 UTC
Created attachment 105360 [details]
attachment-11904-1.dat
Comment 9 Andrew 2014-08-27 23:29:42 UTC
Created attachment 105361 [details]
Subscribers Database - Test.odb
Comment 10 Alex Thurgood 2014-09-09 13:24:15 UTC
I see no toolbar in the form from the attached ODB when I open it in :

Version: 4.4.0.0.alpha0+
Build ID: a0b89100be8ccc2b60d08d7e3819cd247a6042b0

my own master build on OSX
Comment 11 Alex Thurgood 2014-09-09 13:28:23 UTC
OK, on another machine with a more recent dev build, I see the toolbar :

Version: 4.4.0.0.alpha0+
Build ID: 1444316d320d32ef3da1bfe5dcb6805e2e65cc08
Comment 12 Alex Thurgood 2014-09-09 13:32:31 UTC
just tried 30 iterations of searching for "cust" in Lastname, no crash
Comment 13 Alex Thurgood 2014-09-09 13:33:03 UTC
tested on osx 10.9.4
Comment 14 Andrew 2014-09-09 22:59:00 UTC
Have you tested on Windows os? This proplem appeared on all my windows os computers. I do 
not have a mac so I cannot test it on that os.
On 9/09/2014 23:33, bugzilla-daemon@freedesktop.org wrote:
>
> *Comment # 13 <https://bugs.freedesktop.org/show_bug.cgi?id=83051#c13> on bug 83051 
> <https://bugs.freedesktop.org/show_bug.cgi?id=83051> from Alex Thurgood 
> <mailto:iplaw67@yahoo.co.uk> *
> tested on osx 10.9.4
> ------------------------------------------------------------------------------------------
> You are receiving this mail because:
>
>   * You reported the bug.
>
Comment 15 Robinson Tryon (qubit) 2015-12-15 10:57:43 UTC
Migrating Whiteboard tags to Keywords: (possibleRegression)
[NinjaEdit]