Bug 83216 - Macros: Periodically unable to edit macro, but able to run macro
Summary: Macros: Periodically unable to edit macro, but able to run macro
Status: RESOLVED DUPLICATE of bug 83218
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: BASIC (show other bugs)
(earliest affected) release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
Whiteboard: BSA
Keywords: possibleRegression
Depends on:
Reported: 2014-08-29 02:53 UTC by bordmail4
Modified: 2015-12-15 10:57 UTC (History)
0 users

See Also:
Crash report or crash signature:

ods file with embedded macro that displays the problem (211.06 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-08-29 02:53 UTC, bordmail4

Note You need to log in before you can comment on or make changes to this bug.
Description bordmail4 2014-08-29 02:53:31 UTC
Created attachment 105402 [details]
ods file with embedded macro that displays the problem

Problem description: 
Updated from an old 4104 version to this new 4304 and I have repeteadly encountered since then this bug (i guess it's a bug):
- at startup the next day, after opening a ods file (attached) with an embedded macro that worked the previous day, Libre Office displays the recovery screen if I try to edit the macro, through either Tools/Macros/organize/basic.. or Tools/Organize Dialogs/ modules... Problem repeats every time I try to edit the macro, though each recovery is done without problems. Running the macro works fine from the start so I guess it's not a missing library.

- the problem persists until I open another ods file with an unrelated but similar macro. There is no data relation between the 2, all data needed to run is contained in each file

I've not tried opening first another macro each day
I'm attaching the file.

Hope you get this fixed.

Operating System: Windows 7
Version: release
Last worked in: release
Comment 1 Jacques Guilleron 2014-08-31 16:22:36 UTC
Hi bordmail4,

As said in the next report, you previously send this one.
Since this is the same, I set it as Duplicate.



*** This bug has been marked as a duplicate of bug 83218 ***
Comment 2 Robinson Tryon (qubit) 2015-12-15 10:57:48 UTC
Migrating Whiteboard tags to Keywords: (possibleRegression)