Download it now!
Bug 83272 - FILEOPEN: Line style generally not preserved by SVG import
Summary: FILEOPEN: Line style generally not preserved by SVG import
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
4.2.4.2 release
Hardware: Other All
: medium major
Assignee: Not Assigned
URL:
Whiteboard: confirmed:4.3.4.1:Windows
Keywords: filter:svg
Depends on:
Blocks: Shapes-Line
  Show dependency treegraph
 
Reported: 2014-08-30 13:54 UTC by Hans Breuer
Modified: 2018-06-24 09:35 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
zip file containing render-test.* exhibiing the line style problem (247.67 KB, application/zip)
2014-08-30 13:54 UTC, Hans Breuer
Details
inkscape-0.92.2-svg-print (220.20 KB, application/pdf)
2017-09-20 23:39 UTC, paulystefan
Details
rendertest.svg import in LOO DRAW 5.4.2.1-64 export in PDF (127.84 KB, application/pdf)
2017-09-20 23:43 UTC, paulystefan
Details
LO 6.0.0 hybird PDF of render-test.svg from attachment 105465 (290.35 KB, application/pdf)
2017-09-21 00:56 UTC, V Stuart Foote
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Hans Breuer 2014-08-30 13:54:02 UTC
Created attachment 105465 [details]
zip file containing render-test.* exhibiing the line style problem

All format tests with render-test from Dia lead to a loss of line style information. Import via PDF, SVG, CGM, WMF, WPG file and copy&paste per GDI Metafile all lead to (almost) solid lines no matter if the input line was dotted, dashed or something more complex. With SVG it seems to be an issue with wrongly scaled dash length.

My tests with other applications supporting these formats let me assume a general LibreOffice problem.
Comment 1 Buovjaga 2014-11-13 12:40:35 UTC
Reproduced. PDF is fine, though.

Win 7 64-bit Version: 4.4.0.0.alpha2+
Build ID: b021b5983c62e266b82d9f0c5c6d8d8900553827
TinderBox: Win-x86@39, Branch:master, Time: 2014-11-12_01:10:08

Ubuntu 14.10 64-bit Version: 4.4.0.0.alpha2+
Build ID: 5bff4b016c4b44f4123e0e6a4fd4c0c4dc0cfa2d
TinderBox: Linux-rpm_deb-x86_64@46-TDF-dbg, Branch:master, Time: 2014-11-13_00:14:29
Comment 2 V Stuart Foote 2014-11-13 18:49:43 UTC
On Winows 7 sp1, 64-bit en-US with
Version: 4.3.4.1
Build ID: bc356b2f991740509f321d70e4512a6a54c5f243

@Hans, could you attache the actual Dia diagram you worked with? If you can make it fully CC license that is a nice test case for devs to work with.

@Beluga, if you look close the PDF does have a few issues when opened in Draw, look at the the Dashlen 0.4 corners--good when compared to PDF opened in Adobe Reader and much better than the other graphics formats. But what did it look like in the original Dia diagram?

Filter import of SVG text objects is a problem as in bug 77268, but the line styles are borked there as well.

-=-note-=-
I noticed that DIA installs Windows shell menu items to do the Exports to these formats and more when a .Dia document is selected in Explorer, but most are export only formats from DIA.  Still a useful tool for generating vector sample files.
Comment 3 V Stuart Foote 2014-11-13 18:52:32 UTC
Sorry, thining about it. Reworking these filters is more of an issue than just a needed enhancement. But suspect it would not be a simple issue to resolve.

Setting medium/major
Comment 4 vvort 2014-11-14 05:14:53 UTC
Surprisingly, pdf import is almost perfect (tested with clipping).
Corner glitches are not pdf import problem.
The same effect you will see if create dashed line by yourself.
Comment 5 Robinson Tryon (qubit) 2015-12-03 11:05:42 UTC
Converting Whiteboard tags to Keywords: filter:pdf
Comment 6 David Tardon 2015-12-03 12:07:46 UTC
Please open a separate bug for each format, unless you are really sure the problem is in some common layer. Which is rather doubtful. E.g., the WPG file is not imported as expected because libwpg does not support line stroke other than solid for WPG1 format.
Comment 7 QA Administrators 2017-09-01 11:16:36 UTC Comment hidden (obsolete)
Comment 8 paulystefan 2017-09-20 23:39:06 UTC
Created attachment 136411 [details]
inkscape-0.92.2-svg-print

in inkscape shows display and print pdf all allright
Comment 9 paulystefan 2017-09-20 23:43:04 UTC
Created attachment 136412 [details]
rendertest.svg import  in LOO DRAW 5.4.2.1-64 export in PDF

rendertest.svg import  in LOO DRAW 5.4.2.1-64 export in PDF 

many errors in lines and fonts size
Comment 10 V Stuart Foote 2017-09-21 00:56:11 UTC
Created attachment 136415 [details]
LO 6.0.0 hybird PDF of render-test.svg from attachment 105465 [details]

(In reply to paulystefan from comment #9)
> Created attachment 136412 [details]
> rendertest.svg import  in LOO DRAW 5.4.2.1-64 export in PDF
> 
> rendertest.svg import  in LOO DRAW 5.4.2.1-64 export in PDF 
> 
> many errors in lines and fonts size

Yes, that is opening into Draw. I had similar results with 5.4.2.1 & 6.0.0

But, try it with Insert -> Image, it uses a different filter and is at least as good as Inkscape.  Hybird PDF attached (w/ embedded ODG) open in draw or a PDF reader of your choice.
Comment 11 Roman Kuznetsov 2018-06-22 14:45:36 UTC
files SVG and PDF from render-test.zip opens fine in LO Draw 6.1 beta 2 (menu File->Open)

hybrid PDF from V Stuart Foote opens in LO Draw 6.1 beta 2 (menu File->Open) very fine too

but files .cgm and .wpg opens with wrong rendering

may be need create other bug for .cgm and .wpg files?
Comment 12 Buovjaga 2018-06-24 09:35:28 UTC
Let's close.

Created bug 118340 for CGM and bug 118341 for WPG