Download it now!
Bug 83278 - Missing type of directory at "Tools - Options - LibreOffceDev - Paths"
Summary: Missing type of directory at "Tools - Options - LibreOffceDev - Paths"
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.4.0.0.alpha0+ Master
Hardware: All Linux (All)
: high major
Assignee: Not Assigned
URL:
Whiteboard: target:4.4.0
Keywords: regression
Depends on:
Blocks: Options-Dialog-Paths
  Show dependency treegraph
 
Reported: 2014-08-30 15:50 UTC by Thomas Hackert
Modified: 2017-07-24 15:32 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Hackert 2014-08-30 15:50:00 UTC
Hello @ll,
I hope, I have chosen the right component and all. If not, feel free to change it adequate ... ;)

While I was configuring my parallel installed Version: 4.4.0.0.alpha0+ Build ID: 1298c1d13572c6fbfbabb813b2d6843368c6df1f TinderBox: Linux-rpm_deb-x86@45-TDF, Branch:master, Time: 2014-08-29_00:42:19 (following the instructions from https://wiki.documentfoundation.org/Installing_in_parallel) and with the en_US lang- as well as helppack under Debian Testing I discovered the following:

1. Start LO
2. Go to "Tools – Options", then LibreOfficeDev – Paths"

On my system, all of the different type of directories (AutoCorrect, AutoText, Backups, etc.) are missing there ... :(

I have reported it to our qa ml, where Robert confirmed it with OpenSuse 64Bit (see http://nabble.documentfoundation.org/Libreoffice-qa-Type-of-directories-missing-in-quot-Tools-Options-LibreOfficeDev-Paths-quot-in-4-4-0--td4120768.html for the thread), but I am not sure, if I should change architecture to "All" ... :(

Sorry for the inconvenience and have a nice evening
Thomas.
Comment 1 Robert Großkopf 2014-08-30 17:47:53 UTC
Could confirm that the directories are missing for the paths.

My System: OpenSUSE 64bit rpm Linux,
tested with LO 4.4.0.0alpha from 2014-08-23
Comment 2 Julien Nabet 2014-08-30 21:40:54 UTC
On pc Debian x86-64 with master sources updated today, I could reproduce this.
Comment 3 Commit Notification 2014-08-30 23:08:31 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=880c18f23068a1faf34f36a67161e3b85fffdea7

Resolves fdo#83278: Missing type of directory at "Tools/Options/LODev/Paths"



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 4 Julien Nabet 2014-08-30 23:12:54 UTC
Thomas: I just reverted your patch to quickly fix (because quite visible) this but perhaps I missed something and there's another way.
In this case, don't hesitate to revert my commit and fix this the good way.
Comment 5 Thomas Arnhold 2014-08-31 07:14:14 UTC
Hm, sorry for this. I did test this and it worked, but maybe the resource file didn't get updated because I only did an incremental rebuild. Tough string stuff...
Comment 6 Robert Großkopf 2014-08-31 16:28:32 UTC
Have just installed this version:
Version: 4.4.0.0.alpha0+
Build ID: 880c18f23068a1faf34f36a67161e3b85fffdea7
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2014-08-30_23:30:44

There the paths appear.

When I look at date and time it couldn't have anything to do with the fix of Julian ...
Comment 7 Julien Nabet 2014-08-31 16:34:16 UTC
Robert: if I use buildid from your build version to search on cgit, I've got this:
http://cgit.freedesktop.org/libreoffice/core/log/?qt=range&q=880c18f23068a1faf34f36a67161e3b85fffdea7
Patch commited 2014-08-30 23:06:43 (GMT)
If the build retrieved is also GMT, 2014-08-30_23:30:44, it's ok.

Did I miss something?
Comment 8 Thomas Arnhold 2014-08-31 17:12:25 UTC
Julian, you're right.

Robert: The build id is the last commit id. Upon this commit id the build is made, so Julians commit is exactly the last one in :)
Comment 9 Robert Großkopf 2014-08-31 17:38:22 UTC
Ok, haven't known how to check if the bug is fixed in a version. Have only read "in the next 24-48 hours" and then counted from Julians commit to the version I have downloaded ... only 22 minutes instead of 24 hours.

Thanks for the explanations.