Bug Hunting Session
Bug 83320 - UI: Enable/disable Draw toolbar, makes a button in the toolbar appear and then disappear after the toolbar is shown
Summary: UI: Enable/disable Draw toolbar, makes a button in the toolbar appear and the...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.6.2 release
Hardware: Other All
: medium normal
Assignee: Maxim Monastirsky
URL:
Whiteboard: BSA target:6.0.0
Keywords:
Depends on:
Blocks: Toolbars
  Show dependency treegraph
 
Reported: 2014-08-31 23:04 UTC by marcosgdf
Modified: 2017-09-24 23:09 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Video of the problem (410.67 KB, video/quicktime)
2014-08-31 23:04 UTC, marcosgdf
Details

Note You need to log in before you can comment on or make changes to this bug.
Description marcosgdf 2014-08-31 23:04:37 UTC
Created attachment 105520 [details]
Video of the problem

Problem description: 
When I enable the drawing tools toolbar, the toolbar is displayed and 1 ms later a button of the toolbar disappears, making the rest of them move to the left immediately after the toolbar is shown.

Steps to reproduce:
1. Enable/disable Drawing toolbar

Current behavior: Appear and disappear a button after showing the toolbar

Expected behavior: Final toolbar composition when toolbar is shown

              
Operating System: Mac OS X
Version: 4.3.1.2 release
Comment 1 Yousuf Philips (jay) (retired) 2014-09-14 00:45:38 UTC
Hello marcosgdf,

Thank you for submitting the bug. I can confirm this issue happens in 4.1.6 and master and it has been around since the 4.1.x releases. When the drawing toolbar is shown, it is automatically hides the vertical text and vertical callouts buttons, which causes this behaviour. I'm not sure if its possible to hide buttons from the toolbar before the toolbar is visible, but will await feedback from the development team to know if this is fixable.
Comment 2 Robinson Tryon (qubit) 2014-09-25 21:40:51 UTC
Bug is confirmed and status is NEW -> Removing need*Advice tags from the whiteboard.
Comment 3 Yousuf Philips (jay) (retired) 2014-11-08 14:22:16 UTC
This hiding of buttons also happens when you right-click and customize the toolbar by adding or removing entries in the 'Visible Buttons' submenu.
Comment 4 QA Administrators 2015-12-20 16:18:15 UTC Comment hidden (obsolete, spam)
Comment 5 QA Administrators 2017-01-03 19:49:59 UTC Comment hidden (obsolete, spam)
Comment 6 Commit Notification 2017-09-24 22:05:07 UTC
Maxim Monastirsky committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=fb60217569b0fb5bc949c58b054da71992fe2582

tdf#83320 Hide vertical text commands early

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.