Bug 83364 - UI: Help information missing in the Outline & Numbering tab of Paragraph Style window
Summary: UI: Help information missing in the Outline & Numbering tab of Paragraph Styl...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Documentation (show other bugs)
Version:
(earliest affected)
4.2.5.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium enhancement
Assignee: sdc.blanco
URL:
Whiteboard: target:6.5.0
Keywords:
Depends on:
Blocks: Chapter-Numbering
  Show dependency treegraph
 
Reported: 2014-09-01 18:58 UTC by Albrecht Müller
Modified: 2020-01-03 23:39 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
example of Chapter Numbering used to make chapter and appendix structure (11.60 KB, application/vnd.oasis.opendocument.text)
2020-01-02 04:33 UTC, sdc.blanco
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Albrecht Müller 2014-09-01 18:58:13 UTC
In the Outline & Numbering tab of the Paragraph Style window there a controls to define the outline level and the numbering style of a paragraph. This may not work as expected as there are two different concepts of how the numbering for some paragraph works. Therefore the user may need help information at this point.

To see the problem, press F11 to get the Styles and Formatting window, and press the Paragraph Styles button. Right click on some style offered there and choose modify to open the Paragraph  Style window. Select the Outline & Numbering tab. You will see somethink as shown in attachment 105322 [details] or attachment 105323 [details] of bug 83071. The controls are disabled if the paragraph is some header style that can be changed using the Tools -> Outline Numbering window. They are enabled for other paragraph styles. The user may want to change the outline style and is not aware that there is something like the Outline Numbering tool. The only thing he or she sees are disabled controls. So how it is possible to change the outline style. On the other hand the user may want to define a header style. He or she sees the controls enabled, selects the outline level and the numbering style and will notice, that this does not work as expected: The outline level will not match the corresponding level in the list style used for numbering. In both cases the user may try to get help using the help button.

What he or she will see is something like attachment 105324 [details] belonging to bug 83071, i.e. no useful information.

You may also have a look at bug 62032 to find someone else who fell into this trap.

The expected behaviour is that there is useful help information which explains that

a) You cannot define Outline Numbering using this window. You have to use the Tools -> Outline Numbering window for that purpose. That is why the controls are disabled.

b) If you define both an outline level and a list style, these things are independent of each other and serve different purposes. The outline level can be used to include this paragraph style in the table of contents in addition to the "standard" header styles. The numbering level that is shown at some paragraph is not controlled by the outline level of the paragraph style (specified in the outline level control above) but set for each paragraph individually using the tab key at the beginning of a line. This works the same way for paragraph styles that define some outline level and those that represent body text. 

Observed with LibreOffice version 4.2.5.2 and Windows 7.
Comment 1 Buovjaga 2014-11-13 12:26:17 UTC
Sounds like a reasonable enhancement -> NEW.
Comment 2 Commit Notification 2019-12-29 10:29:17 UTC
Seth Chaiklin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/help/commit/6164605732b852f76c60bd9d64a7651a27591763

tdf#83364 corrections/additions to Outline and Numbering help page
Comment 3 sdc.blanco 2019-12-29 17:34:40 UTC
(In reply to Albrecht Müller from comment #0)
 
> The expected behaviour is that there is useful help information which
> explains that...

See https://help.libreoffice.org/6.5/en-US/text/swriter/01/05030800.html

(under Edit Style)

Maybe this is sufficient for closing this bug?
Comment 4 Albrecht Müller 2020-01-01 17:55:38 UTC
(In reply to sdc.blanco from comment #3)
> (In reply to Albrecht Müller from comment #0)
>  
> > The expected behaviour is that there is useful help information which
> > explains that...
> 
> See https://help.libreoffice.org/6.5/en-US/text/swriter/01/05030800.html
> 
> (under Edit Style)
> 
> Maybe this is sufficient for closing this bug?

OK, I think the major problems have been fixed: In Version 6.0.4.2 the help button brings up some reasonable help information. The 6.5 version of the help information contains the information that gives the user a chance to find the right place to change the settings. Maybe a hint in some tooltip could make things still easier for the (novice) user.

What I still miss is a more comprehensive explanation of the numbering concepts and of its limitations. This explanation could save the user the time to find out these concepts and limitations by trial and error - there is a pretty big space to search and I guess there are some bug reports related to this problem. I try to sketch out what such a explanation should contain. Note the information in this sketch may be wrong due to my limited knowledge. I did not include the description of some use cases that may take advantage of various features or best practices to overcome limitations.

LibreOffice Writer supports two hierarchical numbering systems: chapter numbering and numbering styles. Despite the fact that their properties are pretty similar they serve different purposes and therefore behave differently.

The chapter numbering system is intended to reflect the global structure of a document. Therefore you can define only a single chapter numbering system for a given document. Numbering styles are intended to deal with structured content within some parts of the document. The structure of this content is assumed to be unrelated to the structure of the document. Therefore it is possible to use an arbitrary number of different numbering styles in the same document. 

There are different user interfaces for both systems: The Chapter Numbering Dialogue (reachable by Tools -> Chapter Numbering...) allows to define the properties of the single chapter numbering system.

Numbering styles are identified by their names. There is a numbering style dialogue that allows to define the properties of each style. You can open this dialogue from the Styles and formatting window (to open this window choose Styles ->  Manage Styles or press F11). Select the list styles display, bring up the context menu of the style to change and choose "Modify...".

You will get the same dialogue to edit the numbering style associated with some paragraph if you open the "Paragraph Style" dialogue, choose the "Outline & Numbering" tab and press "Edit Style" button.

There are also separate user interfaces to change the structure of the content:

To assign a hierarchy level to a chapter heading use CTRL+0 ... CTRL+9 or use the "Headings" part in the navigator. In addition to promoting and demoting the hierarchy level (called "outline level" in this case) the navigator allows to rearrange chapters.

To change the hierarchy level of a numbering style use the "Increase indent" or "Decrease indent" buttons in the formatting toolbar or the entries in the Format -> Lists submenu. The functions there are roughly the same as those found in the navigator but the work on number formats instead of the chapter numbering. The context menu opened at the end of a line also allows to promote and demote numbering styles. 

If the cursor is at the beginning of some line you can demote and promote the hierarchy level using the TAB or SHIFT+TAB keys respectively. This works for both systems. Note that this methods works differently if you apply it to the first header or the first numbered paragraph. In this case is does not demote or promote the hierarchy level but changes the indentation of all paragraphs that take part in the numbering.

There is a limitation in the chapter numbering system such that you cannot define a common document structure like the following:

1. Chapter one
2. Chapter two
...
m. Chapter m
A1. Appendix one
A2. Appendix two
...
An. Appendix n

(maybe I am wrong - but I still have to find a straightforward way to define this kind of outline. Numbering styles have the same limitation but in this case it is easy to work around this problem. You may simply define an additional numbering style for the appendix. Note: As this is not the intended use of numbering styles this approach has the problem that outline level and numbering level may get out of sync.)

Chapter numbering is relevant for the table of contents and the Navigator, numbering styles are not. Nevertheless numbering styles may appear in the table of contents and in the Navigator as part of the paragraph they belong to.

The outline level controls the hierarchical position in the table of contents and in the Navigator. If the paragraph format is part of the chapter numbering system then it also controls its numbering. The outline level does _not_ affect the numbering level of a paragraphs numbering style. This is the general rule. There are some special cases:

For any outline level you can define at most one paragraph style in the chapter numbering system. But you can have an arbitrary number of paragraph styles at the same outline level. They behave differently in various respects:

If a paragraph style is in the chapter numbering system then demoting and promoting  in the Navigator assigns a different paragraph style to the corresponding paragraph. You cannot change its outline level using the paragraph format dialogue: You have to use the chapter numbering dialogue. These paragraphs generate at most one entry in the table of contents.

If this paragraph is not part of the chapter numbering system then demoting and promoting changes the outline level of this paragraph but does not assign a different paragraph style. This  paragraph may appear in the table of contents twice: One entry corresponds to its outline level. The other may appear at the position that you specify for its paragraph style in the table of contents.

As the outline level and the numbering level of a numbering style are independent of each other changing the outline level of some paragraph does not affect its numbering: You have to promote or demote the numbering level in a separate step. It is possible that this paragraph is also part of of the chapter numbering system. If these two systems are really independent then this paragraph should get two numbers. One should come from the chapter numbering and one from the numbering style. But only one number is shown. I was not able to find out the semantics of this case: The relation between chapter numbering and numbering style is unclear. Note: Promoting and demoting in the Navigator changes the paragraph style which causes the numbering to change. This somehow seems to affect the level of the numbering style too.

There are a couple of situations where there is a transfer of numbering styles or chapter numbering to other locations. It is possible to import styles, e.g. numbering styles, from other Writer documents. But I still have to find a way how I can do the same with definitions of chapter numbering.

The Cut/Copy & Paste or Drag & Drop mechanisms will - among other things - allow to transfer numbering information to other positions in the same document, to some other Writer document, to documents of different components of LibreOffice such as Calc, Impress or Draw. This kind of information may come from or go to applications that are not related to LibreOffice: web browsers, Microsofts Word Pad or Microsoft Office, PDF readers ... to name a few.

LibreOffice also supports importing from and exporting to various document formats such as plain text, RTF, various Microsoft Word Formats, HTML etc.

These sources and targets may support concepts that are similar to LibreOffice's chapter numbering or numbering style systems. Details may differ and this can cause loss of numbering information during the conversion process. If interoperability is a concern some kind of cross reference could be useful that tells which information will be lost and which will preserved in various conversion processes.

I assume there are various issues to discuss in the context of master documents but I did not use this kind of documents yet.
Comment 5 sdc.blanco 2020-01-02 04:33:05 UTC
Created attachment 156890 [details]
example of Chapter Numbering used to make chapter and appendix structure
Comment 6 sdc.blanco 2020-01-02 04:40:00 UTC
(In reply to Albrecht Müller from comment #4)
> 
> There is a limitation in the chapter numbering system such that you cannot
> define a common document structure like the following:
> 
> 1. Chapter one
> 2. Chapter two
> ...
> m. Chapter m
> A1. Appendix one
> A2. Appendix two
> ...
> An. Appendix n
> 
Attachment 156890 [details] uses only Chapter Numbering to produce this structure. Maybe it is an exemplar of what you are seeking?
Comment 7 Albrecht Müller 2020-01-02 20:33:21 UTC
(In reply to sdc.blanco from comment #6)
> (In reply to Albrecht Müller from comment #4)
> > 
> > There is a limitation in the chapter numbering system such that you cannot
> > define a common document structure like the following:
> > 
> > 1. Chapter one
> > 2. Chapter two
> > ...
> > m. Chapter m
> > A1. Appendix one
> > A2. Appendix two
> > ...
> > An. Appendix n
> > 
> Attachment 156890 [details] uses only Chapter Numbering to produce this
> structure. Maybe it is an exemplar of what you are seeking?

Nice workaround - thank you for the idea. I did not think this way yet and tried to use numbering styles.

Both solutions are not what I would consider "straightforward" as they both introduce some strange behaviour. Using numbering styles allows numbering and outline level to go out of sync. Your approach does not reflect the document structure. In your example document the appendices technically are part of Chapter IV. If you move this chapter to some other place the appendices will go to that place too, i.e. leave their place at the end of the document. You have to reserve some outline levels for use in the the appendices and cannot use them in the main text.

The help function should explain these limitations and discuss some workarounds and enable the user to choose one that suits best his or her needs.

A better solution would be to unify chapter numbering and numbering styles. Numbering styles should allow to associate paragraph styles with hierarchy levels. This eliminates the need for a separate chapter numbering dialogue: The numbering style used for chapter numbering is defined in the first heading.

The paragraph  format contains an option that allows to restart the numbering at the  paragraph it belongs to. This option could be extended such that it restarts the chapter numbering with a different numbering style, for example with some numbering style designed for the appendix. Based on the assumption that the second chapter of an appendix still belongs to the appendix if it is moved before the first one the instruction to use a new numbering style should be transferred to the chapter that is now the first in the appendix. Note: This is different from the current behaviour that is used for the instruction to restart numbering. This instruction seems to move together with the paragraph.
Comment 8 sdc.blanco 2020-01-03 23:39:44 UTC
(In reply to Albrecht Müller from comment #4)
 
> OK, I think the major problems have been fixed: In Version 6.0.4.2 the help
> button brings up some reasonable help information. The 6.5 version of the
> help information contains the information that gives the user a chance to
> find the right place to change the settings. 

Sounds good.  So I will close this bug.

> Maybe a hint in some tooltip
> could make things still easier for the (novice) user.

File a new enhancement report when you have concrete/specific suggestions.  The more specific, the better (e.g., specific locations, specific suggested text).