Bug 83378 - VIEWING: Fullscreen: Black screen when closing (not quit) any full screen window from LibreOffice on Mac OS X
Summary: VIEWING: Fullscreen: Black screen when closing (not quit) any full screen win...
Status: RESOLVED DUPLICATE of bug 72490
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.3.1.2 release
Hardware: Other Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
: 91861 95426 104723 (view as bug list)
Depends on:
Blocks: Matters-to-Caolan Full-Screen-Mode
  Show dependency treegraph
 
Reported: 2014-09-01 23:00 UTC by js.fr
Modified: 2018-04-02 11:50 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
Image showing the bug cluttering effect (659.02 KB, image/png)
2016-04-17 14:03 UTC, guillaumelasne0
Details

Note You need to log in before you can comment on or make changes to this bug.
Description js.fr 2014-09-01 23:00:01 UTC
Problem description: 
All in the subject: "Black screen when closing (not quit) Writer file while in full screen on Mac OS X 10.9.4"

Steps to reproduce:
1. Open a Writer file
2. Switch it into full screen
3. Close the window (cmd + W)

Current behavior:
Keep a black full screen without any useful thing

Expected behavior:
Close the current fullscreen totally and eventually go to the next open LibreOffice document or to the LibreOffice Launcher on the main desktop.
              
Operating System: Mac OS X
Version: 4.3.1.2 release
Comment 1 retired 2014-09-02 17:38:18 UTC
Confirmed same OS and LO versions -> NEW
Comment 2 marcosgdf 2014-10-20 22:03:27 UTC
Confirmed Mac OS X 10.10
Comment 3 Fedelosa 2014-12-24 17:08:03 UTC
Same thing with 

Versión: 4.3.5.2
in a MacBook Air 11 inch with OSX 10.10.1
Comment 4 Erkan 2015-08-24 12:23:20 UTC
Here is here problem. I have test 4.4 and 5.x of LibreOffice. This isn't still fix. To who of the developer can you inform that he/she can fix this bugs?
Comment 5 Alex Thurgood 2015-10-12 10:20:54 UTC
*** Bug 91861 has been marked as a duplicate of this bug. ***
Comment 6 Jonathan Price 2015-10-20 10:29:07 UTC
Facing same problem - OS X El Capitan 10.11. LibraOffice Version: 5.0.2.2. Also faced same problem in Yosemite
Comment 7 raal 2015-11-14 20:42:06 UTC
*** Bug 95426 has been marked as a duplicate of this bug. ***
Comment 8 YogiD 2015-12-14 15:25:17 UTC Comment hidden (me-too)
Comment 9 Gellimac 2016-02-12 09:38:16 UTC
Same issue for me in LO 5.0 and mac 10.10.5
Comment 10 guillaumelasne0 2016-04-17 14:03:04 UTC
Created attachment 124431 [details]
Image showing the bug cluttering effect
Comment 11 guillaumelasne0 2016-04-17 14:07:23 UTC
The bug is not only for writer but also for calc, impress, draw, math and the start menu. Every time you close a fullscreen LibreOffice window on Mac you have a black screen, cluttering your 4 finger swipe with no apparent limit on how many you can have. Still not working on LibreOffice Vanilla 5.1.2.2 fresh install.
Comment 12 ace_dent 2016-05-10 11:51:12 UTC
Tested with: Mac OS X El Capitan 10.11.4 (15E2066) with LibreOffice Version: 5.1.2.2
Build ID: d3bf12ecb743fc0d20e0be0c58ca359301eb705f
CPU Threads: 4; OS Version: Mac OS X 10.11.4; UI Render: default.

It seems using the native OSX full-screen behaviour (which now puts the zoomed in window in it's own space), is broken. The central issue is how LO handles Spaces on OSX.

Workaround: Double click on the window's title bar to maximise the window (like 'full screen' in earlier OSX versions).

Related, possibly duplicated, issues ~ 
Missing menu bar: #53282, #76476, #96134, #97402, #97709.
Extra blank screen (black- was grey): #72490, #83378, #96134.
General: #85259, #95362.
Comment 13 Franklin Weng 2016-12-17 08:41:23 UTC
*** Bug 104723 has been marked as a duplicate of this bug. ***
Comment 14 Franklin Weng 2016-12-17 08:42:43 UTC
Still exists in 5.3.0.0 Beta2
Comment 15 QA Administrators 2017-12-18 03:26:53 UTC Comment hidden (obsolete)
Comment 16 js.fr 2017-12-18 22:54:48 UTC
The bug is still present.
Version: 6.0.0.0.beta2
Build ID: 13edaaa12f25de343fce136064e27da66c1c4fa4
Threads CPU : 4; OS : Mac OS X 10.13.2; UI Render : GL; 
Locale : fr-FR (fr_FR.UTF-8); Calc: group threaded
Comment 17 eisa01 2018-04-02 11:50:19 UTC
This is a duplicate

*** This bug has been marked as a duplicate of bug 72490 ***