Bug 83455 - UI: Sidebar > Properties > Character: underline dropdown barely viewable (white underlines instead of black) only using Sifr icon set
Summary: UI: Sidebar > Properties > Character: underline dropdown barely viewable (whi...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.3.1.2 release
Hardware: Other All
: low minor
Assignee: Adolfo Jayme
QA Contact:
URL:
Whiteboard: target:5.3.0 target:5.2.0.1 target:5.1.5
Keywords:
: 100296 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-09-03 20:26 UTC by retired
Modified: 2016-10-25 18:54 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
can't see anything ;) (21.37 KB, image/jpeg)
2014-09-03 20:26 UTC, retired
Details

Note You need to log in before you can comment on or make changes to this bug.
Description retired 2014-09-03 20:26:16 UTC
Created attachment 105704 [details]
can't see anything ;)

Problem description: see screenshot, those underlines should be black instead of white

Steps to reproduce:
1. open view > sidebar
2. in sidebar > properties > character
3. underline drowdown

Current behavior: while underlines

Expected behavior: black underlines
Operating System: Mac OS X
Version: 4.3.1.2 release
Comment 1 retired 2014-09-03 20:27:45 UTC
icon theme issue: only with Sifr icon set.
tried galaxy and underlines are black.
Comment 2 Matthew Francis 2014-09-04 02:27:56 UTC
Confirmed. Only with the Sifr icon set

Setting to:
NEW
Low - Only with a single, non-default icon set
Minor - It's a little inconvenient but you can still set underlines using the dropdown
Platform: All - Occurs on Linux as well
Comment 3 Maxim Monastirsky 2014-09-04 07:54:56 UTC
That's because the sifr theme was initially based on the HiContrast one. There are still many HiContrast images inside the sifr folder. For this case the images are at icon-themes/sifr/svx/res/symphony/line*.png
Comment 4 QA Administrators 2015-10-14 19:56:26 UTC Comment hidden (spam)
Comment 5 steve -_- 2015-10-14 22:06:39 UTC
persisting
OS X 10.11
Sifr Icon set
LO Version: 5.1.0.0.alpha1+
Build ID: 5aa58e499a1fbd4e54692233d1b7f8c6237ad8e2
TinderBox: MacOSX-x86_64@49-TDF, Branch:master, Time: 2015-09-09_03:16:30
Locale: de-DE (de.UTF-8)

Identical to current screenshot
Comment 6 steve -_- 2015-10-25 15:09:15 UTC
This is only using the Sifr icon set. Since Breeze is the default now on OS X, the problem is not as bad as when Sifr still was the default.
Comment 7 Maxim Monastirsky 2016-06-09 20:51:36 UTC
*** Bug 100296 has been marked as a duplicate of this bug. ***
Comment 8 Commit Notification 2016-06-11 09:43:26 UTC
Adolfo Jayme Barrientos committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ffac8e3a483c84de2961784fceac2b21aa39a18c

tdf#83455 Remove color-inverted line images from Sifr

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2016-06-11 10:03:59 UTC
Adolfo Jayme Barrientos committed a patch related to this issue.
It has been pushed to "libreoffice-5-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=acc6c9989fd942be3ec8e791ed1da45ec8e3afd4&h=libreoffice-5-2

tdf#83455 Remove color-inverted line images from Sifr

It will be available in 5.2.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 steve -_- 2016-06-13 12:09:38 UTC
Thanks a lot for the fix. Confirmed.
Comment 11 Commit Notification 2016-06-14 10:40:45 UTC
Adolfo Jayme Barrientos committed a patch related to this issue.
It has been pushed to "libreoffice-5-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=95eb6aaa812b650708f9e7db3489696beeaf3eff&h=libreoffice-5-1

tdf#83455 Remove color-inverted line images from Sifr

It will be available in 5.1.5.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.