Bug 83538 - Formatting table in Impress doesn't works correctly (impress)
Summary: Formatting table in Impress doesn't works correctly (impress)
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
(earliest affected)
Inherited From OOo
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
: 89839 (view as bug list)
Depends on:
Blocks: ImpressDraw-Tables
  Show dependency treegraph
Reported: 2014-09-05 16:53 UTC by roumanet
Modified: 2019-03-14 20:01 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:

see page 4 and 5 (876.12 KB, application/vnd.oasis.opendocument.presentation)
2014-09-05 16:53 UTC, roumanet

Note You need to log in before you can comment on or make changes to this bug.
Description roumanet 2014-09-05 16:53:04 UTC
Created attachment 105814 [details]
see page 4 and 5

1) creating a new table on a page with button Table (toobar button)
--> a table is created with one line grey, one line dark grey, etc.

2) Write some words in each box of the first column

3) Write some words in other column and select these boxes
--> many boxes are selected but not all the table

4) try to change colors or size text through fill button toobars
--> Size apply to all texts even out of the selection
--> selecting Grey 1 (first grey under black fill color) fill selected boxes in black. Try again grey 1, it's OK
Comment 1 roumanet 2014-09-05 19:26:22 UTC
Tested with same problem on version

By the way, don't see any update : I've to download myself.
Comment 2 A (Andy) 2014-09-06 12:01:43 UTC
reproducible with LO (Win 8.1)

Remarks to step 4:
Change the font size with the icons INCREASE FONT and REDUCE FONT and change the font color with the icon FONT COLOR in the toolbar at the top.

Increasing and decreasing the font size changes the size of the whole text and not only of the selected cells.  Pressing the icons INCREASE or REDUCE FONT leads to loosing the selection, but the selection should be kepted -> Faulty.  Therefore, for changing the FONT COLOR in the next step the selection needs to be redone.  But then only the selected cells are changed -> Correctly.
Comment 3 Owen Genat (retired) 2014-10-05 02:45:49 UTC
Bug 46917 added to See Also list.
Comment 4 A (Andy) 2015-03-08 11:10:13 UTC
*** Bug 89839 has been marked as a duplicate of this bug. ***
Comment 5 tommy27 2016-04-16 07:27:53 UTC Comment hidden (obsolete)
Comment 6 Jeppe Bundsgaard 2016-04-16 11:23:45 UTC
This bug is still present in LibreOffice 5.2.2. 
Build ID: 1:5.1.2~rc2-0ubuntu1~wily0
Andy's remarks in comment #2 still pertains.
Comment 7 Jeppe Bundsgaard 2016-04-16 11:53:33 UTC
I tested with LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-

on Kubuntu 15.10.

It is the same. Version changed to inherited from OOo.
Comment 8 roumanet 2017-04-14 14:45:51 UTC
Can someone else try these operations with LO5.3.1 or superior ?
It seems to be partially fixed (but not commented)...

Size text bug still there.
Comment 9 roumanet 2018-02-04 09:58:39 UTC
Tested under 5.4 : the bug isn't the same now.

Selecting a row (or a line) and changing formatting font size is ok (with REDUCE button or INCREASE button) : now Bug is you can't do it twice time because after the first click, the selection disapear and all the table become selected.
Comment 10 QA Administrators 2019-02-05 03:46:36 UTC Comment hidden (obsolete)
Comment 11 roumanet 2019-03-01 17:02:44 UTC
Problem solved in LO6.2.0.3
Comment 12 Xisco Faulí 2019-03-14 20:01:15 UTC
(In reply to roumanet from comment #11)
> Problem solved in LO6.2.0.3
> Thanks!

Thanks for retesting with the latest version.
Setting to RESOLVED WORKSFORME as the commit fixing this issue hasn't been identified.