Download it now!
Bug 83593 - XLSX FILTER: Bad import of DrawingML rotation (Formatting lost on XLSX diagram)
Summary: XLSX FILTER: Bad import of DrawingML rotation (Formatting lost on XLSX diagram)
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.5.2 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Balázs Regényi
URL:
Whiteboard: BSA target:7.1.0 target:7.0.0.1
Keywords:
: 76456 104289 104290 120458 123608 123609 123611 132116 (view as bug list)
Depends on:
Blocks: OOXML-Shapes
  Show dependency treegraph
 
Reported: 2014-09-07 18:56 UTC by Joel G
Modified: 2020-08-28 08:44 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample file used. (132.88 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2014-09-07 18:56 UTC, Joel G
Details
small sample file (12.34 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2014-09-18 09:46 UTC, raal
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Joel G 2014-09-07 18:56:36 UTC
Created attachment 105864 [details]
Sample file used.

Problem description: 
Opening a MS office spreadsheet (xlsx) on LO makes the diagram in it loose formatting

Steps to reproduce:
1. Create diagram on MS Office and save file as xlsx
2. Open Document on LO


Current behavior:
Data is kept but diagram format is not the same. 

Expected behavior:
Diagram shows expected shape and order
              
Operating System: Windows 8
Version: 4.2.5.2 release
Comment 1 raal 2014-09-18 09:44:59 UTC
I can confirm with LO 4.3.1, WIN7.
Lines are incorrectly rotated.
Comment 2 raal 2014-09-18 09:46:02 UTC
Created attachment 106492 [details]
small sample file
Comment 3 tommy27 2016-04-16 07:22:43 UTC Comment hidden (obsolete)
Comment 4 QA Administrators 2017-05-22 13:22:10 UTC Comment hidden (obsolete)
Comment 5 eisa01 2018-03-17 14:42:21 UTC
Still present

Version: 6.1.0.0.alpha0+
Build ID: 8e8dd8f320a3ff59ff8a16c1a7a867888ce80700
CPU threads: 2; OS: Mac OS X 10.12.6; UI render: default; 
TinderBox: MacOSX-x86_64@49-TDF, Branch:master, Time: 2018-03-13_23:59:29
Locale: en-US (en_US.UTF-8); Calc: group
Comment 6 Gabor Kelemen 2019-05-17 08:16:38 UTC
This is not a chart object, but DrawingML shapes with incorrect rotation in XLSX. Adjusting meta bug.
Comment 7 Szabolcs Toth 2020-05-29 15:17:20 UTC
*** Bug 132116 has been marked as a duplicate of this bug. ***
Comment 8 Szabolcs Toth 2020-05-29 15:17:53 UTC
*** Bug 104289 has been marked as a duplicate of this bug. ***
Comment 9 Szabolcs Toth 2020-05-29 15:18:27 UTC
*** Bug 123611 has been marked as a duplicate of this bug. ***
Comment 10 Szabolcs Toth 2020-05-29 15:19:49 UTC
*** Bug 104290 has been marked as a duplicate of this bug. ***
Comment 11 Szabolcs Toth 2020-05-29 15:20:16 UTC
*** Bug 123608 has been marked as a duplicate of this bug. ***
Comment 12 Szabolcs Toth 2020-05-29 15:20:38 UTC
*** Bug 123609 has been marked as a duplicate of this bug. ***
Comment 13 Szabolcs Toth 2020-05-29 15:21:03 UTC
*** Bug 120458 has been marked as a duplicate of this bug. ***
Comment 14 Commit Notification 2020-05-29 15:27:30 UTC
Szabolcs Toth committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/130e6a3f4493b987a7d0b177cc84d65219b47d13

tdf#83593 XLSX DrawingML shape import: fix missing rotation

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 15 Timur 2020-05-30 09:35:23 UTC
Oh, looking at someone closing 8 reports with one fix... 
"it is extremely dangerous to our democracy" here on Bugzilla, where folks report or confirm without checking facts first :) 

https://m.youtube.com/watch?v=D9rbHpA_6W4

(some joke hopefully allowed).
Comment 16 Commit Notification 2020-05-31 20:35:33 UTC
Szabolcs Toth committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/d24e590cab4c948f19d4eaa00eaec81364c5b8ee

tdf#83593 XLSX DrawingML shape import: fix missing rotation

It will be available in 7.0.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 17 NISZ LibreOffice Team 2020-08-28 08:44:59 UTC
*** Bug 76456 has been marked as a duplicate of this bug. ***