Bug Hunting Session
Bug 83672 - FILEOPEN: .xlsx Rotated Images No longer Rotated
Summary: FILEOPEN: .xlsx Rotated Images No longer Rotated
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.5.7.2 release
Hardware: All All
: medium normal
Assignee: Serdar Oktay TUNÇ
URL:
Whiteboard: target:6.0.0
Keywords: bibisected, bisected, filter:xlsx, regression
: 67776 91454 97988 103050 (view as bug list)
Depends on: 106197
Blocks: Calc-Images XLSX
  Show dependency treegraph
 
Reported: 2014-09-09 13:48 UTC by squeezechart
Modified: 2017-08-30 19:10 UTC (History)
12 users (show)

See Also:
Crash report or crash signature:


Attachments
demo.xlsx (84.56 KB, application/excel)
2014-09-09 13:48 UTC, squeezechart
Details
test doc for other bug (8.71 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2015-02-25 05:56 UTC, Markus Mohrhard
Details

Note You need to log in before you can comment on or make changes to this bug.
Description squeezechart 2014-09-09 13:48:04 UTC
Created attachment 105984 [details]
demo.xlsx

when opening this XLSX the picture shadow is displayed without gradient and image is not rotated (lion)

spreadsheet opened in Excel 2010: http://www.squeezechart.com/excel.png
spreadsheet opened in alc 4.3.1.2: http://www.squeezechart.com/calc.png
Comment 1 ign_christian 2014-09-09 15:30:43 UTC
Hi again.. Thanks for the report. Since gradient issue has been reported in another bug, lets focus only in not rotated picture.

After unzip the file, I saw the picture is PNG and created with Excel 2010 (14.0300). Don't know if it's the same behavior with another image format.

Confirm reproduced with LO 4.3.1.2, 4.2.6.3, 4.0.6.2, 3.5.7.2 under Ubuntu 12.04 x86

Interestingly LO 3.3.0.4 loaded that image rotated with rotation angle: 343,18 degrees.
But AOO 4.1.1 loaded the image with 338,80 degrees rotation angle and -7,96 degrees slant angle.

Could you check what is the correct angle with Excel?
Comment 2 ign_christian 2014-09-09 15:38:03 UTC
WPS (Kingsoft) Office 2014 tells that image has 16 degrees rotation, which is reversed interpretation compared to LO. Perhaps it's the same interpretation with MSO.
Comment 3 squeezechart 2014-09-09 15:58:57 UTC
Excel 2010 says rotation is 17%
Comment 4 squeezechart 2014-09-09 16:00:57 UTC
(In reply to comment #3)
> Excel 2010 says rotation is 17 degrees
Comment 5 raal 2014-10-17 15:06:07 UTC Comment hidden (obsolete)
Comment 6 Xisco Faulí 2014-10-20 09:25:10 UTC Comment hidden (obsolete)
Comment 7 Sushil Shinde 2014-11-14 10:08:24 UTC
I think this is regression because of this change set http://cgit.freedesktop.org/libreoffice/core/commit/?id=1abc0695d770eebd21256a86aeee14a5384d84c7


This issue is duplicate of https://bugs.freedesktop.org/show_bug.cgi?id=67776.
Comment 8 Xisco Faulí 2014-11-14 13:52:54 UTC
I do confirm that 1abc0695d770eebd21256a86aeee14a5384d84c7 introduced this regression. I add 'bisected' to Keyboard.
Last commit from Noel was on 2014-02-03 so I'm not sure he's still involved in the project to take a look...
@Mmeeks: Do you have access to bnc#762542 ?
Comment 9 Sushil Shinde 2015-02-20 08:04:21 UTC
I have reverted previous changes and unit test for it.
Please review : https://gerrit.libreoffice.org/#/c/13090/
Comment 10 Sushil Shinde 2015-02-20 08:05:18 UTC
** I have reverted previous changes and added unit test for it.
Please review : https://gerrit.libreoffice.org/#/c/13090/
Comment 11 Markus Mohrhard 2015-02-25 05:56:48 UTC
Created attachment 113662 [details]
test doc for other bug

Attached document is broken by the patch. I'm not going to accept the patch in its current form as it just reverts another fix.
Comment 12 squeezechart 2015-06-10 10:40:21 UTC
This issue is still present in LibreOffice 5.1.0.0 alpha tested today
Comment 13 Robinson Tryon (qubit) 2015-12-13 11:11:07 UTC Comment hidden (obsolete)
Comment 14 Luke 2016-02-21 04:06:36 UTC
*** Bug 97988 has been marked as a duplicate of this bug. ***
Comment 15 Luke 2016-02-21 04:12:54 UTC
Steps to reproduce:
1. In Calc or Excel, insert an image
2. Rotate the image
3. Save as XLSX
4. Open in Calc

This import issue affects both Calc and Excel generated XLSX files.
Comment 16 Bartosz 2016-08-03 23:17:46 UTC
*** Bug 67776 has been marked as a duplicate of this bug. ***
Comment 17 squeezechart 2016-09-20 12:47:21 UTC
bug is still present - tested with LibreOffice 5.2.1 on Win10_x64
Comment 18 Xisco Faulí 2016-09-24 14:25:19 UTC
*** Bug 91454 has been marked as a duplicate of this bug. ***
Comment 19 JoNi 2017-03-23 14:50:11 UTC
*** Bug 103050 has been marked as a duplicate of this bug. ***
Comment 20 Commit Notification 2017-08-26 23:00:01 UTC
serdarot5 committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=2b7561799eeb0bf8ae14bff3702ffa6cda15d17c

fixed image and textbox rotation on xlsx files tdf#83672

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 21 Xisco Faulí 2017-08-30 18:47:55 UTC
Verified in

Version: 6.0.0.0.alpha0+
Build ID: 78960ad06faca055a6d97afbc764c902d5d07f6f
CPU threads: 1; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2017-08-30_06:31:19
Locale: es-ES (es_ES); Calc: group

@serdarot5, thanks for your work here. Could you please close this as RESOLVED FIXED if your work is done here? Could you also backport it to 5.4?