Bug 83808 - Scale images proportionally by default (Calc, Impress, Draw)
Summary: Scale images proportionally by default (Calc, Impress, Draw)
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.3.1.2 release
Hardware: All All
: medium enhancement
Assignee: Samuel Mehrbrodt (CIB)
QA Contact:
URL:
Whiteboard: target:4.4.0
Keywords:
Depends on:
Blocks:
 
Reported: 2014-09-13 02:03 UTC by Owen Genat (retired)
Modified: 2016-03-04 21:20 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Owen Genat (retired) 2014-09-13 02:03:17 UTC
This enhancement is the counterpart to bug 71669, which changed the default behaviour under Writer v4.3 from:

- Hold down SHIFT to rescale image proportionally.

... to:

- Hold down SHIFT to rescale image non-proportionally.

It would be good to have consistent UI behaviour for this type of action across ALL components that can accept image insertion. Currently the behaviour described above is reversed in Calc, Impress, and Draw.

Related Ask thread: http://ask.libreoffice.org/en/question/39676/
Comment 1 retired 2014-09-13 08:18:52 UTC
+1 overdue. Was curious why it wasn't in all components initially. But guess that's due to time constraints.

Please do make this behavior universal to deliver consistency and good defaults in all components. Thx.

NEW
Comment 2 m.a.riosv 2014-09-13 12:15:19 UTC
+1, seems it was a partial implementation,request wasn't only for writer. Now, the same key combination doing the opposite along different components. As a minimum not too friendly.
Comment 3 Commit Notification 2014-09-26 16:48:16 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ef58e10844dff60cd218306b059ec81d8421f961

fdo#83808 Scale images proportionally by default in Impress/Draw



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 4 Samuel Mehrbrodt (CIB) 2014-09-26 16:48:49 UTC
Calc part is still missing.
Comment 5 Commit Notification 2014-09-26 22:47:00 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=425711faddb208efa97e869b885919fff9e570d0

fdo#83808 Scale images proportionally by default in Calc



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 6 retired 2014-09-27 22:31:37 UTC
Thanks a lot Samuel. Important fix.
Comment 7 Owen Genat (retired) 2014-09-28 00:20:47 UTC
Thanks from me also Samuel. As soon as it hits the deb x86_64 daily I will test to confirm.
Comment 8 retired 2014-09-28 09:58:26 UTC
Verified on OS X 10.9.5 for Draw, Presentation, Calc.
Comment 9 Mike §chinagl 2014-12-20 23:04:43 UTC
This bug fix comes with LibreOffice 4.4 (release notes https://wiki.documentfoundation.org/ReleaseNotes/4.4) 

Images are now scaled proportionally by default in Calc and Impress/Draw as they were already in Writer.
Comment 10 tmacalp 2015-01-12 21:23:48 UTC
I believe this feature had the unintended side-effect of also constraining image drag movement by default.  I've reported that behavior in bug 88339.

This forces all image drag movement to be constrained to horizontal, vertical, or diagonal axes by default.  Holding shift while dragging now overrides the constraint and allows you to place the image where you want.  I don't think this is the intended behavior.
Comment 11 Mike §chinagl 2015-01-22 11:17:54 UTC
As the release is going to happen the next days please assure that everybody is happy with that bug fix
Comment 12 tmacalp 2015-01-22 13:02:04 UTC
(In reply to Mike §chinagl from comment #11)
> As the release is going to happen the next days please assure that everybody
> is happy with that bug fix

There are two patches in that image move bug fix: one for draw/impress, and one for calc.  I'm only waiting on the very last patch to go through review.

Currently, the patches for bug 88339 are merged with the following versions:

master:
calc: reviewed/merged
draw: reviewed/merged

libreoffice-4-4 (LibreOffice 4.4.1+)
calc: reviewed/merged
draw: reviewed/merged

libreoffice-4-4-0
calc: reviewed/merged
draw: waiting for review 

So, if 4.4.0 is released the way things are, the bug will be half fixed.  Calc/writer's image movement will be fixed, but draw/impress will be broken.  If it helps, the patch in question is a 1-liner.
https://gerrit.libreoffice.org/#/c/14078/