Bug 83877 - Digital signature: Support visual identification / signature lines
Summary: Digital signature: Support visual identification / signature lines
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium enhancement
Assignee: Samuel Mehrbrodt (CIB)
URL:
Whiteboard: target:6.1.0
Keywords:
: 108089 (view as bug list)
Depends on:
Blocks: Digital-Signatures
  Show dependency treegraph
 
Reported: 2014-09-15 10:15 UTC by Owen Genat (retired)
Modified: 2018-05-30 14:07 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
bugs (160.43 KB, application/vnd.oasis.opendocument.text)
2018-01-20 17:23 UTC, raal
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Owen Genat (retired) 2014-09-15 10:15:40 UTC
This is a follow-on from bug 63001 which was resolved invalid due to containing multiple issues. I am splitting them up into individual bugs as the requests seem reasonable and contained a good example. Related Ask thread:

http://ask.libreoffice.org/en/question/1119/

Quoting from the original report:

> ... often the print out of the digital[ly] document need visual features to 
> tell the reader that the document was electronically signed by Mr. X at such 
> date and time. Adobe does it nicely, but it has only one fixed image set to do 
> so. Similar feature with custom images by the author is required, again with 
> provision for multiple signatures. This would greatly enhance the visual appeal 
> of the document and its authenticity. MS Word 2010 has already implemented such 
> a system, and they call it "signature lines", and one could add o[n]e or more 
> signature lines to a document.

Refer attachment 77281 [details] and attachment 77351 [details].
Comment 1 Cor Nouws 2014-09-15 12:15:41 UTC
thanks for filing the issue > New
Comment 2 Samuel Mehrbrodt (CIB) 2017-11-23 09:24:13 UTC
*** Bug 108089 has been marked as a duplicate of this bug. ***
Comment 3 Commit Notification 2017-11-28 06:59:49 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ecd683d3f98444b69a96cbf8bff57d4e691e6cfd

tdf#83877 OOXML Roundtrip of SignatureLine properties

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Commit Notification 2017-11-28 11:04:57 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d3440e0ebfa68ac8d2cbec9b44d0fc491162ee0e

tdf#83877 Unit test for OOXML SignatureLine Roundtrip

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Samuel Mehrbrodt (CIB) 2017-12-04 14:30:57 UTC
Attachment 133665 [details] shows how the dialog looks in Word.
Comment 6 Commit Notification 2017-12-04 16:27:25 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=bfd613a4628c8827168f64fc2a97685785d04a84

tdf#83877 ODF extension to write signature lines

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2017-12-12 10:20:29 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f64a78b49bffdbc614e1fcdc8ff906edd895b65e

Related tdf#83877 Add signatureline element to draw:frame, not draw:image

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Timur 2017-12-12 12:39:26 UTC
Can you please explain how is this intended to work? 
File-Digital Signatures-Insert .... or sth.else?
Not obvious.
Comment 9 Samuel Mehrbrodt (CIB) 2017-12-12 12:43:20 UTC
(In reply to Timur from comment #8)
> Can you please explain how is this intended to work? 
> File-Digital Signatures-Insert .... or sth.else?
> Not obvious.

The dialog is not yet there.
Once this patch ( https://gerrit.libreoffice.org/#/c/45810/ ) is merged you can find it in Writer: Insert->Signature Line.
Comment 10 Commit Notification 2017-12-13 14:45:18 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=03db771e92160e95b0af8710f88b0c43591e8f3e

tdf#83877 Add dialog to generate signature line

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2017-12-14 19:12:43 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=edc3ec2b168e58624211de3dfa14eb17eceda8ec

tdf#83877 Edit existing signature lines

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Cor Nouws 2017-12-14 21:56:13 UTC
Nice work. Thanks a lot!
Comment 13 Timur 2017-12-15 10:17:10 UTC
I'd like to see Help for Insert->Signature Line.
Like, how to see Email and Sing date, how to use Instructions to the signer, Comments (I don't see it here nor in MS Word, not obvious why).
And, is this related to Digital signatures. I don't see it is so far (similar to MS Word).
Comment 14 Samuel Mehrbrodt (CIB) 2017-12-18 09:58:17 UTC
(In reply to Timur from comment #13)
> I'd like to see Help for Insert->Signature Line.
> Like, how to see Email and Sing date, how to use Instructions to the signer,
> Comments (I don't see it here nor in MS Word, not obvious why).

Will work with the doc team to provide help there.

> And, is this related to Digital signatures. I don't see it is so far
> (similar to MS Word).

It's not implemented yet, but the goal is that you are able to sign this shape using a digital signature in the end.
Comment 15 Commit Notification 2018-01-10 07:35:46 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=dd758f54fa5ea1ecd3d793bcea999d771010ff00

tdf#83877 Copy signature line properties too when copying shape

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 16 raal 2018-01-20 17:23:26 UTC
Created attachment 139235 [details]
bugs

Hi Samuel, few bugs at attachment.
Comment 17 Commit Notification 2018-03-20 06:44:31 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=39fd78b79efd00e27ea068c03edf83b9dc6b9b57

tdf#83877 ODF: Load signature lines

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 18 Commit Notification 2018-03-20 06:46:00 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=2068e1a556af412f77fe88a6765e50d326d225c7

tdf#83877 SignatureLineDialog: Fix reading "can add comments" property

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 19 Samuel Mehrbrodt (CIB) 2018-03-20 06:50:46 UTC
(In reply to raal from comment #16)
> Created attachment 139235 [details]
> bugs
> 
> Hi Samuel, few bugs at attachment.

Hi Raal, hope this is fixed with the commit from comment 18.
About the default text in the signing instructions field: I don't think it makes sense to add such a generic default text. we can as well show such a default text in the dialog when the user wants to sign.
I'd just leave that field empty, to be filled by the user if neccessary.
Comment 20 Commit Notification 2018-03-20 07:37:21 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=48baafc46825f1248ea9269308cadbd698a23ffc

tdf#83877 Add ODF roundtrip test for signature lines

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 21 Commit Notification 2018-03-22 15:07:06 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=5b348b1a8ca3c5ba1049aacba1ac2e3c43ed26b7

tdf#83877 Move SignatureLineDialog to svx

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 22 Timur 2018-03-23 08:56:02 UTC
I still don't see "Email" and "Sign date" even if they are added/checked. 
Please explain the intended use of "Instructions to the signer", "Add comments".
Comment 23 Samuel Mehrbrodt (CIB) 2018-03-23 12:10:56 UTC
(In reply to Timur from comment #22)
> I still don't see "Email" and "Sign date" even if they are added/checked. 
> Please explain the intended use of "Instructions to the signer", "Add
> comments".

Still WIP: https://gerrit.libreoffice.org/#/c/51735/
Comment 24 Commit Notification 2018-04-13 06:08:31 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ca2fd526160b8f69524cdcf8c57f814b0ad48029

tdf#83877 Add dialog to sign signature lines

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 25 Commit Notification 2018-04-13 12:25:50 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=6f6f37b7a48e30b976eb1806364c83b69047cab9

tdf#83877 Move SignatureLineDialog to cui

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 26 Commit Notification 2018-04-13 12:25:57 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f4b5a16688f63f5ab7f8b058d2cb3416ebfe84c4

tdf#83877 SignatureLineDialog: Improve default values

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 27 Commit Notification 2018-04-13 13:00:36 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=53cc801ed93e4aa76c67ce6aeb0333a56049a1c1

tdf#83877 Signatureline dialog: Move shared stuff to common base

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 28 Commit Notification 2018-04-13 13:53:21 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ee79612fc7f33d87f6cc722cdd3e669eaa79bd98

tdf#83877 Make user input xml safe

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 29 Commit Notification 2018-04-13 15:29:49 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=28db2de99a85f3b6397fbd372658853e8020bf15

tdf#83877 Show signing instructions in sign dialog

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 30 Commit Notification 2018-04-16 06:47:33 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=6654e68cd596345d1b74856ef47c83efcbf503d3

tdf#83877 Fix a11y relations in sign dialog

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 31 Commit Notification 2018-04-16 06:47:42 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f27e700c945473012127ad5ee92f0c233e5039ba

tdf#83877 Also hide label when user can't add coment

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 32 Commit Notification 2018-04-16 06:51:25 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=cee027a7e504b0a09d60f4cbd8bc2967836b40bc

tdf#83877 Improve signatureline svg

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 33 Commit Notification 2018-04-16 06:51:34 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=df5e2026e5807219979bd74a4e036cf5fa5224ad

tdf#83877 Also check button state when changing text

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 34 Commit Notification 2018-05-18 12:46:02 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=201321f648e82ecc610e7a3324a46248a19c1704

tdf#83877 Write SignatureLineId to ODF & OOXML signatures

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 35 Commit Notification 2018-05-22 07:43:47 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=6499ea2ff45fa42094d41c5c417f66a3ae5a22ae

tdf#83877 Add valid/invalid images to signatures

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 36 Commit Notification 2018-05-22 07:43:54 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=090e243c401fdb73a917a5deb36279c445cfcbb9

tdf#83877 Use Signer comments as signature description

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 37 Commit Notification 2018-05-22 08:28:12 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=203d967c045c4bf4e83d18bdcb96e11f899e1056

Related tdf#83877 Select certificate ok button label doesn't match

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 38 Samuel Mehrbrodt (CIB) 2018-05-30 14:01:09 UTC
With https://cgit.freedesktop.org/libreoffice/core/commit/?id=4315aea624635af540cdc5a497f5a9b607f52f2b this is mostly complete now.

There are still some issues which will be handled in follow-up bugs.

Feel free to test and report any issues you find.