Download it now!
Bug 83928 - EDITING: Reverting image replacement/compression corrupts animations
Summary: EDITING: Reverting image replacement/compression corrupts animations
Status: RESOLVED DUPLICATE of bug 119514
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.3.1.2 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2014-09-16 12:11 UTC by ravingdesi
Modified: 2018-08-27 09:41 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ravingdesi 2014-09-16 12:11:26 UTC
Problem description: 
This bug may be related to Bug 83882 I reported earlier. When I replace an image (tested .svg and .png) or compress it and undo this step, the animation that was associated to it gets corrupted and only shows as "-1".


1. Download https://dl.dropboxusercontent.com/u/17406199/bugtmp/Bug15.odp
2. Open the animations tab to see that the image is associated to the animation
3. Click right and choose "Compress graphic" or "Change picture" and replace it (e.g. with https://dl.dropboxusercontent.com/u/17406199/bugtmp/Bug15.svg )
4. Undo (ctrl+z)
5. Look at the animations tab again. The animation is now shown as "-1" and is not associated with this object anymore

Currently, the animation is not associated with the object anymore after undoing:
https://dl.dropboxusercontent.com/u/17406199/bugtmp/Bug15_2.png

Expected behavior:
Animation should be working like before:
https://dl.dropboxusercontent.com/u/17406199/bugtmp/Bug15_1.png

              
Operating System: Ubuntu
Version: 4.3.1.2 release
Comment 1 Owen Genat (retired) 2014-09-28 06:35:46 UTC
(In reply to comment #0)
> This bug may be related to Bug 83882 I reported earlier. 

My guess would be that there is a general problem with undoing certain transformations. Determining if this is the case will require a developer / expert. 

Confirmed. Status set to NEW. Bug 83882 added to See Also list.
Comment 2 tommy27 2016-04-16 07:24:43 UTC Comment hidden (obsolete)
Comment 3 public 2016-04-19 20:29:56 UTC
The bug is still present in 
Version: 5.0.5.2
Build ID: 5.0.5.2 Arch Linux build-3

I claim this is really a duplicate of bug 83882. Every operation that replaces the image ("Replace", "Compress", "Convert", ...) results in the same wrong behavior.

*** This bug has been marked as a duplicate of bug 83882 ***
Comment 4 Xisco Faulí 2018-08-27 09:41:06 UTC

*** This bug has been marked as a duplicate of bug 119514 ***