Bug 83948 - TRACK CHANGES: Add 'Change Comment' to right-click context menu
Summary: TRACK CHANGES: Add 'Change Comment' to right-click context menu
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 79196 (view as bug list)
Depends on:
Blocks: Track-Changes Context-Menu Writer-Comments
  Show dependency treegraph
 
Reported: 2014-09-16 21:21 UTC by Yousuf Philips (jay) (retired)
Modified: 2017-02-24 18:04 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
example of the track change right-click context menu (38.90 KB, image/png)
2014-09-21 18:50 UTC, Yousuf Philips (jay) (retired)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2014-09-16 21:21:37 UTC
Presently, the context menu has 4 entries when you right-click on a tracked change - Accept Change, Reject Change, Next Change, Previous Change. It would be good to also have 'Change Comment' after 'Reject Change'.
Comment 1 Yousuf Philips (jay) (retired) 2014-09-21 18:50:15 UTC
Created attachment 106615 [details]
example of the track change right-click context menu
Comment 2 Yousuf Philips (jay) (retired) 2014-09-22 05:08:35 UTC
Removed see also link as that bug relates to general comments and thing bug replaces to comments in track changes. Please reverse if you think i'm wrong Adolfo.
Comment 3 Adolfo Jayme 2014-09-24 10:23:34 UTC
Do whatever you want, I don’t care.
Comment 4 A (Andy) 2014-10-15 20:25:38 UTC
For me this seems to be logical, but I would say not only on a tracked change, but also for a right mouse click on an unchanged word / text passage. 
 
If you are working together with a group of coworkers on one document and you get this document with tracked changes then it could be that you want to insert a comment on a tracked change but also on a word or text passage that has not been changed.
Comment 5 Yousuf Philips (jay) (retired) 2014-10-16 22:16:20 UTC
Andy: You would use regular comments in that scenario.
Comment 6 A (Andy) 2014-10-17 21:49:47 UTC
@Jay: Thanks for your feedback.

Would it in this case be interesting to be able to add a comment also with a right mouse click or would this blow up the right mouse click context menu?  I am not yet sure, if this would be good or not.
Comment 7 Yousuf Philips (jay) (retired) 2014-10-18 09:21:23 UTC
It was an option i was thinking to suggest, but now insert comment is a button in the standard toolbar in the next release, so it isnt as crucial as it was before. :D
Comment 8 Yousuf Philips (jay) (retired) 2014-11-03 20:02:28 UTC
*** Bug 79196 has been marked as a duplicate of this bug. ***
Comment 9 Yousuf Philips (jay) (retired) 2014-12-22 09:55:38 UTC
As 'change comment' isnt used very much, most likely because its only an odf feature, and is available in the track changes toolbar, there isnt as much of a need for it in the context menu.