Bug 84036 - FORMATTING: Copy/Paste breaks conditional format ranges into many small range fragments. Undo wont fix this.
Summary: FORMATTING: Copy/Paste breaks conditional format ranges into many small range...
Status: RESOLVED DUPLICATE of bug 80768
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.6.2 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2014-09-18 10:08 UTC by Michael Wyraz
Modified: 2014-09-19 06:24 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Wyraz 2014-09-18 10:08:54 UTC
Problem description: 

Steps to reproduce:

1. Create a conditional format for a range
The "Conditional format" list contains now exactly this entry

2. Copy the contents of one cell in this range to another (Copy&Paste) or do some other Copy&Paste actions

3. Look at the conditional formats
The "Conditional format" list now contains lots of entries for several parts of the range (which in sum give the range).

4. (additional bug)
Then undoing the copy&paste action, the contitional formats remains fragmented.

Expected behavior:

Copy&Paste within a conditional formated range must not change/split the range.

Paste with ("only text/numbers/...") selected into a conditional formated range must not change/split the range.

Pasting content with different format may fragment the range. But undo must revert this.

Best solution would be some automatism that merges multiple conditional formated ranges with the same conditions and formats to a single range. This should either get triggered after each change that would otherwise change the ranges. Alternatively it's a button in the conditional formats list.
              
Operating System: Linux (Other)
Version: 4.2.6.2 release
Comment 1 ign_christian 2014-09-19 06:24:56 UTC
Hello Michael, thanks for reporting. Enhancement request regarding this issue has been filed. You'll be CCed on that bug then

*** This bug has been marked as a duplicate of bug 80768 ***