Bug 84142 - UI: Some color pickers pop up with titlebar unless the Kwin/KDE setting forces no titlebar and no frame
Summary: UI: Some color pickers pop up with titlebar unless the Kwin/KDE setting force...
Status: RESOLVED DUPLICATE of bug 78188
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.3.1.2 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 91804 (view as bug list)
Depends on:
Blocks: Color-Picker-Widget KDE
  Show dependency treegraph
 
Reported: 2014-09-21 19:38 UTC by Nico Dorn
Modified: 2019-09-09 07:09 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Pop-up window with system titlebar (17.86 KB, image/png)
2014-09-21 19:38 UTC, Nico Dorn
Details
Pop-up window forced not to display the titlebar (58.46 KB, image/png)
2014-09-21 19:39 UTC, Nico Dorn
Details
Pop-up window that defaults to the right behaviour (8.59 KB, image/png)
2014-09-21 19:40 UTC, Nico Dorn
Details
Pop-up window with system titlebar (17.86 KB, image/png)
2014-09-21 19:41 UTC, Nico Dorn
Details
Popup Color Picker (92.86 KB, image/png)
2014-12-14 02:26 UTC, nogajun
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nico Dorn 2014-09-21 19:38:50 UTC
Created attachment 106618 [details]
Pop-up window with system titlebar

System: Kubuntu 14.04, KDELibs 4.13.3, Qt 4.8.6

Current behaviour: Clicking the arrow of the "Background" picker of the "Formatting" toolbar exhibits a pop-up window with the system's titlebar (see popup_background.png)

Expected behaviour: The pop-up should not have any titlebar.

Workaround: KWin (the KDE window manager) can force the pop-up window not to display titlebars and frames (see popup_background_forced.png).

Effected pickers (as far I as I can see):
* "Formatting" toolbar: Font color, Highlighting, Background
* "Table" toolbar: Border style, Border Color, Borders, Background
* "Frame" toolbar: Background

Refer to the "Insert" toolbar to find pickers that are not effected at all (see popup_table.png).
Comment 1 Nico Dorn 2014-09-21 19:39:34 UTC
Created attachment 106619 [details]
Pop-up window forced not to display the titlebar
Comment 2 Nico Dorn 2014-09-21 19:40:06 UTC
Created attachment 106620 [details]
Pop-up window that defaults to the right behaviour
Comment 3 Nico Dorn 2014-09-21 19:41:16 UTC
Created attachment 106621 [details]
Pop-up window with system titlebar
Comment 4 Nico Dorn 2014-09-21 19:41:55 UTC Comment hidden (spam)
Comment 5 Nico Dorn 2014-09-21 19:44:12 UTC
Sorry for the noise. But I don't know how to fix comment #4. :/
Comment 6 Owen Genat (retired) 2014-10-05 10:33:55 UTC
Summary amended for clarity.
Comment 7 Nico Dorn 2014-10-05 11:53:19 UTC
Sorry, that was a misunderstanding. You can actually force the titlebars not to be shown (as a workaround). But some of them are visible by default.
Comment 8 Daniel Pastushchak 2014-12-12 18:00:32 UTC
Could not reproduce. I'm using Ubuntu 14.10 with KDE(4.14.1) and LibreOfficeDev Version: 4.5.0.0.alpha0+
Build ID: dad173d9588e6abc2a465198b7d2881d4629246a
TinderBox: Linux-rpm_deb-x86_64@46-TDF-dbg, Branch:master, Time: 2014-12-10_22:53:28
Comment 9 nogajun 2014-12-14 02:23:34 UTC
I reproduce it on 4.4.0.0.beta2.

- Debian GNU/Linux Sid (amd64)
    - KDElibs: 4.14.2 (Package: 4:4.14.2-4)
    - Qt: 4.8.6 (Package: 4:4.8.6+git64-g5dc8b2b+dfsg-2+b1)
- LibreOffice
    - Version: 4.4.0.0.beta2
    - Build ID: be92f32b8f21603a6b7a75dd645f7475bdee519d
    - Locale: ja_JP
Comment 10 nogajun 2014-12-14 02:26:53 UTC
Created attachment 110830 [details]
Popup Color Picker
Comment 11 Nico Dorn 2014-12-14 12:48:24 UTC
Set status to NEW (more than one person affected).
Comment 12 Buovjaga 2015-06-09 07:49:16 UTC
*** Bug 91804 has been marked as a duplicate of this bug. ***
Comment 13 QA Administrators 2016-09-20 10:14:26 UTC Comment hidden (obsolete)
Comment 14 Maxim Monastirsky 2017-10-22 15:45:05 UTC

*** This bug has been marked as a duplicate of bug 78188 ***