Bug Hunting Session
Bug 84157 - EDITING: formulas not adjusted correctly on sort
Summary: EDITING: formulas not adjusted correctly on sort
Status: RESOLVED DUPLICATE of bug 81633
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.3.1.2 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: possibleRegression
Depends on:
Blocks:
 
Reported: 2014-09-22 04:15 UTC by Elmar
Modified: 2015-12-15 10:57 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
spreadsheet that has data for replicaiton of problem (45.44 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-09-22 04:15 UTC, Elmar
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Elmar 2014-09-22 04:15:51 UTC
Created attachment 106638 [details]
spreadsheet that has data for replicaiton of problem

Problem description: 
Formula like: =G3+D4+E4 in row 4: when sorted does not adjust correctly - the last two variables change to the row sorted to, but the first variable remains static.

Steps to reproduce:
1. ....
2. ....
3. ....

Current behavior:
if sorted to row 25 (say) then formula is =G3+D25+E25

Expected behavior:
should be =G24+D25+E25
              
Operating System: Ubuntu
Version: 4.3.1.2 release
Last worked in: 4.3.0.4 release
Comment 1 Jean-Baptiste Faure 2014-09-22 04:31:09 UTC
Already reported and discussed, see bug 81633.
Will be configurable in version 4.4

Best regards. JBF

*** This bug has been marked as a duplicate of bug 81633 ***
Comment 2 Robinson Tryon (qubit) 2015-12-15 10:57:49 UTC
Migrating Whiteboard tags to Keywords: (possibleRegression)
[NinjaEdit]