Bug 84181 - Background colour chooser in Libreoffice Writer 4.4 table toolbar opens off screen
Summary: Background colour chooser in Libreoffice Writer 4.4 table toolbar opens off s...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.4.0.0.alpha0+ Master
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks: Color-Picker-Widget
  Show dependency treegraph
 
Reported: 2014-09-22 12:41 UTC by Gabriel Diosan
Modified: 2014-10-27 23:08 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot showing the colour chooser opening off the bottom of the screen (109.01 KB, image/png)
2014-09-22 12:41 UTC, Gabriel Diosan
Details
Under Windows it displays very off position, but visible (113.13 KB, image/png)
2014-09-22 13:37 UTC, Adolfo Jayme
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gabriel Diosan 2014-09-22 12:41:18 UTC
Created attachment 106674 [details]
Screenshot showing the colour chooser opening off the bottom of the screen

When attempting to change the background colour of a table cell in Libreoffice Writer 4.4, the colour chooser (in the table toolbar) does not detect the bottom screen edge and the majority of the colour chooser opens off screen.

Steps to reproduce:

1. Open Libreoffice Writer and insert a table
2. Click within the table (the table toolbar appears at the bottom)
3. Click on the background colour icon

Expected behaviour: The colour chooser should detect the bottom of the screen and open upwards.

Current behaviour: The colour chooser opens downward as usual and the majority of the colour chooser is not visible.

I have attached a screenshot to show the problem.

Tested on Ubuntu Gnome 14.10 Beta & Lubuntu 14.04.

This is a regression from Libreoffice 4.2.6 and 4.3.1.

Gabriel
Comment 1 Tomaz Vajngerl 2014-09-22 12:57:33 UTC
Hmm..
Comment 2 Cor Nouws 2014-09-22 13:19:31 UTC
Comment on attachment 106674 [details]
Screenshot showing the colour chooser opening off the bottom of the screen

correct mimi-type
Comment 3 Adolfo Jayme 2014-09-22 13:37:31 UTC
Created attachment 106679 [details]
Under Windows it displays very off position, but visible
Comment 4 Maxim Monastirsky 2014-10-27 22:50:29 UTC
Is it still an issue? It seems to me fixed since http://cgit.freedesktop.org/libreoffice/core/commit/?id=7d860f6134654c2f46ceebb1ca1a792c143af795. Can someone else confirm?
Comment 5 V Stuart Foote 2014-10-27 23:08:39 UTC
(In reply to Maxim Monastirsky from comment #4)
> Is it still an issue? It seems to me fixed...

Yes confirmed fixed--now nicely pinned to the toolbar. And can be "torn away".

On Windows 7 sp1, 64-bit en-US with
Version: 4.4.0.0.alpha1+
Build ID: 608396721edcdfce8a325026844fd2fab72bbb73
TinderBox: Win-x86@42, Branch:master, Time: 2014-10-27_08:02:11
as well as
Version: 4.4.0.0.alpha1+
Build ID: fa58d91094895a530648630fa64b8724ea1e4305
TinderBox: Win-x86@39, Branch:master, Time: 2014-10-26_09:30:18