Download it now!
Bug 84301 - Mac OS X: Command-click on document window title does nothing on newly saved documents
Summary: Mac OS X: Command-click on document window title does nothing on newly saved ...
Status: RESOLVED DUPLICATE of bug 59163
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.1.4.2 release
Hardware: x86-64 (AMD64) Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-09-25 00:47 UTC by pinertech
Modified: 2017-08-26 22:50 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Example document window drop down menu (23.81 KB, image/png)
2014-09-25 00:54 UTC, pinertech
Details

Note You need to log in before you can comment on or make changes to this bug.
Description pinertech 2014-09-25 00:47:14 UTC
Mac OS X: In LibreOffice Writer, when you hold down the Command key and click the window title of a newly created and saved document, the pop down menu that shows you the document's path does NOT appear. When you close document and reopen the document, it works properly from that point on for that particular document.

Calc and Impress are NOT affected and work properly at all times.

Reproduce: Start up LibreOffice on Mac OS X. Start new Writer document. Save the document with a name. Hold down Command key and click on title of document window, and nothing will happen.
Comment 1 pinertech 2014-09-25 00:54:06 UTC
Created attachment 106822 [details]
Example document window drop down menu

This is what the beginning of the drop down menu on the document window title looks like when it is working.
Comment 2 Matthew Francis 2014-09-28 02:50:42 UTC
This will be fixed in LibreOffice 4.4

*** This bug has been marked as a duplicate of bug 56562 ***
Comment 3 pinertech 2014-09-28 19:04:37 UTC
This bug does not appear to be a duplicate of 56562. 

I retested for this bug 84301 with the following nightly build (the bug for 56562 had a patch applied 3 weeks ago), and the bug is still there. Create new document in Writer, save as normal .odt document, and Command click on window title does nothing. This bug has been there in previous 4.x releases.

Version: 4.4.0.0.alpha0+
Build ID: 2348f05b31f5fc6f4e60b128e9133c76e6df8ae3
TinderBox: MacOSX-10.9-x86_64@53, Branch:master, Time: 2014-09-28_06:41:43

Also, bug 56562 seemed to affect only .doc files and not .odt files.
Comment 4 Joel Madero 2014-11-04 03:50:39 UTC
Never confirmed by QA team - moving to UNCONFIRMED.
Comment 5 Alex Thurgood 2014-11-04 09:31:54 UTC
confirming on 10.10

Version: 4.4.0.0.alpha1+
Build ID: 4dbed9ef9a2299587d75bd9fae96b05dac0675c3
Comment 6 Alex Thurgood 2014-11-04 09:37:19 UTC
Changed title back to original because I can reproduce on any type of document, not just Writer
Comment 7 Alex Thurgood 2014-11-04 09:40:47 UTC
Also present in

Version: 4.2.4.2
Build ID: 63150712c6d317d27ce2db16eb94c2f3d7b699f8
Comment 8 Alex Thurgood 2014-11-04 09:43:54 UTC
Also in 
Version: 4.1.4.2
Build ID: 0a0440ccc0227ad9829de5f46be37cfb6edcf72
Comment 9 QA Administrators 2015-12-20 16:17:39 UTC Comment hidden (obsolete)
Comment 10 pinertech 2015-12-20 19:47:48 UTC
Version 5.0.4.2 (release)
OS X 10.11.2

Issue still exists
No change in behavior (tested in WP, spreadsheet, presentation)
Comment 11 Alex Thurgood 2015-12-21 08:51:12 UTC
Confirming also in

Version: 5.2.0.0.alpha0+
Build ID: ce3d3f5543e3e132a3473af27aa2c827336add0f
CPU Threads: 2; OS Version: -; UI Render: default; 
Locale : fr-FR (fr.UTF-8)
Comment 12 QA Administrators 2017-01-03 19:55:26 UTC Comment hidden (obsolete)
Comment 13 eisa01 2017-08-26 22:50:05 UTC
This is really a duplicate of bug 59163, as the drop down is tied to the proxy icon

The drop down (i.e. the proxy icon) shows if you save an empty document, but if you have written e.g., test it doesn't show

Version: 5.4.0.3
Build ID: 7556cbc6811c9d992f4064ab9287069087d7f62c
CPU threads: 2; OS: Mac OS X 10.12.6; UI render: default; 
Locale: en-US (en_US.UTF-8); Calc: group

*** This bug has been marked as a duplicate of bug 59163 ***