Download it now!
Bug 84335 - SVG files built with dvisvgm don't work anymore in LibreOffice
Summary: SVG files built with dvisvgm don't work anymore in LibreOffice
Status: RESOLVED DUPLICATE of bug 78554
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-09-25 19:46 UTC by famillyguy
Modified: 2015-04-13 12:33 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
SVG file representing Einstein most famous result. (4.37 KB, image/svg+xml)
2014-09-25 19:46 UTC, famillyguy
Details

Note You need to log in before you can comment on or make changes to this bug.
Description famillyguy 2014-09-25 19:46:41 UTC
Created attachment 106874 [details]
SVG file representing Einstein most famous result.

I'm using Libreoffice Version: 4.2.6.3 Build ID: 420m0(Build:3) on Ubuntu 14.04.

When I try to open or insert (via paste) SVG files made with dvisvgm in a draw/impress document, it fails to display the image properly (or doesn't display them at all, or simply start working really slow).

I've verified that the SVG is valid using the validator found here: "http://jigsaw.w3.org/css-validator/". The same files work in GNOME Image Viewer, InkScape, Chrome, Comix, ... Anything I can find that supports SVG except LibreOffice.

This used to work in previous versions of LibreOffice, although I can't say which version introduced the problem.

I've attached an example file.

Thank you.

Jos
Comment 1 Tomaz Vajngerl 2014-09-25 20:23:02 UTC
I think this is a duplicate of fdo#78554 and will be fixed in 4.2.7 - at least it works in 4.3.1 and master.

*** This bug has been marked as a duplicate of bug 78554 ***