Bug 84338 - FILEOPEN: CSV File creates garbled preview and almost freezes LibreOffice
Summary: FILEOPEN: CSV File creates garbled preview and almost freezes LibreOffice
Status: RESOLVED DUPLICATE of bug 82418
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.3.1.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2014-09-25 22:01 UTC by bugmenot
Modified: 2015-07-30 11:49 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of import window. (51.02 KB, image/png)
2014-09-25 22:18 UTC, m.a.riosv
Details
Better have a look at this one (Linux 64bit) (58.24 KB, image/png)
2014-09-30 15:14 UTC, bugmenot
Details

Note You need to log in before you can comment on or make changes to this bug.
Description bugmenot 2014-09-25 22:01:27 UTC
Problem description: When attempting to open a 667kB CSV file the preview shows only one line with a few Chinese characters at the beginning followed by probably invalid Unicode characters. None of the characters are part of the CSV file and LibreOffice tested is a US English version which is not expected to display any Chinese messages.

Steps to reproduce:
1. Download a test CSV file from http://real-chart.finance.yahoo.com/table.csv?s=IBM&d=8&e=25&f=2014&g=d&a=0&b=2&c=1962&ignore=.csv
2. Save test file as "IBM.csv"
3. Open "IBM.csv" with LibreOffice to see effects stated above

Current behavior: When actually attempting to import the CSV data the following popup message is produced: "The data could not be loaded because the maximum number of characters per cell was exceeded". Then LibreOffice becomes almost unresponsive.

Expected behavior: CSV text data should be converted and displayed as spreadsheet after selecting the appropriate separator.


Operating System: openSUSE
Version: 4.3.1.2 release
Comment 1 bugmenot 2014-09-25 22:07:26 UTC
Opening the CSV file with a text editor to copy and paste the text into an empty LibreOffice spreadsheet seems to be a suitable workaround.
Comment 2 m.a.riosv 2014-09-25 22:18:25 UTC
Created attachment 106878 [details]
Screenshot of import window.

Hi bugmenot,

opens fine for me with
Win7x64 - LibreOffice 4.3.2.1

Attached screenshot of import window that works for me.

Please could you attach a screenshot of import window, to try with the same options.
Comment 3 bugmenot 2014-09-26 16:26:16 UTC
(In reply to comment #2)
> Created attachment 106878 [details]
> Screenshot of import window.
> 
> Hi bugmenot,
> 
> opens fine for me with
> Win7x64 - LibreOffice 4.3.2.1
> 
> Attached screenshot of import window that works for me.
> 
> Please could you attach a screenshot of import window, to try with the same
> options.

Configurations are not comparable: You are running 32-bit software on 64 bit Windows, while my version of LibreOffice is 64 bit (on OpenSuse Linux).
Comment 4 bugmenot 2014-09-30 15:14:23 UTC
Created attachment 107130 [details]
Better have a look at this one (Linux 64bit)

LibreOffice for Windows apparently seems to work, while The 64 bit variant for Linux does not.
Comment 5 Jacques Guilleron 2014-09-30 20:15:30 UTC
Hi bugmenot,

Did you try to change Character set in your Import wndows, something like Western Europe, to see what happens to this table and not to have Chinese characters.
Next, check also Detect special numbers to have dates formated as date format, and numbers formated a
Comment 6 Jacques Guilleron 2014-09-30 20:27:53 UTC
Numbers formated as general numbers (not as text).

Jacques
Comment 7 bugmenot 2014-09-30 23:14:39 UTC
Thanks to the comments of Jacques Guilleron I have recognized that LibreOffice had defaulted to UTF-16 for text import from a CSV file. Changing this to UTF-8 or ISO-8859-1 is initially necessary to import contents properly.

There is no problem, however, if the UTF-16 character set is selected while pasting the same contents from the clipboard. This is albeit the text import window looks identical to the one during CSV file import.
Comment 8 Buovjaga 2014-11-14 17:05:45 UTC
For me on 64-bit Ubuntu, it offers UTF-8 right away. Dare I suggest we close this as WORKSFORME? What do you think, bugmenot?

Ubuntu 14.10 64-bit Version: 4.4.0.0.alpha2+
Build ID: 5bff4b016c4b44f4123e0e6a4fd4c0c4dc0cfa2d
TinderBox: Linux-rpm_deb-x86_64@46-TDF-dbg, Branch:master, Time: 2014-11-13_00:14:29

Version: 4.3.3.2
Build ID: 430m0(Build:2)
Comment 9 Robinson Tryon (qubit) 2014-11-24 00:48:40 UTC
(In reply to Beluga from comment #8)
> For me on 64-bit Ubuntu, it offers UTF-8 right away. Dare I suggest we close
> this as WORKSFORME? What do you think, bugmenot?

Status -> NEEDINFO

bugmenot: Is it still suggesting UTF-16 to you? If so, please leave a comment and change status to UNCONFIRMED. If not, let's change status to RESOLVED WORKSFORME.
Comment 10 QA Administrators 2015-06-08 14:28:27 UTC
Dear Bug Submitter,

This bug has been in NEEDINFO status with no change for at least
6 months. Please provide the requested information as soon as
possible and mark the bug as UNCONFIRMED. Due to regular bug
tracker maintenance, if the bug is still in NEEDINFO status with
no change in 30 days the QA team will close the bug as INVALID
due to lack of needed information.

For more information about our NEEDINFO policy please read the
wiki located here:
https://wiki.documentfoundation.org/QA/Bugzilla/Fields/Status/NEEDINFO

If you have already provided the requested information, please
mark the bug as UNCONFIRMED so that the QA team knows that the
bug is ready to be confirmed.
 
Thank you for helping us make LibreOffice even better for everyone!

This NEEDINFO Message was generated on: 2015-06-08

Warm Regards,
QA Team
Comment 11 p.abrahams@clara.co.uk 2015-06-10 17:44:55 UTC
I hit this problem the first time I tried to open a CSV file using 4.3.7.2 .

It seems that when the product is shipped the character set defaults to UTF-16. Once you change it to UTF-8 it becomes the default and everything works.

The question is what should the product be shipped with? I noticed that there is an option of 'System' which also works but I do not know what it really means. Would it be a better default to ship with?
Comment 12 Buovjaga 2015-06-10 17:55:33 UTC
Changing back to unconfirmed due to comment 11 so this doesn't fly under the radar.
Comment 13 raal 2015-06-11 12:18:34 UTC
Duplicate of bug 88909 ?
Comment 14 Maxim Monastirsky 2015-07-30 11:49:08 UTC

*** This bug has been marked as a duplicate of bug 82418 ***