Bug Hunting Session
Bug 84351 - SIDEBAR: Menu selections should not toggle visibility i.e., once open, sidebar should remain open
Summary: SIDEBAR: Menu selections should not toggle visibility i.e., once open, sideba...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.0.0.alpha0+ Master
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Sidebar-UI-UX
  Show dependency treegraph
 
Reported: 2014-09-26 05:37 UTC by Yousuf Philips (jay) (retired)
Modified: 2016-10-24 15:13 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2014-09-26 05:37:28 UTC
Currently there are two problems with the sidebar.

1) If you have the sidebar full opened on 'styles and formatting' and you go into the styles drop down menu and click 'more', it will close the sidebar so only the tabs are shown. Same thing happens if you go to Tools > Gallery twice.

2) If the sidebar is enabled, but hidden (hidden means that the tab column is hidden and all that is left is a smal sliver which you can press to expand the sidebar), pressing Tools > Gallery or styles drop down menu > 'more' will not expand the sidebar.
Comment 1 Owen Genat (retired) 2014-09-30 14:00:16 UTC
(In reply to comment #0)
> 1) If you have the sidebar full opened on 'styles and formatting' and you go
> into the styles drop down menu and click 'more', it will close the sidebar
> so only the tabs are shown. Same thing happens if you go to Tools > Gallery
> twice.

This only applies to v4.4.0.0 (not v4.2.6.3 or v4.3.2.2). Presumably this is related to the recent changes to make these options open only in the sidebar by default i.e., bug 73151. Is the query here that once open, repeated selection of the same option should leave the sidebar open and not toggle show/hide status? Note also that Format > Styles and Formatting still opens a separate panel.

> 2) If the sidebar is enabled, but hidden (hidden means that the tab column
> is hidden and all that is left is a smal sliver which you can press to
> expand the sidebar), pressing Tools > Gallery or styles drop down menu >
> 'more' will not expand the sidebar.

At present (v4.4.0.0 2014-09-25 x86_64 deb) I find the entire show/hide feature of the sidebar to be somewhat flaky (returns to a completely hidden state all the time and then will not open except via manual click-n-drag). As a result I am uncertain how to treat this report. Version set to 4.4.0.0.
Comment 2 Yousuf Philips (jay) (retired) 2014-09-30 20:23:58 UTC
(In reply to comment #1)
> This only applies to v4.4.0.0 (not v4.2.6.3 or v4.3.2.2). Presumably this is
> related to the recent changes to make these options open only in the sidebar
> by default i.e., bug 73151. Is the query here that once open, repeated
> selection of the same option should leave the sidebar open and not toggle
> show/hide status? Note also that Format > Styles and Formatting still opens
> a separate panel.

Yes repeated selections shouldnt toggle show/hide.

> At present (v4.4.0.0 2014-09-25 x86_64 deb) I find the entire show/hide
> feature of the sidebar to be somewhat flaky (returns to a completely hidden
> state all the time and then will not open except via manual click-n-drag).
> As a result I am uncertain how to treat this report. Version set to 4.4.0.0.

Yes its behaviour is still not optimal. Something even worse is that i've noticed that the sidebar hides itself for no reason after i just open it. It has happened to me quite a few times but in cant pin point exact steps to reproduce it.
Comment 3 Owen Genat (retired) 2014-10-01 15:59:27 UTC
Thanks for clarifying Jay. There is certainly as issue here. I have amended the summary to be clearer i.e., problem (1). Maybe raise a separate bug for (2)? It seems a bit more difficult as it is less defined at present. Status set to NEW.
Comment 4 Yousuf Philips (jay) (retired) 2014-10-01 22:52:31 UTC
I dont think this should require two bugs to be made, as both bugs relate to the hiding/showing behaviour of the sidebar. But if only one is fixed in this bug, i'll open up the second.
Comment 5 Samuel Mehrbrodt (CIB) 2014-10-16 14:53:03 UTC
> 1) If you have the sidebar full opened on 'styles and formatting' and you go
> into the styles drop down menu and click 'more', it will close the sidebar
> so only the tabs are shown. Same thing happens if you go to Tools > Gallery
> twice.

This is a regression since http://cgit.freedesktop.org/libreoffice/core/commit/?id=04e96b6d6eb55b9ff2a6ec9c4ce52260e33df121

Thomas, could you have a look at this?
Comment 6 Yousuf Philips (jay) (retired) 2014-10-16 19:50:59 UTC
Seems i already filed problem 2 in bug 83546. :D
Comment 7 Thomas Arnhold 2014-10-17 07:04:45 UTC
Samuel, please just revert 04e96b6d6eb55b9ff2a6ec9c4ce52260e33df121 . This will fix it. Thank!