Bug 84381 - SIDEBAR: Properties deck (Area/Line content panels) should respond more accurately to selected objects
Summary: SIDEBAR: Properties deck (Area/Line content panels) should respond more accur...
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:5.1.0 target:5.2.0
Keywords: needsDevEval, topicUI
Depends on:
Blocks: Sidebar-Properties
  Show dependency treegraph
 
Reported: 2014-09-27 00:19 UTC by Yousuf Philips (jay) (retired)
Modified: 2018-09-12 02:38 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2014-09-27 00:19:20 UTC
Presently in impress (but this also happens in other apps), if you click on a line object, the sidebar shows the 'area' section, which it shouldnt. Similarly when you click on a non-line object, the sidebar should has the arrow subsection of the line section disabled, as it doesnt do anything to the object.
Comment 1 Owen Genat (retired) 2014-09-30 13:37:47 UTC
(In reply to comment #0)
> Presently in impress (but this also happens in other apps), if you click on
> a line object, the sidebar shows the 'area' section, which it shouldnt.

I get both the Area and Line sub-panels expanded in v4.2.6.3, v4.3.2.2, and v4.4.0.0 2014-09-25 under GNU/Linux. Given most drawn objects use both, perhaps the gradient at the top of each sub-panel could slightly darken or change hue to indicate active selection? Alternatively a highlighting border? I generally agree though.

> Similarly when you click on a non-line object, the sidebar should has the
> arrow subsection of the line section disabled, as it doesnt do anything to
> the object.

I agree. Confirmed. Status set to NEW. Summary amended for clarity.
Comment 2 Owen Genat (retired) 2014-10-01 12:02:58 UTC
Summary amended to be in keeping with terminology:

https://wiki.openoffice.org/wiki/File:SidebarNames.png
Comment 3 Commit Notification 2015-06-29 13:02:42 UTC
Rishabh Kumar committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=7bb74f1a73b953ef2263f25b0df202e8a588307e

tdf#84381: Improved sidebar selection analyser for Calc and Draw/Impress

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 4 Robinson Tryon (qubit) 2015-12-14 06:14:50 UTC Comment hidden (obsolete)
Comment 5 Commit Notification 2016-01-25 07:16:57 UTC
Rishabh committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=eede66cd922b0f867b7521a9d96e2c6f42a973dc

tdf#84381: Disable the line arrowheads when non-line object is selected

It will be available in 5.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Xisco Faulí 2016-09-15 22:35:30 UTC
Hello,
Is this bug fixed?
If so, could you please close it as RESOLVED FIXED?
Comment 7 Xisco Faulí 2017-09-11 08:38:08 UTC
Dear developer,
This bug has been in ASSIGNED status for more than 3 months without any
activity. Resetting it to NEW.
Please assigned it back to yourself if you're still working on this.

@Jay, could you please check whether this issue is fixed already ?
Comment 8 Yousuf Philips (jay) (retired) 2017-09-11 16:19:01 UTC
(In reply to Xisco Faulí from comment #7)
> @Jay, could you please check whether this issue is fixed already ?

The only thing remaining seems to be that the area content panel still appears in writer when selecting a line.
Comment 9 QA Administrators 2018-09-12 02:38:32 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present with the latest version of LibreOffice from https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the information from Help - About LibreOffice.
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a comment that includes the information from Help - About LibreOffice.

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not 
appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3) from http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to 'inherited from OOo';
4b. If the bug was not present in 3.3 - add 'regression' to keyword


Feel free to come ask questions or to say hello in our QA chat: https://kiwiirc.com/nextclient/irc.freenode.net/#libreoffice-qa

Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team

MassPing-UntouchedBug