Download it now!
Bug 84382 - Emoji no longer display on OSX / 4.4 master
Summary: Emoji no longer display on OSX / 4.4 master
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
4.4.0.0.alpha0+ Master
Hardware: Other Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2014-09-27 02:19 UTC by Matthew Francis
Modified: 2015-12-15 11:03 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample document (9.71 KB, application/vnd.oasis.opendocument.text)
2014-09-27 02:20 UTC, Matthew Francis
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Matthew Francis 2014-09-27 02:19:39 UTC
The "Apple Color Emoji" font works on OSX in 4.3 but not in 4.4 master - specifically for the characters in the range U+1F300


Bisection puts the breakage at:

commit 4a0cb642f18b674f37db8e9bd30942740df08e4c
Author: Norbert Thiebaud <nthiebaud@gmail.com>
Date:   Sun Jul 20 07:49:45 2014 +0200

    vcl quartz: Add support back for DXArray tweaking


(in what is probably a separate bug, the system character viewer can't be used to insert emoji characters into Writer even on 4.3 - the characters of the attached example were copied from the web)
Comment 1 Matthew Francis 2014-09-27 02:20:35 UTC
Created attachment 106939 [details]
Sample document
Comment 2 Alex Thurgood 2014-10-02 12:15:31 UTC
I can insert the emoji in LO 4322 via Insert > Special character, the grid display is really weird though, all of the icons are shifted up and to the left of center.


In Version: 4.4.0.0.alpha0+
Build ID: 9bcd96a36e323a1c70eeefa81f2c8ea595f59444

the emoji are no longer displayed in the test document. The character grid shows the emoji as for 4322, but insertion just leads to blank insert, i.e. the emoji are not drawn on the page

confirming, regression
Comment 3 Alex Thurgood 2014-10-02 12:17:34 UTC
Norbert: do you think your change might have been responsible for this ?
Comment 4 Joel Madero 2015-01-05 17:17:52 UTC
Adding bibisected to whiteboard as bisected keyword is a subset of bibisected whiteboard.

Thanks!
Comment 5 tommy27 2015-07-27 12:35:42 UTC
would you please guys with Mac give an update of the bug status with current LibO 5.0.0 RC4 or 5.1.0 alpha daily builds?

please also taka a look at this one which I reported under Windows.
Bug 92940 - many Emojis do not work
Comment 6 Iandol 2015-07-27 15:50:12 UTC
I can see the LOLcats in the sample document in 5.1 and add characters from Insert > Special Charcter.

BUT I can get a LO crash if I try to use the OS emoji & symbols viewer to insert emoji, though it is not reproducible and I can insert other high-range unicode like alchemical symbols: 🜢🜣

I'm running 10.11 public beta, and Writer 5.1 has general problems so not sure if the crash is relevant.
Comment 7 Alex Thurgood 2015-07-28 17:43:25 UTC
Version: 5.1.0.0.alpha1+
Build ID: e2281331b1ab40288494ab3659d9c66e13d3e905
Locale : fr-FR (fr.UTF-8)

OSX 10.10.4

I see the LOLcats in the appended test document.

Using the Emoji shortcuts works for me too.

Setting as WFM
Comment 8 Alex Thurgood 2015-07-28 17:44:49 UTC
Also works in

Version: 5.0.0.4
Build ID: cf112dc905650fb985306a7a03d2fe3fcc6c978f
Locale: fr-FR (fr.UTF-8)

OSX 10.10.4
Comment 9 Robinson Tryon (qubit) 2015-12-15 11:03:40 UTC
Migrating Whiteboard tags to Keywords: (bibisected)
[NinjaEdit]