Bug Hunting Session
Bug 84513 - EDITING Cutting table row (or column) doesn't register an undo event
Summary: EDITING Cutting table row (or column) doesn't register an undo event
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 95313 (view as bug list)
Depends on:
Blocks: Undo-Redo Cut-Copy
  Show dependency treegraph
 
Reported: 2014-09-30 14:30 UTC by Katarina Behrens
Modified: 2017-12-18 15:41 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Katarina Behrens 2014-09-30 14:30:23 UTC
1. Open a new Impress document. Insert table, any size, populate it with some data

2. Select whole row (or column), Ctrl-X to cut (or click Cut icon)

3. This should register an undo event and it should be possible to redo it, but it doesn't

This is reproducible with few days old master build, but I can observe this with as old LibO as 3.5, so I entered 'Inherited from OOo'. Similar bug: fdo#70048
Comment 1 sophie 2014-10-23 14:20:51 UTC
Hi, tested with master under Linux, confirmed, set as New - Sophie
Comment 2 Buovjaga 2015-10-26 08:41:08 UTC
*** Bug 95313 has been marked as a duplicate of this bug. ***
Comment 3 QA Administrators 2016-11-08 11:57:07 UTC Comment hidden (obsolete)
Comment 4 Mark Hung 2017-12-18 15:23:14 UTC
I can't reproduce this issue in LibreOffice 5.4.

Version: 5.4.0.3
Build ID: 7556cbc6811c9d992f4064ab9287069087d7f62c
CPU threads: 8; OS: Windows 6.2; UI render: default; 
Locale: zh-TW (zh_TW); Calc: group

Maybe this has been fixed?
Comment 5 Buovjaga 2017-12-18 15:41:55 UTC
(In reply to Mark Hung from comment #4)
> I can't reproduce this issue in LibreOffice 5.4.
> 
> Version: 5.4.0.3
> Build ID: 7556cbc6811c9d992f4064ab9287069087d7f62c
> CPU threads: 8; OS: Windows 6.2; UI render: default; 
> Locale: zh-TW (zh_TW); Calc: group
> 
> Maybe this has been fixed?

True, I am able to undo and redo OK.

Arch Linux 64-bit
Version: 6.1.0.0.alpha0+
Build ID: b2d87e00ed93db79ba64a9bef83e20d44c69dd7c
CPU threads: 8; OS: Linux 4.14; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group threaded
Built on December 18th 2017