Download it now!
Bug 84572 - COLOR PICKER: Popup appears and shrinks the space used by the recent colors list
Summary: COLOR PICKER: Popup appears and shrinks the space used by the recent colors list
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.4.0.0.alpha0+ Master
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Color-Picker-Widget
  Show dependency treegraph
 
Reported: 2014-10-02 00:07 UTC by Yousuf Philips (jay) (retired)
Modified: 2014-12-01 19:29 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshot of how the recent color list looks (18.60 KB, image/png)
2014-10-02 00:20 UTC, Yousuf Philips (jay) (retired)
Details
screenshot (23.13 KB, image/png)
2014-10-29 07:37 UTC, Yousuf Philips (jay) (retired)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2014-10-02 00:07:52 UTC
Pulled from bug 37480 comment 17.

3) medium: when the popup appears, the color palette color area expands, which causes the recent colors area to be shrunk, which causes the recent colors scrollbar buttons to overlap and the recent colors list to be less visible and less easy to click, as they are about ~10px in height.
Comment 1 Yousuf Philips (jay) (retired) 2014-10-02 00:20:41 UTC
Created attachment 107210 [details]
screenshot of how the recent color list looks
Comment 2 tommy27 2014-10-04 07:03:35 UTC
I confirm issue on Win7x64  using 4.4.0.0.alpha0+
Build ID: 268b9c10c9ff27c74678ace99762f28d58d33012
TinderBox: Win-x86@42, Branch:master, Time: 2014-10-02_23:35:24
Comment 3 tommy27 2014-10-24 19:40:31 UTC
retested with 4.4.0.0.alpha1+ under Win7
Build ID: 6ba8b7f5eacac969e4781d63718083a05491b1bc
TinderBox: Win-x86@42, Branch:master, Time: 2014-10-24_02:23:51

the recent colors list buttons have now the same size of the palette list buttons.

could we label this as resolved?
Comment 4 Yousuf Philips (jay) (retired) 2014-10-24 20:10:55 UTC
It is larger than it used to be, but still not the same size as the palette list.

Palette List Size : 13x12
Recent List Size : 13x9

Version: 4.4.0.0.alpha1+
Build ID: 6ba8b7f5eacac969e4781d63718083a05491b1bc
TinderBox: Linux-rpm_deb-x86@45-TDF, Branch:master, Time: 2014-10-24_05:10:51
Comment 5 Maxim Monastirsky 2014-10-28 21:24:09 UTC
@Jay: Does http://cgit.freedesktop.org/libreoffice/core/commit/?id=3efc3cc5b0b4b6151e928c2348c7dc6f74181db5 make any difference in this regard?
Comment 6 Yousuf Philips (jay) (retired) 2014-10-28 22:04:46 UTC
@Maxim: As i dont compile, i have to wait for the next daily build. :D
Comment 7 Yousuf Philips (jay) (retired) 2014-10-29 07:37:12 UTC
Created attachment 108607 [details]
screenshot

Got the latest build and the area isnt being shrunk anymore but the area now is smaller than it used to be, which makes the scrollbar buttons to overlap each other and i'm not able to get to the second row of recently used colors.
Comment 8 Maxim Monastirsky 2014-10-29 07:49:09 UTC
(In reply to Jay Philips from comment #7)
> Got the latest build and the area isnt being shrunk anymore but the area now
> is smaller than it used to be, which makes the scrollbar buttons to overlap
> each other and i'm not able to get to the second row of recently used colors.
There should not be a second row. The recent color count is no more than one row by design. See Tomaž Vajngerl comment at https://gerrit.libreoffice.org/11494/.

Regarding the scrollbar - it's a bug, as it shouldn't appear at all.
Comment 9 Yousuf Philips (jay) (retired) 2014-10-29 07:57:49 UTC
(In reply to Maxim Monastirsky from comment #8)
> There should not be a second row. The recent color count is no more than one
> row by design. See Tomaž Vajngerl comment at
> https://gerrit.libreoffice.org/11494/.

I thought that might be the case. :D Well then can we add maybe 2 or 3 pixels padding above and below, so i doesnt seem so cramped. Also is it possible to remove the scrollbar buttons on the right.

> Regarding the scrollbar - it's a bug, as it shouldn't appear at all.

If the scrollbar isnt supposed to show, what visual indicator is a user supposed to know that there are additional colors outside of the ones currently being displayed.
Comment 10 Maxim Monastirsky 2014-10-29 08:00:29 UTC
(In reply to Jay Philips from comment #9)
> If the scrollbar isnt supposed to show, what visual indicator is a user
> supposed to know that there are additional colors outside of the ones
> currently being displayed.
I'm talking about the scrollbar of the recent colors.
Comment 11 Yousuf Philips (jay) (retired) 2014-10-29 10:20:32 UTC
(In reply to Maxim Monastirsky from comment #10)
> I'm talking about the scrollbar of the recent colors.

Oh okay. Well they still do appear. :D
Comment 12 Maxim Monastirsky 2014-12-01 19:21:12 UTC
Hi Jay,

Can we close this bug?
Comment 13 Yousuf Philips (jay) (retired) 2014-12-01 19:29:11 UTC
Hi Maxim,

Dont see any scrollbar now but can anything be done about expanding the height of the recent color section, as mentioned in comment 7: "Got the latest build and the area isnt being shrunk anymore but the area now is smaller than it used to be".