Download it now!
Bug 84606 - FILEOPEN RTF: MS Word SYMBOL field is not updated
Summary: FILEOPEN RTF: MS Word SYMBOL field is not updated
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.2.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:rtf
Depends on:
Blocks: RTF
  Show dependency treegraph
 
Reported: 2014-10-02 20:32 UTC by Jaroslav Semančík
Modified: 2019-04-03 08:54 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
The RTF document that is opened without brackets (517.99 KB, application/rtf)
2014-10-02 20:32 UTC, Jaroslav Semančík
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jaroslav Semančík 2014-10-02 20:32:39 UTC
Created attachment 107235 [details]
The RTF document that is opened without brackets

The last line of the attached document should be enclosed in brackets. It is opened correctly in MS WordPad and in OpenOffice 3.2.1. But opened in LibreOffice 4.1.2.3 the brackets are missing.
Comment 1 Urmas 2014-10-03 03:09:06 UTC
Confirming. The SYMBOL fields are not updated by LO.
Comment 2 Urmas 2014-10-03 03:21:57 UTC
Apparently it's the norm for Word to save that field with the empty result.
Comment 3 A (Andy) 2015-04-06 19:14:01 UTC
Reproducible with LO 4.4.1.2, Win 8.1
Comment 4 Robinson Tryon (qubit) 2015-12-10 01:08:20 UTC Comment hidden (obsolete)
Comment 5 QA Administrators 2017-03-06 13:48:00 UTC Comment hidden (obsolete)
Comment 6 Daniel Grieger 2017-03-22 07:34:04 UTC
I could reproduce the bug with LO 5.2.6.2, Win 7 x64.
Comment 7 QA Administrators 2018-03-23 03:34:55 UTC Comment hidden (obsolete)
Comment 8 Phil Krylov 2019-04-03 08:54:14 UTC
Cannot reproduce in:

Version: 6.2.0.3
Build ID: 98c6a8a1c6c7b144ce3cc729e34964b47ce25d62
CPU threads: 4; OS: Mac OS X 10.13.6; UI render: GL; VCL: osx; 
Locale: en-US (en_RU.UTF-8); UI-Language: en-US
Calc: threaded