Bug 84623 - FILESAVE; FORMATTING
Summary: FILESAVE; FORMATTING
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.3.2.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium blocker
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-10-03 08:27 UTC by Jānis Eisaks
Modified: 2015-03-01 16:56 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
.ods file illustrating the problem (50.90 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-10-03 08:27 UTC, Jānis Eisaks
Details
clean file (33.00 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-10-03 08:29 UTC, Jānis Eisaks
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jānis Eisaks 2014-10-03 08:27:59 UTC
Created attachment 107252 [details]
.ods file illustrating the problem

for FILESAVE:

if during the work some sheets are deleted and conditional formatting in remaining one cleared up using "clear Direct formatting", the .ods file contains all conditional formattings with bad cells references (I unpacked the .ods and browsed through xml). Why it is not cleaned up? Is it somehow connected with the formatting styles previously used, but no longer needed?

And the second, for FORMATTING - for unknown (or may be due the above one) reasons it is almost impossible to create correct conditional formatting - making conditional formatting for the range after some time one of the cells becomes disconnected with range and gets its own strange form of conditional formatting.

I tried to reproduce it without the result - repeating the actions in the new file everything works correct and file having almost the same info as problematic one is two times smaller than the one produced by removing sheets from it. Additionally - in the new file under Conditional formatting/Manage there is order and piece, while for the second - after some time mess is showing up there even if everything (conditional formatting) is re-done from anew or respective rows are copy/pasted and corrected according to the underlying principle.

P.S. attached problematic file as only one attachment allowed

Janis
Comment 1 Jānis Eisaks 2014-10-03 08:29:16 UTC
Created attachment 107253 [details]
clean file

clean file as described in the initial letter
Comment 2 Owen Genat (retired) 2014-10-05 05:23:09 UTC
(In reply to Jānis Eisaks from comment #0)
> if during the work some sheets are deleted and conditional formatting in
> remaining one cleared up using "clear Direct formatting", the .ods file
> contains all conditional formattings with bad cells references 

I could not reproduce this, but that may be due to not understanding how the sheets were deleted (the problem example only contains a single sheet). This may also be a duplicate of bug 75940.

> And the second, for FORMATTING - for unknown (or may be due the above one)
> reasons it is almost impossible to create correct conditional formatting -
> making conditional formatting for the range after some time one of the cells
> becomes disconnected with range and gets its own strange form of conditional
> formatting.

You may need to more clear indicate the exact steps (menu selections) used to recreate each problem. Status set to NEEDINFO. Please set back to UNCONFIRMED, once the clearer instructions are provided. Thanks.
Comment 3 Jānis Eisaks 2014-10-05 13:31:54 UTC
Hi!

Sheets were deleted by simply selecting them, rightclicked and "Delete"

As for reproduction - I already wrote that I did not succeeded reproducing the problem repeating actions in new file. The operations were simple: 

select the region to be cinditinal-formatted, 
choose "Formula" as a condition
enter the formula, in this case, for example - IF (MATCH(H2;$A$3:$E$3;0) >0).

In the new file i find no glitches while in the original problems showed up during the further formatting
Comment 4 Julien Nabet 2015-03-01 16:56:51 UTC
Janis: about the original file where you can reproduce the problem, with which LO version did you create it?
Indeed, it could be due to a bug of a former LO version.
I mean perhaps the former LO version didn't clean conditions when a sheet was removed.

Anyway, let's put this to WFM.
If you reproduce the problem with a brand new file, don't hesitate to reopen this tracker and give the minimal steps to reproduce this.
Meanwhile, you can clean manually the conditions of the original file.

Also, you might be interested in the fact that 4.3.6 and 4.4.1 LO versions have been released.