Bug 84699 - TOOLBAR: Table drop down 'More' accelerator not working
Summary: TOOLBAR: Table drop down 'More' accelerator not working
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.0.0.alpha0+ Master
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 86678 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-10-06 01:59 UTC by Yousuf Philips (jay) (retired)
Modified: 2017-03-06 15:07 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2014-10-06 01:59:24 UTC
An accelerator was added to the 'More' button at the bottom of the toolbar table button drop down in master, but it doesnt work. This was reported by V Stuart Foote in bug 84551 comment 25 and this is a confirmation of it.

Version: 4.4.0.0.alpha0+
Build ID: ced24ffba2fa1754c466b7944b0ee06d21292706
TinderBox: Linux-rpm_deb-x86@45-TDF, Branch:master, Time: 2014-10-04_21:36:54
Comment 1 Gordo 2015-04-29 18:51:17 UTC
1. The More Options button opens Insert Table dialogue.
2. Ctrl + F12 brings up the Insert Table dialogue.
3. Selecting text and pressing More Options automatically converts text to table with no Convert Text to Table dialogue.
4. Selecting a row of text in a table and pressing More Options opens the Insert Table dialogue, after which the text is lost.
5. Individually multi-selecting text in columns in a row and pressing More Options automatically inserts another table.

All of this happens in previous versions.

Version: 4.4.2.2
Build ID: c4c7d32d0d49397cad38d62472b0bc8acff48dd6

Change to RESOLVED WORKSFORME.
Comment 2 Yousuf Philips (jay) (retired) 2015-04-30 13:55:19 UTC
Hi Gordo,

Unfortunately this hasnt been fixed.

Steps:
1) Click the 'insert table' button in toolbar.
2) Notice the accelerator underline under the 'M' in 'More Options...' button.
3) Press the letter M

Result: Nothing happens.
Comment 3 Maxim Monastirsky 2016-01-25 15:03:08 UTC
*** Bug 86678 has been marked as a duplicate of this bug. ***
Comment 4 Maxim Monastirsky 2016-01-25 15:07:04 UTC
There is a general problem of keyboard handling in floating windows. See Bug 76002.
Comment 5 V Stuart Foote 2016-01-25 15:34:46 UTC
Believe this is more than a GTK2/GTK3 issue as Windows builds are also affected.

On Windows 10 Pro 64-bit en-US (10586) with
Version: 5.2.0.0.alpha0+
Build ID: 49b5eed56c470975927bb7b0328337ab8a76a910
CPU Threads: 8; OS Version: Windows 6.19; UI Render: GL; 
TinderBox: Win-x86@39, Branch:master, Time: 2016-01-24_06:50:26
Locale: en-US (en_US)

STR as in comment 2 continue to reproduce.
Comment 6 QA Administrators 2017-03-06 14:33:28 UTC Comment hidden (obsolete)
Comment 7 V Stuart Foote 2017-03-06 15:07:30 UTC
This seems to have been corrected. STR as in comment 2 no longer produce issue.