Download it now!
Bug 84712 - Please add PDF import in Writer and Impress
Summary: Please add PDF import in Writer and Impress
Status: RESOLVED DUPLICATE of bug 32249
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-10-06 11:29 UTC by yvan
Modified: 2014-10-09 11:21 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
sample PDF file (1.43 MB, application/pdf)
2014-10-09 10:44 UTC, yvan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description yvan 2014-10-06 11:29:40 UTC
Hi,

LibreOffice can import PDF in Draw, and does it well.
Wouldn't it be possible to import PDF the same way in Writer and Impress ?

Thanks very for your answer,
YvanM
Comment 1 sophie 2014-10-06 12:07:17 UTC
Hi, you can do so by producing hybrid pdf, see here how to proceed:
https://wiki.documentfoundation.org/Documentation/HowTo/CreateAHybridPDF
Closing as notabug. Sophie
Comment 2 yvan 2014-10-08 19:12:43 UTC
Thanks for the tip, but after you explanation I think I have to clarify my question :

Probably depending on the type of PDF files, you can sometimes add a PDF into Draw, which uses it like a picture.
The same PDF file can't be imported into Writer nor Impress.

I don't understand why this wouldn't be possible : if one can, the others should also.

I'm sorry I don't have this PDF anymore, so I can't add it to the report.

Regards,
YvanM
Comment 3 yvan 2014-10-09 10:43:21 UTC
I attached a test PDF to the report.
Using Windows 7 and LibreOffice 4.2.6.3, I can right click on the PDF, choose "Open with ... -> LibreOffice Draw".
But if I try to open it with LibreOffice Impress, it will still open it with Draw. Same thing if I try with Writer.

You may want to open PDF with Writer or Impress for many reasons, and there is no simple way to convert the PDF into a picture if this one has more than one page.

Let say for example that you want to add page numbers to the bottom of each pages of the attached document. The simplest would seem to import it into Impress, and to add a footer, but you can't.

You might also want to include a PDF in a Writer document.
Comment 4 yvan 2014-10-09 10:44:03 UTC
Created attachment 107609 [details]
sample PDF file
Comment 5 sophie 2014-10-09 11:21:36 UTC
Hi, I doubt that someone will implement this one day, but anyway it's a duplicate of 32249. Thanks for your report - Sophie

*** This bug has been marked as a duplicate of bug 32249 ***