Download it now!
Bug 84732 - Style in footnote settings is no longer special when saving as doc or docx and text loses style
Summary: Style in footnote settings is no longer special when saving as doc or docx an...
Status: RESOLVED DUPLICATE of bug 90611
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.3.3.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Footnote-Endnote
  Show dependency treegraph
 
Reported: 2014-10-07 00:56 UTC by kasmong
Modified: 2017-06-01 08:48 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description kasmong 2014-10-07 00:56:53 UTC
I have tried to create a custom style for the footnotes in my documents. It looks work fine at first but when I closed the document and reopened it, I found the style of that footnote went back to the default "footnote" style.
Comment 1 Alex Thurgood 2014-10-07 13:12:13 UTC
Please provide test document

Which version of LO?

Does this problem still exist on actual latest version of LO?
Comment 2 hstryeshua 2014-12-29 10:38:45 UTC
I met the same problem in Debian Linux Libreoffice 4.3.3-2, when the document saved as ".doc" format.

if saving as ".odt" format, that problem went away.
Comment 3 Gordo 2015-05-24 15:23:37 UTC
1. New Text Document.
2. In Sidebar → Styles and Formatting, right click → New.
3. On Organiser tab, type “testfootnote” in Name, change Inherit from to None, change Category to “Special Styles”, and OK.
4. Tools → Footnotes/Endnotes, on Footnote tab in Styles change Paragraph to “testfootnote” and OK.
5. In document, type “test”.
6. Place cursor after “test” and Insert → Footnote/Endnote and OK default.
7. Type “test” in footnote.
8. Save document in odt format, close and reopen.
Result:
Paragraph style in footnote is “testfootnote”.  Tools → Footnotes/Endnotes still shows “testfootnote” as the paragraph style.

9. Save document in doc format, close, and reopen.
Result:
Paragraph style in footnote is “testfootnote”.  Tools → Footnotes/Endnotes has reverted to “Footnote”.  In Styles and Formatting, right click → Modify on “testfootnote” shows Category on Organiser tab as “Custom Styles”.  Any new footer created will be in “Footnote” style.

10. Open odt version and save in docx format, close, and reopen.
Result:
Paragraph style in footnote is “Footnote”.  Tools → Footnotes/Endnotes has reverted to “Footnote”.  In Styles and Formatting, right click → Modify on “testfootnote” shows Category on Organiser tab as “Custom Styles”.  Any new footer created will be in “Footnote” style.

Document    Style          Footnote      "testfootnote"
Format      in Text        Settings      Category Style
=======================================================
odt         testfootnote   testfootnote  Special Styles
odt → doc   testfootnote   Footnote      Custom Styles
odt → docx  Footnote       Footnote      Custom Styles

If you create a custom style and set it to Special Styles but don't use it the footnote settings or in the text then it will still revert to Custom Styles when saving as a doc or docx.

Windows Vista 64
Version: 4.4.3.2
Build ID: 88805f81e9fe61362df02b9941de8e38a9b5fd16
Comment 4 Buovjaga 2015-06-08 10:41:39 UTC
Reproduced with steps from comment 3.

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: be8512f99bc9ab18e55aabe01cc0ab1e6baea9e6
TinderBox: Win-x86@39, Branch:master, Time: 2015-06-08_05:58:40
Locale: fi-FI (fi_FI)
Comment 5 QA Administrators 2016-09-20 10:01:40 UTC Comment hidden (obsolete)
Comment 6 Justin L 2017-06-01 08:48:17 UTC
The main problem where the footnote style was not imported was fixed in 5.1 for bug 90611 by https://cgit.freedesktop.org/libreoffice/core/commit/?h=libreoffice-5-3&id=519b34300f73b1e08f6194d6ba49d4fc010cf186

The second issue - where the "footnote and endnotes setting" remembers the style for new footnotes likely is not a part of the .docx spec, and thus is a LO-only capability.

I will close this as a duplicate.  If you can produce an MSWord-produced file/recreation steps that proves that these "footnotes and endnotes settings" exist in .docx format, then you can submit that as a new bug.

*** This bug has been marked as a duplicate of bug 90611 ***