Download it now!
Bug 84850 - EDITING: undo of deleted cells fails to recalculate formula
Summary: EDITING: undo of deleted cells fails to recalculate formula
Status: RESOLVED DUPLICATE of bug 80846
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.3.2.2 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-10-09 20:44 UTC by jdschwa
Modified: 2020-01-30 09:14 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jdschwa 2014-10-09 20:44:57 UTC
Steps to reproduce:
Create a new spreadsheet
A1 = 1
A2 = 2
A3 = 3
A4 = 4
A5 = "=SUM(A1:A4)"
-> A5 is calculated as 10 (correctly)

Select A1:A2 and press delete key
-> A5 is calculated as 7 (correctly)

Use Ctrl-Z to undo.
-> A5 is not recalculated, still says 7 (incorrectly)


Same behaviour with Edit->Delete Contents(all) + Edit->Undo

Tested on Ubuntu 14.04 (4.2.6.3 x86-64) and Windows 7 (4.3.2.2 x86).
Comment 1 m.a.riosv 2014-10-09 22:11:17 UTC
Please if you are not agree, reopen it.

*** This bug has been marked as a duplicate of bug 80846 ***
Comment 2 johnboatroght 2019-05-09 09:42:31 UTC
I am really impressed with that. I like to refer your site to get good topics to read. Almost I have all your posts and this one is the best. This article has clarified the ideas in an interesting way. There are bunches of writers essentially writing websites with no smart thought or point; it is extremely frustrating however the majority of your posts are extremely stunning. Your article is impeccable with a great association. I am working with best essay writing service https://buyessays.us as writer decent articles get great learning.
Comment 3 JaneStewartiuy 2020-01-30 09:14:59 UTC
I had a similar task and now I understand where my mistake was. I had to spend a lot of time searching for an answer, and the solution, as always, was simple. Read more about a similar case here https://www.genuinewriting.com/