Bug 85259 - In fullscreen mode under Mac OSX, application switches Space focus, when attemting to change font setting of text
Summary: In fullscreen mode under Mac OSX, application switches Space focus, when atte...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: x86-64 (AMD64) macOS (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-10-20 21:15 UTC by marcosgdf
Modified: 2017-06-28 08:28 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Video (2.34 MB, video/mov)
2014-10-20 21:15 UTC, marcosgdf
Details

Note You need to log in before you can comment on or make changes to this bug.
Description marcosgdf 2014-10-20 21:15:38 UTC
Created attachment 108140 [details]
Video

Having Writer in fullscreen under Mac OS X 10.10, if I try to change the font size of a text, Mac automatically changes the window so I can't click any font size.

Please take a look at the video to have an idea of what am I talking about.
Comment 1 Alex Thurgood 2014-10-22 08:15:13 UTC
You are using OSX Spaces.
LibreOffice remembers which Space was used to launch it, which is why it switches back.
The problem does not occur if you open LO in a Space of its own.

Yes, this is a problem, but there is a simple workaround.
Comment 2 Alex Thurgood 2014-10-22 08:19:20 UTC
Actually, the problem does occur once in fullscreen mode, irrespective of Space in which LO is started, but switching back to LO window, and reselecting text to change font doesn't repeat the Space switch behaviour
Comment 3 Alex Thurgood 2014-10-22 08:23:58 UTC
The problem is not the UI, but the way the app interacts with OSX environment. It could be the fullscreen switching code, the main NSapp code, or any other number of things.
Comment 4 steve 2015-11-13 11:26:03 UTC
So what's up with this?
OS X 10.11.1
LO Version: 5.1.0.0.alpha1+
Build ID: 4d9f4af05f78e8c5126e011e89a172026021691a
TinderBox: MacOSX-x86_64@49-TDF, Branch:master, Time: 2015-11-06_10:37:14
Locale: de-DE (de.UTF-8)

I have no toolbars when sitching to fullscreen. So there might be another bug now in fullscreen. As is, this bug here is no longer reproducible due to missing toolbars. Anybody up for more input? Should we file another bug?
Comment 5 ace_dent 2016-05-10 11:51:38 UTC
Tested with: Mac OS X El Capitan 10.11.4 (15E2066) with LibreOffice Version: 5.1.2.2
Build ID: d3bf12ecb743fc0d20e0be0c58ca359301eb705f
CPU Threads: 4; OS Version: Mac OS X 10.11.4; UI Render: default.

It seems using the native OSX full-screen behaviour (which now puts the zoomed in window in it's own space), is broken. The central issue is how LO handles Spaces on OSX.

Workaround: Double click on the window's title bar to maximise the window (like 'full screen' in earlier OSX versions).

Related, possibly duplicated, issues ~ 
Missing menu bar: #53282, #76476, #96134, #97402, #97709.
Extra blank screen (black- was grey): #72490, #83378, #96134.
General: #85259, #95362.
Comment 6 QA Administrators 2017-05-22 13:38:27 UTC Comment hidden (obsolete)
Comment 7 Alex Thurgood 2017-06-28 08:26:34 UTC
No repro with

Version: 5.3.4.2
Build ID: f82d347ccc0be322489bf7da61d7e4ad13fe2ff3
Threads CPU : 4; Version de l'OS :Mac OS X 10.12.5; UI Render : par défaut; Moteur de mise en page : nouveau; 
Locale : fr-FR (fr_FR.UTF-8); Calc: group


WFM
Comment 8 Alex Thurgood 2017-06-28 08:28:20 UTC
I have set this to WFM on 10.12.5, but the problem might continue to exist on earlier releases of OSX - if so, please re-open and specify which version of OSX is affected.