Bug Hunting Session
Bug 85283 - FILEOPEN: DOC - Image with white fill color appearing as transparent
Summary: FILEOPEN: DOC - Image with white fill color appearing as transparent
Status: VERIFIED DUPLICATE of bug 101826
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.0.0.alpha0+ Master
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, filter:doc, regression
Depends on:
Blocks: DOC alg_writerframes-regressions
  Show dependency treegraph
 
Reported: 2014-10-21 10:56 UTC by Yousuf Philips (jay) (retired)
Modified: 2019-05-27 12:08 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshot 4.3.x vs 4.4.x (62.01 KB, image/png)
2014-10-21 20:08 UTC, tommy27
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2014-10-21 10:56:03 UTC
Steps:
1) Open https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/873287/+attachment/2540085/+files/problematic%20document.doc
2) Notice that the image under 'SIGNATURE and SEAL' is transparent

The image is supposed to have a white fill color. This is a regression as it works correctly in 4.3 daily.

Version: 4.4.0.0.alpha0+
Build ID: c68642d535f2ebb7f1cd866ad19b1fd018e7cd6d
TinderBox: Linux-rpm_deb-x86@45-TDF, Branch:master, Time: 2014-10-18_23:03:32
Comment 1 tommy27 2014-10-21 20:08:05 UTC
Created attachment 108209 [details]
screenshot 4.3.x vs 4.4.x

confirmed under Win7x64 using LibO 4.4.0.0.alpha0+
Build ID: 3e2bd1e4022e25b77bcc8eba5e02c1adc57008a1
TinderBox: Win-x86@42, Branch:master, Time: 2014-10-16_01:04:13

see attached screenshot
Comment 2 Xisco Faulí 2014-10-22 11:01:43 UTC
9d57c189d74551d2b3770cc81139ea10a62e672f is the first bad commit
commit 9d57c189d74551d2b3770cc81139ea10a62e672f
Author: Bjoern Michaelsen <bjoern.michaelsen@canonical.com>
Date:   Mon May 12 05:19:54 2014 +0000

    source-hash-5b5e62650354788e50b44f32c22b687b2018aba9
    
    commit 5b5e62650354788e50b44f32c22b687b2018aba9
    Author:     Stephan Bergmann <sbergman@redhat.com>
    AuthorDate: Fri Mar 28 15:22:57 2014 +0100
    Commit:     Stephan Bergmann <sbergman@redhat.com>
    CommitDate: Fri Mar 28 15:23:09 2014 +0100
    
        Remove remaining DBG_CTOR etc. remnants from chart2
    
        Change-Id: Iaf07f77b4228d4debb2620625b14ce7dc41e3a98

:100644 100644 9506902c6a27010b21fa60db2785cf8c6a99663b b7caf44d24c70027187d09beb9d1a84d3c2251d5 M	ccache.log
:100644 100644 f131bc060e8059666f8d7f3d448a0a6b8e1df7e4 67e626a238104bf7e45c40698e0e7cc28a4cd98c M	commitmsg
:100644 100644 5db1c1712e795b3ab96960366a53cf84ae3d8bca e6b0918bbb842858c3ad70bde38bc555a88e1bf0 M	make.log
:040000 040000 6dbe8a26ebf7cb34dc34ce783aa54092c2e9e5ed 0be05708421a37d2d8695098f2569749e3ed39de M	opt

# bad: [423a84c4f7068853974887d98442bc2a2d0cc91b] source-hash-c15927f20d4727c3b8de68497b6949e72f9e6e9e
# good: [65fd30f5cb4cdd37995a33420ed8273c0a29bf00] source-hash-d6cde02dbce8c28c6af836e2dc1120f8a6ef9932
git bisect start 'latest' 'oldest'
# good: [e02439a3d6297a1f5334fa558ddec5ef4212c574] source-hash-6b8393474974d2af7a2cb3c47b3d5c081b550bdb
git bisect good e02439a3d6297a1f5334fa558ddec5ef4212c574
# good: [4850941efe43ae800be5c76e1102ab80ac2c085d] source-hash-980a6e552502f02f12c15bfb1c9f8e6269499f4b
git bisect good 4850941efe43ae800be5c76e1102ab80ac2c085d
# good: [a900e72b6357882284c5955bdf939bf14269f5fb] source-hash-dd1050b182260a26a1d0ba6d0ef3a6fecc3f4e07
git bisect good a900e72b6357882284c5955bdf939bf14269f5fb
# skip: [e80660c5a1d812cd04586dae1f22767fc3778c4a] source-hash-07c60c8ee2d1465544a6a39e57bc06b3690b8dfb
git bisect skip e80660c5a1d812cd04586dae1f22767fc3778c4a
# bad: [df9bcaed2faa2a8d11b19f877cdff3a12a887278] source-hash-6ba9692d8bbe3e3c245aca9a7c928e81178d05f1
git bisect bad df9bcaed2faa2a8d11b19f877cdff3a12a887278
# bad: [9d57c189d74551d2b3770cc81139ea10a62e672f] source-hash-5b5e62650354788e50b44f32c22b687b2018aba9
git bisect bad 9d57c189d74551d2b3770cc81139ea10a62e672f
# good: [ce81582766413e76a63c047bfd6227ab12fcd866] source-hash-3d1b1eea83703919c43620f9adef05e5b24c4bed
git bisect good ce81582766413e76a63c047bfd6227ab12fcd866
# good: [87bfccc81c2d8028642492b80505217d7b42a5a8] source-hash-5b4b6b2aad548cdc27ba2aa7d87ff584ec7e97dd
git bisect good 87bfccc81c2d8028642492b80505217d7b42a5a8
# good: [1b831d02ff29aa5763cf33ae75131f98d882201f] source-hash-b7c3e851465638d4416ca8837937946353561088
git bisect good 1b831d02ff29aa5763cf33ae75131f98d882201f
# good: [a6c3773eefb6c6ea2e1a8ad980c258c07a1a8e65] source-hash-4f48dc2f978d36ef9ba08bf828894fa578430fc7
git bisect good a6c3773eefb6c6ea2e1a8ad980c258c07a1a8e65
# good: [d888081586d217a52fd06ce89f146aa4080b4ca9] source-hash-722c82b018327c1f9578ddc533ebbb06080848eb
git bisect good d888081586d217a52fd06ce89f146aa4080b4ca9
# first bad commit: [9d57c189d74551d2b3770cc81139ea10a62e672f] source-hash-5b5e62650354788e50b44f32c22b687b2018aba9
Comment 3 Xisco Faulí 2014-10-22 11:19:13 UTC
I can reproduce this issue with Openoffice 4.0.1 as well so it's possible that it was merged from openoffice code, probably in this commit 6e61ecd09679a66060f932835622821d39e92f01
Comment 4 Matthew Francis 2014-12-27 02:56:33 UTC
It was indeed this commit which changed the behaviour:

commit 6e61ecd09679a66060f932835622821d39e92f01
Author: Armin Le Grand <alg@apache.org>
Date:   Wed Mar 19 16:17:02 2014 +0000

    Merge back branch alg_writerframes to trunk
    
    (cherry picked from commit b635b4fa4e42053d30ab639643d2236a20243f62)
Comment 5 Matthew Francis 2014-12-28 08:44:49 UTC
Adding a Cc: to vmiklos@collabora.co.uk as the committer for the AOO merge mentioned above (6e61ecd09679a66060f932835622821d39e92f01)

Could you possibly take a look at this? Thanks
Comment 6 V Stuart Foote 2015-03-04 16:34:15 UTC

*** This bug has been marked as a duplicate of bug 86578 ***
Comment 7 Michael Stahl (CIB) 2015-04-14 16:00:14 UTC
image set to "no transparency" rendered transparent - not a dupe of 86578

reopening...
Comment 8 Robinson Tryon (qubit) 2015-12-13 11:10:51 UTC Comment hidden (obsolete)
Comment 9 Björn Michaelsen 2016-08-14 18:46:50 UTC
adding filt:doc keyword.
Comment 10 Aron Budea 2016-09-26 08:55:12 UTC
Bisections of bug 94287 and bug 92095 point to the same commit.
Comment 11 Xisco Faulí 2016-09-26 15:03:07 UTC
Adding Cc: to Armin Le Grand
Comment 12 QA Administrators 2017-12-10 16:40:01 UTC Comment hidden (obsolete)
Comment 13 Xisco Faulí 2018-04-03 12:09:46 UTC
*** Bug 116758 has been marked as a duplicate of this bug. ***
Comment 14 Justin L 2019-01-22 18:40:17 UTC
Fixed in LibreOffice 6.3 thanks to bug 101826

*** This bug has been marked as a duplicate of bug 101826 ***
Comment 15 Xisco Faulí 2019-05-27 12:08:04 UTC
Verified in

Version: 6.3.0.0.alpha1+
Build ID: 53325b40b557cc84d8d21c1baa0ef8d3bfc00ab8
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded